aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/freefont-ttf/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-12-21 04:08:09 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-12-21 04:08:09 +0000
commitde91c1f36d78c0c1f1a5abc30188f03d7f0ab7c0 (patch)
tree30a8f9651b395bb45c31b56b00bb91482305f9a6 /x11-fonts/freefont-ttf/Makefile
parent388d529ae575d0e451a46a8c50f68f57b93e756a (diff)
Notes
Diffstat (limited to 'x11-fonts/freefont-ttf/Makefile')
-rw-r--r--x11-fonts/freefont-ttf/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-fonts/freefont-ttf/Makefile b/x11-fonts/freefont-ttf/Makefile
new file mode 100644
index 000000000000..0a95ec1d00e5
--- /dev/null
+++ b/x11-fonts/freefont-ttf/Makefile
@@ -0,0 +1,40 @@
+# Ports collection makefile for: freefont-ttf
+# Date created: 2005-12-17
+# Whom: Andreas Kohn <andreas@syndrom23.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= freefont-ttf
+PORTVERSION= 20051206
+CATEGORIES= x11-fonts
+MASTER_SITES= ${MASTER_SITE_SAVANNAH}
+MASTER_SITE_SUBDIR= freefont
+
+MAINTAINER= andreas@syndrom23.de
+COMMENT= Free UCS Outline Fonts
+
+NO_BUILD= yes
+USE_X_PREFIX= yes
+WRKSRC= ${WRKDIR}/freefont-${PORTVERSION}
+SUB_FILES= pkg-message
+SUB_LIST= INSTALLDIR=${INSTALLDIR}
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+INSTALLDIR= ${PREFIX}/lib/X11/fonts/${PORTNAME}
+
+do-install:
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/AUTHORS ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/CREDITS ${DOCSDIR}
+ ${MKDIR} ${INSTALLDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.ttf ${INSTALLDIR}
+ # Use these pregenerated files instead of using mkfontscale and mkfontdir
+ # to avoid xorg-clients dependency
+ ${INSTALL_DATA} ${FILESDIR}/fonts.scale ${INSTALLDIR}
+ ${INSTALL_DATA} ${FILESDIR}/fonts.dir ${INSTALLDIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+.include <bsd.port.mk>