aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/gentium-plus
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2012-12-15 22:05:36 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2012-12-15 22:05:36 +0000
commit9183a5e52848eb3861b7404edc8aabba6aa32173 (patch)
tree05524b74e770b15ca57a7686409b3611ce09d999 /x11-fonts/gentium-plus
parent3965d0dfd7ee98d9dcde7a39f77bb2b69b9bc035 (diff)
downloadports-9183a5e52848eb3861b7404edc8aabba6aa32173.tar.gz
ports-9183a5e52848eb3861b7404edc8aabba6aa32173.zip
Notes
Diffstat (limited to 'x11-fonts/gentium-plus')
-rw-r--r--x11-fonts/gentium-plus/Makefile60
-rw-r--r--x11-fonts/gentium-plus/distinfo2
-rw-r--r--x11-fonts/gentium-plus/files/pkg-message.in13
-rw-r--r--x11-fonts/gentium-plus/pkg-descr14
4 files changed, 89 insertions, 0 deletions
diff --git a/x11-fonts/gentium-plus/Makefile b/x11-fonts/gentium-plus/Makefile
new file mode 100644
index 000000000000..e171d2e6ad71
--- /dev/null
+++ b/x11-fonts/gentium-plus/Makefile
@@ -0,0 +1,60 @@
+# Created by: Matthew Seaman
+# $FreeBSD$
+
+PORTNAME= GentiumPlus
+PORTVERSION= 1.510
+CATEGORIES= x11-fonts
+MASTER_SITES= http://scripts.sil.org/cms/scripts/render_download.php?format=file&media_id=${MEDIA_ID}&filename=/
+
+MAINTAINER= matthew@FreeBSD.org
+COMMENT= Gentium Plus TrueType font collection
+
+LICENSE= OFL
+LICENSE_NAME= SIL Open Font License (OFL)
+LICENSE_FILE= ${WRKSRC}/OFL.txt
+LICENSE_PERMS= auto-accept
+
+USE_ZIP= yes
+XORG_CAT= font
+
+FONTLIBPATH= lib/X11/fonts
+FONTROOTDIR= ${PREFIX}/${FONTLIBPATH}
+INSTALLS_TTF= yes
+MEDIA_ID= ${DISTNAME}${EXTRACT_SUFX}
+NO_BUILD= yes
+USE_TGZ= yes #prevent bsd.xorg.mk from setting USE_BZIP
+
+PLIST_FILES= ${FONTLIBPATH}/${FONTDIR}/${PORTNAME}-I.ttf \
+ ${FONTLIBPATH}/${FONTDIR}/${PORTNAME}-R.ttf
+
+SUB_LIST= "FONTPATH=${FONTROOTDIR}/${FONTDIR}"
+SUB_FILES= pkg-message
+
+DOCSLIST= FONTLOG.txt GENTIUM-FAQ.txt OFL-FAQ.txt OFL.txt README.txt \
+ documentation/GentiumPlus-features.pdf
+PORTDOCS= ${DOCSLIST:C,^.*/,,}
+
+
+.include <bsd.port.options.mk>
+
+.SILENT:
+
+do-configure:
+ @${DO_NADA}
+
+do-install: install-fonts install-docs
+ ${ECHO_MSG}
+ ${CAT} ${PKGMESSAGE}
+ ${ECHO_MSG}
+
+install-fonts:
+ ${MKDIR} ${FONTROOTDIR}/${FONTDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.ttf ${FONTROOTDIR}/${FONTDIR}
+
+install-docs:
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOCSLIST:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/gentium-plus/distinfo b/x11-fonts/gentium-plus/distinfo
new file mode 100644
index 000000000000..38af0c23ddfd
--- /dev/null
+++ b/x11-fonts/gentium-plus/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xorg/font/GentiumPlus-1.510.zip) = f13622cf85a46c094e671b10152ab2d24913661966f370d340253d7c24c42ccd
+SIZE (xorg/font/GentiumPlus-1.510.zip) = 1992184
diff --git a/x11-fonts/gentium-plus/files/pkg-message.in b/x11-fonts/gentium-plus/files/pkg-message.in
new file mode 100644
index 000000000000..a9dd2d482f32
--- /dev/null
+++ b/x11-fonts/gentium-plus/files/pkg-message.in
@@ -0,0 +1,13 @@
+To use these fonts, add the following line to the "Files" section of
+xorg.conf:
+
+ FontPath "%%FONTPATH%%/"
+
+Users of older versions of X may additionally have to make sure that
+the freetype module is loaded. Check /var/log/Xorg.0.log for error
+messages. If freetype is required, add the following line to the
+"Modules" section of xorg.conf:
+
+ Load "freetype"
+
+
diff --git a/x11-fonts/gentium-plus/pkg-descr b/x11-fonts/gentium-plus/pkg-descr
new file mode 100644
index 000000000000..58a703278f89
--- /dev/null
+++ b/x11-fonts/gentium-plus/pkg-descr
@@ -0,0 +1,14 @@
+Gentium is a typeface family designed to enable the diverse ethnic
+groups around the world who use the Latin, Cyrillic and Greek scripts
+to produce readable, high-quality publications. It supports a wide
+range of Latin- and Cyrillic-based alphabets.
+
+The design is intended to be highly readable, reasonably compact, and
+visually attractive. The Latin letters are designed to naturally
+harmonize with the traditional 26 ones. Diacritics are treated with
+careful thought and attention to their use. Gentium also supports both
+polytonic and monotonic Greek. Gentium Plus now includes more extended
+Latin glyphs (Unicode 5.1), archaic Greek symbols, and full extended
+Cyrillic script support
+
+WWW: http://scripts.sil.org/gentium