aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/gentium-plus
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2013-12-08 22:38:52 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2013-12-08 22:38:52 +0000
commit08f342435d49d94edb5d5780db619af89e7f3038 (patch)
treee40af42880ba18d7a3f8182977ac3694849fcd35 /x11-fonts/gentium-plus
parent8c574fc8e99bf7925d457cd82c1b398343d36dfb (diff)
downloadports-08f342435d49d94edb5d5780db619af89e7f3038.tar.gz
ports-08f342435d49d94edb5d5780db619af89e7f3038.zip
Notes
Diffstat (limited to 'x11-fonts/gentium-plus')
-rw-r--r--x11-fonts/gentium-plus/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/x11-fonts/gentium-plus/Makefile b/x11-fonts/gentium-plus/Makefile
index b7352ef07963..5e3a425f7c71 100644
--- a/x11-fonts/gentium-plus/Makefile
+++ b/x11-fonts/gentium-plus/Makefile
@@ -11,20 +11,22 @@ COMMENT= Gentium Plus TrueType font collection
LICENSE= OFL11
+NO_ARCH= yes
+
USE_ZIP= yes
XORG_CAT= font
FONTLIBPATH= lib/X11/fonts
-FONTROOTDIR= ${STAGEDIR}${PREFIX}/${FONTLIBPATH}
+FONTPATH= ${PREFIX}/${FONTLIBPATH}/${FONTDIR}
INSTALLS_TTF= yes
MEDIA_ID= ${DISTNAME}${EXTRACT_SUFX}
NO_BUILD= yes
USE_TGZ= yes #prevent bsd.xorg.mk from setting USE_BZIP
-PLIST_FILES= ${FONTLIBPATH}/${FONTDIR}/${PORTNAME}-I.ttf \
- ${FONTLIBPATH}/${FONTDIR}/${PORTNAME}-R.ttf
+PLIST_FILES= ${FONTPATH:S,^${PREFIX}/,,}/${PORTNAME}-I.ttf \
+ ${FONTPATH:S,^${PREFIX}/,,}/${PORTNAME}-R.ttf
-SUB_LIST= "FONTPATH=${PREFIX}$FONTLIBPATH}/${FONTDIR}"
+SUB_LIST= "FONTPATH=${FONTPATH}"
SUB_FILES= pkg-message
DOCSLIST= FONTLOG.txt GENTIUM-FAQ.txt OFL-FAQ.txt OFL.txt README.txt \
@@ -41,8 +43,8 @@ do-configure:
do-install: install-fonts install-docs
install-fonts:
- ${MKDIR} ${FONTROOTDIR}/${FONTDIR}
- ${INSTALL_DATA} ${WRKSRC}/*.ttf ${FONTROOTDIR}/${FONTDIR}
+ ${MKDIR} ${STAGEDIR}${FONTPATH}
+ ${INSTALL_DATA} ${WRKSRC}/*.ttf ${STAGEDIR}${FONTPATH}
install-docs:
.if ${PORT_OPTIONS:MDOCS}