aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/linux-f10-fontconfig
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2004-12-31 18:24:10 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2004-12-31 18:24:10 +0000
commit64cf27c85d89298041b8c8dc2fd090181e6d10d8 (patch)
tree11668b893f94453b0262a155d53e6eac8dd4a6f5 /x11-fonts/linux-f10-fontconfig
parent440d8863c8d496b982754e2a71867892213a902b (diff)
downloadports-64cf27c85d89298041b8c8dc2fd090181e6d10d8.tar.gz
ports-64cf27c85d89298041b8c8dc2fd090181e6d10d8.zip
Notes
Diffstat (limited to 'x11-fonts/linux-f10-fontconfig')
-rw-r--r--x11-fonts/linux-f10-fontconfig/Makefile36
-rw-r--r--x11-fonts/linux-f10-fontconfig/files/pkg-install.in9
2 files changed, 39 insertions, 6 deletions
diff --git a/x11-fonts/linux-f10-fontconfig/Makefile b/x11-fonts/linux-f10-fontconfig/Makefile
index 2be72b130f64..8070fa864f77 100644
--- a/x11-fonts/linux-f10-fontconfig/Makefile
+++ b/x11-fonts/linux-f10-fontconfig/Makefile
@@ -7,24 +7,48 @@
PORTNAME= fontconfig
PORTVERSION= 2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-fonts linux
-MAINTAINER= trevor@FreeBSD.org
+MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= Linux/i386 binary of Fontconfig
+EXTRACT_DEPENDS=rpm2cpio:${PORTSDIR}/archivers/rpm
+BUILD_DEPENDS= ${LINUXBASE}/usr/lib/libexpat.so.0:${PORTSDIR}/textproc/linux-expat
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_REINPLACE= yes
BASEVERSION= 9
ONLY_FOR_ARCHS= i386
PLIST= ${WRKDIR}/plist
RPM_SET= fontconfig-2.1-9.i386.rpm
+#PKGINSTALL= ${WRKDIR}/pkg-install
+
+do-extract:
+ @${RM} -rf ${WRKSRC}/tmp
+ @${MKDIR} ${WRKSRC}/tmp
+ @cd ${WRKSRC}/tmp; \
+ rpm2cpio < ${DISTDIR}/${DIST_SUBDIR}/${RPM_SET} | cpio -id;
+
+post-patch:
+ @${REINPLACE_CMD} -i "" -e 's:/usr/share/fonts:${X11BASE}/lib/X11/fonts:g ; \
+ s:/usr/X11R6/lib/X11/fonts/OTF:${X11BASE}/lib/X11/fonts/bitstream-vera:g' \
+ ${WRKSRC}/tmp/etc/fonts/fonts.conf
+
pre-install:
- ${RM} -rf ${WRKSRC}/tmp
- ${MKDIR} ${WRKSRC}/tmp
- cd ${WRKSRC}/tmp; \
- rpm2cpio < ${DISTDIR}/${DIST_SUBDIR}/${RPM_SET} | cpio -id; \
+ @cd ${WRKSRC}/tmp; \
${FIND} * -type f -o -type l > ${PLIST}; \
${FIND} -d * -type d | ${GREP} font | \
${SED} -e 's:^:@dirrm :' >> ${PLIST}
+post-install:
+ @${INSTALL_DATA} ${WRKSRC}/tmp/etc/fonts/fonts.conf ${PREFIX}/etc/fonts/
+ @${BRANDELF} -t Linux ${PREFIX}/usr/bin/fc-cache ${PREFIX}/usr/bin/fc-list
+# @${SED} -e 's|%%PREFIX%%|${PREFIX}|g' < ${FILESDIR}/pkg-install.in \
+# > ${PKGINSTALL}
+#.if !defined(PACKAGE_BUILDING)
+# @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+#.endif
+
.include "../../x11-toolkits/linux-gtk/Makefile"
diff --git a/x11-fonts/linux-f10-fontconfig/files/pkg-install.in b/x11-fonts/linux-f10-fontconfig/files/pkg-install.in
new file mode 100644
index 000000000000..92023842a8c4
--- /dev/null
+++ b/x11-fonts/linux-f10-fontconfig/files/pkg-install.in
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+PATH=%%PREFIX%%/bin:%%PREFIX%%/sbin:%%PREFIX%%/usr/bin:%%PREFIX%%/usr/sbin:%%PREFIX%%/usr/X11R6/bin
+export PATH
+
+if [ "$2" = "POST-INSTALL" ]; then
+ echo "Running fc-cache to build fontconfig cache..."
+ %%PREFIX%%/usr/bin/fc-cache -f -v
+fi