aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/roboto-fonts-ttf
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2012-02-23 09:49:30 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2012-02-23 09:49:30 +0000
commitc78fdb287a68c3b34a52459cc1c2565102121a51 (patch)
tree300c445869dcfd4cc0adca6aa912c16af8d709ab /x11-fonts/roboto-fonts-ttf
parent02cdf14494361161f5207802a34a89be69cb3a1d (diff)
downloadports-c78fdb287a68c3b34a52459cc1c2565102121a51.tar.gz
ports-c78fdb287a68c3b34a52459cc1c2565102121a51.zip
Notes
Diffstat (limited to 'x11-fonts/roboto-fonts-ttf')
-rw-r--r--x11-fonts/roboto-fonts-ttf/Makefile42
-rw-r--r--x11-fonts/roboto-fonts-ttf/distinfo2
-rw-r--r--x11-fonts/roboto-fonts-ttf/files/pkg-message.in8
-rw-r--r--x11-fonts/roboto-fonts-ttf/pkg-descr6
-rw-r--r--x11-fonts/roboto-fonts-ttf/pkg-plist20
5 files changed, 78 insertions, 0 deletions
diff --git a/x11-fonts/roboto-fonts-ttf/Makefile b/x11-fonts/roboto-fonts-ttf/Makefile
new file mode 100644
index 000000000000..05e304cf802e
--- /dev/null
+++ b/x11-fonts/roboto-fonts-ttf/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: roboto-fonts-ttf
+# Date created: 2012-02-23
+# Whom: Winston Weinert <winstonw@lavabit.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= roboto-fonts-ttf
+PORTVERSION= 20111129
+CATEGORIES= x11-fonts
+MASTER_SITES= http://developer.android.com/design/static/download/
+DISTNAME= Roboto_Hinted_${PORTVERSION}
+
+MAINTAINER= winstonw@lavabit.com
+COMMENT= The Roboto typeface family
+
+LICENSE= AL2
+
+BUILD_DEPENDS= mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
+ mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale
+
+USE_ZIP= yes
+
+FONTDIR= lib/X11/fonts/Roboto
+PKGMESSAGE= ${WRKDIR}/pkg-message
+PLIST_SUB= FONTDIR=${FONTDIR}
+SUB_FILES= pkg-message
+SUB_LIST= FONTDIR=${FONTDIR}
+
+do-build:
+ @cd ${WRKSRC}/ && \
+ ${LOCALBASE}/bin/mkfontscale && \
+ ${LOCALBASE}/bin/mkfontdir
+
+do-install:
+ ${MKDIR} ${PREFIX}/${FONTDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} *.ttf fonts.* ${PREFIX}/${FONTDIR}/
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/roboto-fonts-ttf/distinfo b/x11-fonts/roboto-fonts-ttf/distinfo
new file mode 100644
index 000000000000..b6ec66361fc3
--- /dev/null
+++ b/x11-fonts/roboto-fonts-ttf/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Roboto_Hinted_20111129.zip) = 99e865226391af3ac922f476c20d3e82fb471e7cece512486f92438b6d37dfcf
+SIZE (Roboto_Hinted_20111129.zip) = 1505533
diff --git a/x11-fonts/roboto-fonts-ttf/files/pkg-message.in b/x11-fonts/roboto-fonts-ttf/files/pkg-message.in
new file mode 100644
index 000000000000..798a45125c89
--- /dev/null
+++ b/x11-fonts/roboto-fonts-ttf/files/pkg-message.in
@@ -0,0 +1,8 @@
+
+You can start using the fonts by following these instructions:
+
+Add the following line to the "Files" section of your X.org configuration
+file:
+
+ FontPath "%%PREFIX%%/%%FONTDIR%%/"
+
diff --git a/x11-fonts/roboto-fonts-ttf/pkg-descr b/x11-fonts/roboto-fonts-ttf/pkg-descr
new file mode 100644
index 000000000000..f9c91cc5a896
--- /dev/null
+++ b/x11-fonts/roboto-fonts-ttf/pkg-descr
@@ -0,0 +1,6 @@
+Roboto is a sans serif typeface family designed to be modern yet
+emotional. It was introduced as the font used for Android 4.0 "Ice
+Cream Sandwich". This typeface is designed for high resolution mobile
+devices so it includes several typefaces for text in different sizes.
+
+WWW: http://developer.android.com/design/style/typography.html
diff --git a/x11-fonts/roboto-fonts-ttf/pkg-plist b/x11-fonts/roboto-fonts-ttf/pkg-plist
new file mode 100644
index 000000000000..a26e70c45de8
--- /dev/null
+++ b/x11-fonts/roboto-fonts-ttf/pkg-plist
@@ -0,0 +1,20 @@
+%%FONTDIR%%/Roboto-Black.ttf
+%%FONTDIR%%/Roboto-BlackItalic.ttf
+%%FONTDIR%%/Roboto-Bold.ttf
+%%FONTDIR%%/Roboto-BoldCondensed.ttf
+%%FONTDIR%%/Roboto-BoldCondensedItalic.ttf
+%%FONTDIR%%/Roboto-BoldItalic.ttf
+%%FONTDIR%%/Roboto-Condensed.ttf
+%%FONTDIR%%/Roboto-CondensedItalic.ttf
+%%FONTDIR%%/Roboto-Italic.ttf
+%%FONTDIR%%/Roboto-Light.ttf
+%%FONTDIR%%/Roboto-LightItalic.ttf
+%%FONTDIR%%/Roboto-Medium.ttf
+%%FONTDIR%%/Roboto-MediumItalic.ttf
+%%FONTDIR%%/Roboto-Regular.ttf
+%%FONTDIR%%/Roboto-Thin.ttf
+%%FONTDIR%%/Roboto-ThinItalic.ttf
+%%FONTDIR%%/fonts.dir
+%%FONTDIR%%/fonts.scale
+@unexec rm %D/%%FONTDIR%%/fonts.cache-1 2>/dev/null || true
+@dirrm %%FONTDIR%%