aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/stix-fonts
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2009-03-01 12:56:04 +0000
committerThierry Thomas <thierry@FreeBSD.org>2009-03-01 12:56:04 +0000
commit2b561dc7b213a8f31d38fdaa81c55d89f8ae0a9c (patch)
tree38cbea9f1ebb093b19c280735ef84ef98bcfa3a9 /x11-fonts/stix-fonts
parent4d7036c976ce7b87c0085d48a02aa5728b94460a (diff)
downloadports-2b561dc7b213a8f31d38fdaa81c55d89f8ae0a9c.tar.gz
ports-2b561dc7b213a8f31d38fdaa81c55d89f8ae0a9c.zip
Notes
Diffstat (limited to 'x11-fonts/stix-fonts')
-rw-r--r--x11-fonts/stix-fonts/Makefile60
-rw-r--r--x11-fonts/stix-fonts/distinfo3
-rw-r--r--x11-fonts/stix-fonts/files/pkg-message.in10
-rw-r--r--x11-fonts/stix-fonts/pkg-descr12
-rw-r--r--x11-fonts/stix-fonts/pkg-plist37
5 files changed, 122 insertions, 0 deletions
diff --git a/x11-fonts/stix-fonts/Makefile b/x11-fonts/stix-fonts/Makefile
new file mode 100644
index 000000000000..ffd56f42022f
--- /dev/null
+++ b/x11-fonts/stix-fonts/Makefile
@@ -0,0 +1,60 @@
+# New ports collection makefile for: STIX fonts
+# Date created: 28 February 2009
+# Whom: Thierry Thomas <thierry@pompo.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= STIX-fonts
+PORTVERSION= 0.20071031
+CATEGORIES= x11-fonts
+MASTER_SITES= http://www.mozilla.org/projects/mathml/fonts/stix/
+DISTNAME= STIXBeta
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= A comprehensive set of fonts for scientific and engineering purposes
+
+BUILD_DEPENDS= mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale \
+ mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir
+RUN_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig
+
+USE_ZIP= yes
+USE_XORG= x11
+
+NO_WRKSUBDIR= yes
+
+PLIST_SUB= FONTDIR="${FONTDIR:S|${PREFIX}/||}" \
+ FCCACHE='${FCCACHE}'
+
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+SUB_LIST= FONTDIR=${FONTDIR}
+
+FONTNAME= stix
+FONTDIR= ${PREFIX}/lib/X11/fonts/${FONTNAME}
+INSTDAT= License.txt Readme.txt fonts.dir fonts.scale
+
+MKFONTSCL_CMD= ${LOCALBASE}/bin/mkfontscale
+MKFONTDIR_CMD= ${LOCALBASE}/bin/mkfontdir
+FCCACHE= ${LOCALBASE}/bin/fc-cache -f -v
+
+do-build:
+ cd ${WRKSRC} && \
+ ${MKFONTSCL_CMD}
+ ${REINPLACE_CMD} -e 's|-misc-|-stix-|' ${WRKSRC}/fonts.scale
+ cd ${WRKSRC} && \
+ ${MKFONTDIR_CMD}
+
+do-install:
+ ${MKDIR} ${FONTDIR}
+ cd ${WRKSRC} && \
+ ${INSTALL_DATA} ${INSTDAT} *.otf ${FONTDIR}
+
+post-install:
+ @${ECHO_MSG} "===> Running fc-cache"
+ -${FCCACHE} ${FONTDIR}
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/stix-fonts/distinfo b/x11-fonts/stix-fonts/distinfo
new file mode 100644
index 000000000000..2ef20091ff85
--- /dev/null
+++ b/x11-fonts/stix-fonts/distinfo
@@ -0,0 +1,3 @@
+MD5 (STIXBeta.zip) = cf15d327b3c0499107b0a178c74a8915
+SHA256 (STIXBeta.zip) = b6c143a4e7d0c0e7de16072cfdee12ac2a049a677687001535882c9ab59c874d
+SIZE (STIXBeta.zip) = 758513
diff --git a/x11-fonts/stix-fonts/files/pkg-message.in b/x11-fonts/stix-fonts/files/pkg-message.in
new file mode 100644
index 000000000000..9c1334d88b56
--- /dev/null
+++ b/x11-fonts/stix-fonts/files/pkg-message.in
@@ -0,0 +1,10 @@
+You can start using the fonts by following these instructions:
+
+Make sure that the freetype module is loaded. If it is not, add the following
+line to the "Modules" section of your X11 / x.org configuration file:
+
+ Load "freetype"
+
+Add the following line to the "Files" section:
+
+ FontPath "%%FONTDIR%%/"
diff --git a/x11-fonts/stix-fonts/pkg-descr b/x11-fonts/stix-fonts/pkg-descr
new file mode 100644
index 000000000000..5a80eab8d060
--- /dev/null
+++ b/x11-fonts/stix-fonts/pkg-descr
@@ -0,0 +1,12 @@
+The mission of the Scientific and Technical Information Exchange (STIX) font
+creation project is the preparation of a comprehensive set of fonts that serve
+the scientific and engineering community in the process from manuscript creation
+through final publication, both in electronic and print formats. Toward this
+purpose, the STIX fonts will be made available, under royalty-free license, to
+anyone, including publishers, software developers, scientists, students, and the
+general public.
+
+These fonts cover all the symbols in MathML and this port can replace the former
+x11-fonts/mathfonts.
+
+WWW: http://www.stixfonts.org/
diff --git a/x11-fonts/stix-fonts/pkg-plist b/x11-fonts/stix-fonts/pkg-plist
new file mode 100644
index 000000000000..8ee616c15c85
--- /dev/null
+++ b/x11-fonts/stix-fonts/pkg-plist
@@ -0,0 +1,37 @@
+@comment $FreeBSD$
+%%FONTDIR%%/License.txt
+%%FONTDIR%%/Readme.txt
+%%FONTDIR%%/STIXGeneral.otf
+%%FONTDIR%%/STIXGeneralBol.otf
+%%FONTDIR%%/STIXGeneralBolIta.otf
+%%FONTDIR%%/STIXGeneralItalic.otf
+%%FONTDIR%%/STIXIntDis.otf
+%%FONTDIR%%/STIXIntDisBol.otf
+%%FONTDIR%%/STIXIntSma.otf
+%%FONTDIR%%/STIXIntSmaBol.otf
+%%FONTDIR%%/STIXIntUp.otf
+%%FONTDIR%%/STIXIntUpBol.otf
+%%FONTDIR%%/STIXIntUpDis.otf
+%%FONTDIR%%/STIXIntUpDisBol.otf
+%%FONTDIR%%/STIXIntUpSma.otf
+%%FONTDIR%%/STIXIntUpSmaBol.otf
+%%FONTDIR%%/STIXNonUni.otf
+%%FONTDIR%%/STIXNonUniBol.otf
+%%FONTDIR%%/STIXNonUniBolIta.otf
+%%FONTDIR%%/STIXNonUniIta.otf
+%%FONTDIR%%/STIXSiz1Sym.otf
+%%FONTDIR%%/STIXSiz1SymBol.otf
+%%FONTDIR%%/STIXSiz2Sym.otf
+%%FONTDIR%%/STIXSiz2SymBol.otf
+%%FONTDIR%%/STIXSiz3Sym.otf
+%%FONTDIR%%/STIXSiz3SymBol.otf
+%%FONTDIR%%/STIXSiz4Sym.otf
+%%FONTDIR%%/STIXSiz4SymBol.otf
+%%FONTDIR%%/STIXSiz5Sym.otf
+%%FONTDIR%%/STIXVar.otf
+%%FONTDIR%%/STIXVarBol.otf
+%%FONTDIR%%/fonts.dir
+%%FONTDIR%%/fonts.scale
+@exec %%FCCACHE%% %D/%%FONTDIR%% 2>/dev/null || true
+@unexec rm %D/%%FONTDIR%%/fonts.cache-1 2>/dev/null || /usr/bin/true
+@dirrm %%FONTDIR%%