aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/texcm-ttf
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2005-03-06 22:36:38 +0000
committerThierry Thomas <thierry@FreeBSD.org>2005-03-06 22:36:38 +0000
commit5a231781d8c8bd14e4017fe69419181ca3ce1762 (patch)
tree91266a8d30f410e183f184df5032e1552d052746 /x11-fonts/texcm-ttf
parentb28f9c30a6ee2e27883036f866cb6f7c231bbc3b (diff)
downloadports-5a231781d8c8bd14e4017fe69419181ca3ce1762.tar.gz
ports-5a231781d8c8bd14e4017fe69419181ca3ce1762.zip
Notes
Diffstat (limited to 'x11-fonts/texcm-ttf')
-rw-r--r--x11-fonts/texcm-ttf/Makefile53
-rw-r--r--x11-fonts/texcm-ttf/distinfo4
-rw-r--r--x11-fonts/texcm-ttf/files/pkg-message.in13
-rw-r--r--x11-fonts/texcm-ttf/pkg-descr6
-rw-r--r--x11-fonts/texcm-ttf/pkg-plist10
5 files changed, 86 insertions, 0 deletions
diff --git a/x11-fonts/texcm-ttf/Makefile b/x11-fonts/texcm-ttf/Makefile
new file mode 100644
index 000000000000..6f1c86d12bef
--- /dev/null
+++ b/x11-fonts/texcm-ttf/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: texcm-ttf
+# Date created: 6 March 2005
+# Whom: Thierry Thomas <thierry@pompo.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= texcm-ttf
+PORTVERSION= 20010117
+CATEGORIES= x11-fonts
+MASTER_SITES= http://www.mozilla.org/projects/mathml/fonts/bakoma/
+DISTFILES= ${PORTNAME}${EXTRACT_SUFX} license.txt
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+EXTRACT_ONLY= ${PORTNAME}${EXTRACT_SUFX}
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= TeX's Computer Modern Fonts
+
+BUILD_DEPENDS= ttmkfdir:${PORTSDIR}/x11-fonts/ttmkfdir
+
+NO_CDROM= "cannot be sold or distributed with any commercial product"
+
+USE_X_PREFIX= yes
+USE_ZIP= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+SUB_FILES= pkg-message
+SUB_LIST= FONTSDIR="${FONTSDIR}"
+PLIST_SUB= FONTSDIR="${FONTSDIR:S|${PREFIX}/||}"
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+FONTNAME= ${PORTNAME}
+FONTSDIR= ${PREFIX}/lib/X11/fonts/${FONTNAME}
+TTMKFDIR_CMD= ${X11BASE}/bin/ttmkfdir
+
+do-build:
+ ${TTMKFDIR_CMD} -c -f ${FONTNAME} -d ${WRKSRC} | ${CAT} -n | \
+ ${SED} -e 's|^ 1|100000|' | ${SORT} -r | \
+ ${CUT} -c 8- > ${WRKSRC}/fonts.scale
+ ${CP} ${WRKSRC}/fonts.scale ${WRKSRC}/fonts.dir
+
+do-install:
+ ${MKDIR} ${FONTSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/* ${FONTSDIR}
+ ${INSTALL_DATA} ${_DISTDIR}/license.txt ${FONTSDIR} # Required by the license
+
+post-install:
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/texcm-ttf/distinfo b/x11-fonts/texcm-ttf/distinfo
new file mode 100644
index 000000000000..6de982bbedd9
--- /dev/null
+++ b/x11-fonts/texcm-ttf/distinfo
@@ -0,0 +1,4 @@
+MD5 (texcm-ttf-20010117/texcm-ttf.zip) = 7bd39b8860b09c8d5e507dae70484b80
+SIZE (texcm-ttf-20010117/texcm-ttf.zip) = 75261
+MD5 (texcm-ttf-20010117/license.txt) = 3ae8d75400a0078db5d7276366c776b0
+SIZE (texcm-ttf-20010117/license.txt) = 1894
diff --git a/x11-fonts/texcm-ttf/files/pkg-message.in b/x11-fonts/texcm-ttf/files/pkg-message.in
new file mode 100644
index 000000000000..6ab48356c7b5
--- /dev/null
+++ b/x11-fonts/texcm-ttf/files/pkg-message.in
@@ -0,0 +1,13 @@
+You can start using the fonts by following these instructions:
+
+Make sure that the freetype module is loaded. If it is not, add the following
+line to the "Modules" section of your X Windows configuration file:
+
+ Load "freetype"
+
+Add the following line to the "Files" section of X Windows configuration file:
+
+ FontPath "%%FONTSDIR%%/"
+
+Note: your X Windows configuration file is typically /etc/X11/XF86Config
+if you are using XFree86, and /etc/X11/xorg.conf if you are using X.Org.
diff --git a/x11-fonts/texcm-ttf/pkg-descr b/x11-fonts/texcm-ttf/pkg-descr
new file mode 100644
index 000000000000..e97dbec74c18
--- /dev/null
+++ b/x11-fonts/texcm-ttf/pkg-descr
@@ -0,0 +1,6 @@
+TeX's Computer Modern Fonts, to be used for example with a Xft enabled
+version of Mozilla or Firefox, in order to display MathML webpages.
+
+With this port, you should also install the port x11-fonts/mathfonts.
+
+WWW: http://www.mozilla.org/projects/mathml/fonts/
diff --git a/x11-fonts/texcm-ttf/pkg-plist b/x11-fonts/texcm-ttf/pkg-plist
new file mode 100644
index 000000000000..b1e8cb5edc63
--- /dev/null
+++ b/x11-fonts/texcm-ttf/pkg-plist
@@ -0,0 +1,10 @@
+@comment $FreeBSD$
+%%FONTSDIR%%/fonts.dir
+%%FONTSDIR%%/fonts.scale
+%%FONTSDIR%%/cmsy10.ttf
+%%FONTSDIR%%/cmr10.ttf
+%%FONTSDIR%%/cmmi10.ttf
+%%FONTSDIR%%/cmex10.ttf
+%%FONTSDIR%%/license.txt
+@unexec rm %D/%%FONTSDIR%%/fonts.cache-1 2>/dev/null || true
+@dirrm %%FONTSDIR%%