aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/ubuntu-font
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2011-11-09 06:31:11 +0000
committerKevin Lo <kevlo@FreeBSD.org>2011-11-09 06:31:11 +0000
commit4ef8e47094b969996ee13dafa81019a9de7a99a4 (patch)
tree7fce1253a7644168e221fb0ddcd99d42148bc36e /x11-fonts/ubuntu-font
parent2b946ea574a673cf031fb3895eca59f53ff06e47 (diff)
Initial import of ubuntu-font 0.80
The Ubuntu Font Family are a set of matching new libre/open fonts in development during 2010--2011. The development is being funded by Canonical Ltd on behalf the wider Free Software community and the Ubuntu project. The technical font design work and implementation is being undertaken by Dalton Maag.
Notes
Notes: svn path=/head/; revision=285329
Diffstat (limited to 'x11-fonts/ubuntu-font')
-rw-r--r--x11-fonts/ubuntu-font/Makefile44
-rw-r--r--x11-fonts/ubuntu-font/distinfo2
-rw-r--r--x11-fonts/ubuntu-font/pkg-descr11
-rw-r--r--x11-fonts/ubuntu-font/pkg-plist24
4 files changed, 81 insertions, 0 deletions
diff --git a/x11-fonts/ubuntu-font/Makefile b/x11-fonts/ubuntu-font/Makefile
new file mode 100644
index 000000000000..6590a3ff2933
--- /dev/null
+++ b/x11-fonts/ubuntu-font/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: ubuntu-font
+# Date created: 09 November 2011
+# Whom: Kevin Lo <kevlo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ubuntu-font
+PORTVERSION= 0.80
+CATEGORIES= x11-fonts
+MASTER_SITES= http://font.ubuntu.com/download/
+
+DISTNAME= ${PORTNAME}-family-${PORTVERSION}
+
+MAINTAINER= kevloFreeBSD.org
+COMMENT= Ubuntu Font Family
+
+LICENSE= UFL
+LICENSE_FILE= ${WRKSRC}/LICENCE.txt
+LICENSE_NAME= Ubuntu Font License (UFL)
+LICENSE_PERMS= auto-accept
+
+BUILD_DEPENDS= mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
+ mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir
+
+USE_ZIP= yes
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
+FONTSDIR= ${PREFIX}/lib/X11/fonts/${PORTNAME}
+
+do-build:
+ cd ${WRKSRC} && ${LOCALBASE}/bin/mkfontscale
+ cd ${WRKSRC} && ${LOCALBASE}/bin/mkfontdir
+
+do-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} *.txt ${DOCSDIR}
+.endif
+ ${MKDIR} ${FONTSDIR}
+ cd ${WRKSRC} && \
+ ${INSTALL_DATA} fonts.dir fonts.scale *.ttf ${FONTSDIR}
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/ubuntu-font/distinfo b/x11-fonts/ubuntu-font/distinfo
new file mode 100644
index 000000000000..89357b6e17d4
--- /dev/null
+++ b/x11-fonts/ubuntu-font/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ubuntu-font-family-0.80.zip) = 107170099bbc3beae8602b97a5c423525d363106c3c24f787d43e09811298e4c
+SIZE (ubuntu-font-family-0.80.zip) = 2091643
diff --git a/x11-fonts/ubuntu-font/pkg-descr b/x11-fonts/ubuntu-font/pkg-descr
new file mode 100644
index 000000000000..e1cb5b1bbf7f
--- /dev/null
+++ b/x11-fonts/ubuntu-font/pkg-descr
@@ -0,0 +1,11 @@
+The Ubuntu Font Family are a set of matching new libre/open fonts in
+development during 2010--2011. The development is being funded by
+Canonical Ltd on behalf the wider Free Software community and the
+Ubuntu project. The technical font design work and implementation is
+being undertaken by Dalton Maag.
+
+Both the final font Truetype/OpenType files and the design files used
+to produce the font family are distributed under an open licence and
+you are expressly encouraged to experiment, modify, share and improve.
+
+WWW: http://font.ubuntu.com/
diff --git a/x11-fonts/ubuntu-font/pkg-plist b/x11-fonts/ubuntu-font/pkg-plist
new file mode 100644
index 000000000000..67f0c8921613
--- /dev/null
+++ b/x11-fonts/ubuntu-font/pkg-plist
@@ -0,0 +1,24 @@
+lib/X11/fonts/ubuntu-font/Ubuntu-B.ttf
+lib/X11/fonts/ubuntu-font/Ubuntu-BI.ttf
+lib/X11/fonts/ubuntu-font/Ubuntu-C.ttf
+lib/X11/fonts/ubuntu-font/Ubuntu-L.ttf
+lib/X11/fonts/ubuntu-font/Ubuntu-LI.ttf
+lib/X11/fonts/ubuntu-font/Ubuntu-M.ttf
+lib/X11/fonts/ubuntu-font/Ubuntu-MI.ttf
+lib/X11/fonts/ubuntu-font/Ubuntu-R.ttf
+lib/X11/fonts/ubuntu-font/Ubuntu-RI.ttf
+lib/X11/fonts/ubuntu-font/UbuntuMono-B.ttf
+lib/X11/fonts/ubuntu-font/UbuntuMono-BI.ttf
+lib/X11/fonts/ubuntu-font/UbuntuMono-R.ttf
+lib/X11/fonts/ubuntu-font/UbuntuMono-RI.ttf
+lib/X11/fonts/ubuntu-font/fonts.dir
+lib/X11/fonts/ubuntu-font/fonts.scale
+%%PORTDOCS%%%%DOCSDIR%%/CONTRIBUTING.txt
+%%PORTDOCS%%%%DOCSDIR%%/FONTLOG.txt
+%%PORTDOCS%%%%DOCSDIR%%/LICENCE-FAQ.txt
+%%PORTDOCS%%%%DOCSDIR%%/LICENCE.txt
+%%PORTDOCS%%%%DOCSDIR%%/README.txt
+%%PORTDOCS%%%%DOCSDIR%%/TRADEMARKS.txt
+%%PORTDOCS%%%%DOCSDIR%%/copyright.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm lib/X11/fonts/ubuntu-font