aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/xfed
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1994-12-08 10:20:17 +0000
committerSatoshi Asami <asami@FreeBSD.org>1994-12-08 10:20:17 +0000
commite1273eb09a875b706647614007fce79064ccc09a (patch)
tree17c6848b3ebb26093fe3a78ed5ff620bc5ccac1b /x11-fonts/xfed
parente33c9300397c3e2abd92178c8be097df4fef943a (diff)
downloadports-e1273eb09a875b706647614007fce79064ccc09a.tar.gz
ports-e1273eb09a875b706647614007fce79064ccc09a.zip
Notes
Diffstat (limited to 'x11-fonts/xfed')
-rw-r--r--x11-fonts/xfed/Makefile36
-rw-r--r--x11-fonts/xfed/pkg-comment1
-rw-r--r--x11-fonts/xfed/pkg-descr8
-rw-r--r--x11-fonts/xfed/pkg-plist3
4 files changed, 48 insertions, 0 deletions
diff --git a/x11-fonts/xfed/Makefile b/x11-fonts/xfed/Makefile
new file mode 100644
index 000000000000..29c4430bcb35
--- /dev/null
+++ b/x11-fonts/xfed/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: xfed
+# Version required: something old
+# Date created: 7 December 1994
+# Whom: asami
+#
+# $Id:$
+#
+
+DISTNAME= xfed
+TARFILE= xfed.tar.gz
+SOURCEFILES= Epistle,README,Imakefile,xfed.man \
+ icon.bit,next.bit,prev.bit,quit.bit,save.bit \
+ defs.h,main.c,output.c,parse.y,scan.l
+USE_IMAKE= yes
+INSTALL_MANPAGES= yes
+#MASTER_SITES= ftp://me10.lbl.gov/pub/hp_X11R3_tape/source/app/
+SOURCESITE= ftp://ftp.cs.orst.edu/pub/src/X11R4/contrib/clients/xfed/
+#EXTRACT_SUFX= .tar.Z
+
+fetch: pre-fetch
+ @if [ ! -d ${DISTDIR} ]; then mkdir -p ${DISTDIR}; fi
+ @noglob= ; \
+ if [ ! -f ${DISTDIR}/${TARFILE} ]; then \
+ rm -rf ${.CURDIR}/src; \
+ mkdir -p ${.CURDIR}/src/xfed; \
+ echo ">> Fetching files from remote site..."; \
+ for file in ${SOURCEFILES}; do \
+ (cd ${.CURDIR}/src/xfed; \
+ ${NCFTP} ${NCFTPFLAGS} ${SOURCESITE}\{$$file\}); \
+ done; \
+ echo ">> Now creating a tarball ${DISTDIR}/${TARFILE}..."; \
+ tar -C ${.CURDIR}/src -czf ${DISTDIR}/${TARFILE} xfed; \
+ rm -rf ${.CURDIR}/src; \
+ fi
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/xfed/pkg-comment b/x11-fonts/xfed/pkg-comment
new file mode 100644
index 000000000000..c03ea1979662
--- /dev/null
+++ b/x11-fonts/xfed/pkg-comment
@@ -0,0 +1 @@
+xfed, a program that will let you edit X fonts (.bdf files)
diff --git a/x11-fonts/xfed/pkg-descr b/x11-fonts/xfed/pkg-descr
new file mode 100644
index 000000000000..385bfdfb870b
--- /dev/null
+++ b/x11-fonts/xfed/pkg-descr
@@ -0,0 +1,8 @@
+xfed is a program that will let you edit X fonts (.bdf files). It
+originates in the pre-R3 days and has been modified by lots of people
+along the way. This version is taken from
+
+ftp.cs.orst.edu:pub/src/X11R4/contrib/clients/xfed
+
+- Satoshi
+asami@cs.berkeley.edu
diff --git a/x11-fonts/xfed/pkg-plist b/x11-fonts/xfed/pkg-plist
new file mode 100644
index 000000000000..560ed14bd143
--- /dev/null
+++ b/x11-fonts/xfed/pkg-plist
@@ -0,0 +1,3 @@
+@cwd /usr/X11R6
+bin/xfed
+man/man1/xfed.1.gz