aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-10-06 20:56:30 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-10-06 20:56:30 +0000
commit4aa34c64c500840cdcabfd0efafc7193e5bb8a8b (patch)
treefc76d3739d2a43261b6861445f6324ba33eade03 /x11-fonts
parentb11013ef42faf2cd763a68665c9bc3b23ee4fc9b (diff)
downloadports-4aa34c64c500840cdcabfd0efafc7193e5bb8a8b.tar.gz
ports-4aa34c64c500840cdcabfd0efafc7193e5bb8a8b.zip
Notes
Diffstat (limited to 'x11-fonts')
-rw-r--r--x11-fonts/Makefile1
-rw-r--r--x11-fonts/fontconfig/Makefile35
-rw-r--r--x11-fonts/fontconfig/distinfo1
-rw-r--r--x11-fonts/fontconfig/files/patch-config_Makedefs.in11
-rw-r--r--x11-fonts/fontconfig/files/patch-fonts.conf.in10
-rw-r--r--x11-fonts/fontconfig/files/patch-src_Makefile.in13
-rw-r--r--x11-fonts/fontconfig/pkg-comment1
-rw-r--r--x11-fonts/fontconfig/pkg-descr17
-rw-r--r--x11-fonts/fontconfig/pkg-plist13
9 files changed, 102 insertions, 0 deletions
diff --git a/x11-fonts/Makefile b/x11-fonts/Makefile
index b57eac4e906c..464ed1a08d00 100644
--- a/x11-fonts/Makefile
+++ b/x11-fonts/Makefile
@@ -12,6 +12,7 @@
SUBDIR += bdfresize
SUBDIR += bitmap-fonts
SUBDIR += etlfonts
+ SUBDIR += fontconfig
SUBDIR += freefonts
SUBDIR += geminifonts
SUBDIR += getbdf
diff --git a/x11-fonts/fontconfig/Makefile b/x11-fonts/fontconfig/Makefile
new file mode 100644
index 000000000000..42c2c3726096
--- /dev/null
+++ b/x11-fonts/fontconfig/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: fontconfig
+# Date created: 06 October 2002
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fontconfig
+PORTVERSION= 2.0
+CATEGORIES= x11-fonts
+MASTER_SITES= http://fontconfig.org/release/
+DISTNAME= fcpackage.${PORTVERSION:S/./_/}
+
+MAINTAINER= gnome@FreeBSD.org
+
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
+LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
+ expat.4:${PORTSDIR}/textproc/expat2
+RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+CONFIGURE_ARGS= --with-confdir=${PREFIX}/etc/fonts \
+ --with-expat=${LOCALBASE} \
+ --with-default-fonts=${X11BASE}/lib/fonts
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+WRKSRC= ${WRKDIR}/${DISTNAME}/fontconfig
+
+pre-patch:
+ @${REINPLACE_CMD} -e 's|[(]LIBDIR[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/fontconfig/distinfo b/x11-fonts/fontconfig/distinfo
new file mode 100644
index 000000000000..4666acdee46a
--- /dev/null
+++ b/x11-fonts/fontconfig/distinfo
@@ -0,0 +1 @@
+MD5 (fcpackage.2_0.tar.gz) = 5ef5c58e501b0cb873ee2b2a04ed74e3
diff --git a/x11-fonts/fontconfig/files/patch-config_Makedefs.in b/x11-fonts/fontconfig/files/patch-config_Makedefs.in
new file mode 100644
index 000000000000..15be7083d300
--- /dev/null
+++ b/x11-fonts/fontconfig/files/patch-config_Makedefs.in
@@ -0,0 +1,11 @@
+--- config/Makedefs.in.orig Sun Oct 6 16:43:39 2002
++++ config/Makedefs.in Sun Oct 6 16:43:47 2002
+@@ -65,7 +65,7 @@
+ CFLAGS=$(CDEBUGFLAGS) @DEFS@ $(FCPATH_DEF) $(INCLUDES)
+
+ LIBBASE=libfontconfig.so
+-LIBFILE=$(LIBBASE).@PACKAGE_MAJOR@.@PACKAGE_MINOR@
++LIBFILE=$(LIBBASE).@PACKAGE_MAJOR@
+ LIBMAJOR=$(LIBBASE).@PACKAGE_MAJOR@
+
+ LIBFONTCONFIG=-L$(SRCDIR) -lfontconfig
diff --git a/x11-fonts/fontconfig/files/patch-fonts.conf.in b/x11-fonts/fontconfig/files/patch-fonts.conf.in
new file mode 100644
index 000000000000..caf5560b98bc
--- /dev/null
+++ b/x11-fonts/fontconfig/files/patch-fonts.conf.in
@@ -0,0 +1,10 @@
+--- fonts.conf.in.orig Sun Oct 6 16:37:34 2002
++++ fonts.conf.in Sun Oct 6 16:37:41 2002
+@@ -21,7 +21,6 @@
+ -->
+
+ <dir>/usr/X11R6/lib/X11/fonts</dir>
+- <dir>/usr/share/fonts</dir>
+ <dir>~/.fonts</dir>
+
+ <!-- FONTPATH_END -->
diff --git a/x11-fonts/fontconfig/files/patch-src_Makefile.in b/x11-fonts/fontconfig/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..16e62724d1b8
--- /dev/null
+++ b/x11-fonts/fontconfig/files/patch-src_Makefile.in
@@ -0,0 +1,13 @@
+--- src/Makefile.in.orig Sun Oct 6 16:42:26 2002
++++ src/Makefile.in Sun Oct 6 16:42:42 2002
+@@ -80,10 +80,6 @@
+ rm -f $@
+ $(MKSHLIB) $(OBJS) $(LIBS)
+
+-$(LIBMAJOR): $(LIBFILE)
+- rm -f $@
+- $(LN_S) $(LIBFILE) $(LIBMAJOR)
+-
+ $(LIBBASE): $(LIBMAJOR)
+ rm -f $@
+ $(LN_S) $(LIBMAJOR) $(LIBBASE)
diff --git a/x11-fonts/fontconfig/pkg-comment b/x11-fonts/fontconfig/pkg-comment
new file mode 100644
index 000000000000..dc1388ee58d8
--- /dev/null
+++ b/x11-fonts/fontconfig/pkg-comment
@@ -0,0 +1 @@
+An XML-based font configuration API for X Windows
diff --git a/x11-fonts/fontconfig/pkg-descr b/x11-fonts/fontconfig/pkg-descr
new file mode 100644
index 000000000000..4ce0de27a216
--- /dev/null
+++ b/x11-fonts/fontconfig/pkg-descr
@@ -0,0 +1,17 @@
+Fontconfig does the following:
+
+ * discover new fonts when installed automatically, removing a common source of configuration problems.
+ * perform font name substitution, so that appropriate alternative fonts can
+ be selected if fonts are missing.
+ * identify the set of fonts required to completely cover a set of languages.
+ * have GUI configuration tools built as it uses an XML-based configuration
+ file (though with autodiscovery, we believe this need is minimized).
+ * efficiently and quickly find the fonts you need among the set of fonts
+ you have installed, even if you have installed thousands of fonts, while
+ minimzing memory usage.
+ * be used in concert with the X Render Extension and FreeType to implement
+ high quality, anti-aliased and subpixel rendered text on a display.
+
+-- keithp
+
+WWW: http://fontconfig.org/
diff --git a/x11-fonts/fontconfig/pkg-plist b/x11-fonts/fontconfig/pkg-plist
new file mode 100644
index 000000000000..fb4c921f5350
--- /dev/null
+++ b/x11-fonts/fontconfig/pkg-plist
@@ -0,0 +1,13 @@
+bin/fc-cache
+bin/fc-list
+bin/fontconfig-config
+etc/fonts/fonts.conf
+etc/fonts/fonts.dtd
+include/fontconfig/fcfreetype.h
+include/fontconfig/fcprivate.h
+include/fontconfig/fontconfig.h
+lib/libfontconfig.so
+lib/libfontconfig.so.1
+libdata/pkgconfig/fontconfig.pc
+@dirrm include/fontconfig
+@dirrm etc/fonts