aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2008-05-19 14:37:31 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2008-05-19 14:37:31 +0000
commit3e31029d23eaf6781bdafe43c406aeb8060536b5 (patch)
tree4637ad49eceb2e5f6f0cfb1fb0178c4553fe4735 /x11-fonts
parenta4fe96a89d19f3829a5c0bd130c8e43dd15938b2 (diff)
downloadports-3e31029d23eaf6781bdafe43c406aeb8060536b5.tar.gz
ports-3e31029d23eaf6781bdafe43c406aeb8060536b5.zip
Notes
Diffstat (limited to 'x11-fonts')
-rw-r--r--x11-fonts/Makefile1
-rw-r--r--x11-fonts/tmu/Makefile42
-rw-r--r--x11-fonts/tmu/distinfo3
-rw-r--r--x11-fonts/tmu/pkg-descr19
-rw-r--r--x11-fonts/tmu/pkg-plist7
5 files changed, 72 insertions, 0 deletions
diff --git a/x11-fonts/Makefile b/x11-fonts/Makefile
index df534dd46be7..3fbd52bae3e9 100644
--- a/x11-fonts/Makefile
+++ b/x11-fonts/Makefile
@@ -116,6 +116,7 @@
SUBDIR += terminus-font
SUBDIR += texcm-ttf
SUBDIR += tkfont
+ SUBDIR += tmu
SUBDIR += tolkien-ttf
SUBDIR += ttmkfdir
SUBDIR += tv-fonts
diff --git a/x11-fonts/tmu/Makefile b/x11-fonts/tmu/Makefile
new file mode 100644
index 000000000000..878b84ed8e7b
--- /dev/null
+++ b/x11-fonts/tmu/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: TibetanMachineUni
+# Date created: 19 May 2008
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tmu
+DISTVERSION= 1.901b
+CATEGORIES= x11-fonts
+MASTER_SITES= CENKES
+# http://www.thdl.org/tools/fonts/index.html
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Free Tibetan Machine Uni font
+
+BUILD_DEPENDS= mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale \
+ mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
+ fc-cache:${PORTSDIR}/x11-fonts/fontconfig
+
+USE_BZIP2= yes
+PLIST_SUB= FONTSDIR="${FONTSDIR:S|${PREFIX}/||}"
+FONTNAME= ${PORTNAME}
+FONTSDIR?= ${PREFIX}/lib/X11/fonts/${FONTNAME}
+
+MKFONTSCL_CMD= ${LOCALBASE}/bin/mkfontscale
+MKFONTDIR_CMD= ${LOCALBASE}/bin/mkfontdir
+FCCACHE_CMD= ${LOCALBASE}/bin/fc-cache -f -v
+
+post-extract:
+ @cd ${WRKSRC}/&&${MV} TibMachUni-${DISTVERSION}.ttf tmu.ttf
+
+do-build:
+ @cd ${WRKSRC}/ && ${MKFONTSCL_CMD} && ${MKFONTDIR_CMD}
+
+do-install:
+ @${INSTALL} -d ${FONTSDIR}/
+ @${INSTALL_DATA} ${WRKSRC}/[ft]* ${FONTSDIR}/
+ @${ECHO_MSG} "===> Running fc-cache"
+ -${FCCACHE_CMD} ${FONTSDIR}
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/tmu/distinfo b/x11-fonts/tmu/distinfo
new file mode 100644
index 000000000000..6ab9b2180651
--- /dev/null
+++ b/x11-fonts/tmu/distinfo
@@ -0,0 +1,3 @@
+MD5 (tmu-1.901b.tar.bz2) = b3f1ff6564c13e01ed3ee376cd5376ee
+SHA256 (tmu-1.901b.tar.bz2) = 0b0ea2451dd5d81e3fe7bb816567fbffa52bd17777db92cd46b0c495e11a266b
+SIZE (tmu-1.901b.tar.bz2) = 1167327
diff --git a/x11-fonts/tmu/pkg-descr b/x11-fonts/tmu/pkg-descr
new file mode 100644
index 000000000000..fe54fdc215f5
--- /dev/null
+++ b/x11-fonts/tmu/pkg-descr
@@ -0,0 +1,19 @@
+The Tibetan & Himalayan Digital Library releases the Unicode character
+based Tibetan Machine Uni OpenType font for writing Tibetan, Dzongkha
+and Ladakhi in dbu-can script with full support for the Sanskrit
+combinations found in chos skad texts.
+
+This font is based on the Tibetan Machine font originally designed and
+developed by Tony Duff of the Tibetan Computer Company over many
+years, the rights of which were purchased from him by the Trace
+Foundation in order to make it freely available under the terms of the
+Gnu General Public License.
+
+OpenType tables and more than 2,000 additional glyphs were added to
+the original font by Nathaniel Garson and Christopher Fynn under the
+auspices of THDL. This new OpenType version of the font contains
+almost 4,000 glyphs and can generate over 20,000 different
+combinations.
+
+WWW: http://www.thdl.org/tools/fonts/
+Author: Tony Duff
diff --git a/x11-fonts/tmu/pkg-plist b/x11-fonts/tmu/pkg-plist
new file mode 100644
index 000000000000..138dcf3ea953
--- /dev/null
+++ b/x11-fonts/tmu/pkg-plist
@@ -0,0 +1,7 @@
+%%FONTSDIR%%/fonts.dir
+%%FONTSDIR%%/fonts.scale
+%%FONTSDIR%%/tmu.ttf
+@exec %%LOCALBASE%%/bin/fc-cache -f -v %D/%%FONTSDIR%% || true
+@unexec rm -f %D/%%FONTSDIR%%/fonts.cache-1 2>/dev/null || true
+@unexec %%LOCALBASE%%/bin/fc-cache -f -v %D/%%FONTSDIR%% || true
+@dirrm %%FONTSDIR%%