aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2017-02-15 13:19:45 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2017-02-15 13:19:45 +0000
commitfea4377ff8f111010308ae076394440cdf7201d8 (patch)
treec9d4ef65e73da48cc61f6afb1b3bc07615e08db9 /x11-fonts
parenta32dc532c6426b7d6d8ec1dba49f815c02cfd61d (diff)
downloadports-fea4377ff8f111010308ae076394440cdf7201d8.tar.gz
ports-fea4377ff8f111010308ae076394440cdf7201d8.zip
Notes
Diffstat (limited to 'x11-fonts')
-rw-r--r--x11-fonts/font-manager/Makefile21
-rw-r--r--x11-fonts/font-manager/distinfo5
-rw-r--r--x11-fonts/font-manager/files/patch-Makefile.in4
-rw-r--r--x11-fonts/font-manager/files/patch-src-constants.py.in4
-rw-r--r--x11-fonts/font-manager/files/patch-src_lib_fm-fontutils.c4
-rw-r--r--x11-fonts/font-manager/pkg-descr14
6 files changed, 30 insertions, 22 deletions
diff --git a/x11-fonts/font-manager/Makefile b/x11-fonts/font-manager/Makefile
index 1e41dd1b5409..1b8c2a09ba8f 100644
--- a/x11-fonts/font-manager/Makefile
+++ b/x11-fonts/font-manager/Makefile
@@ -5,20 +5,23 @@ PORTNAME= font-manager
PORTVERSION= 0.5.7
PORTREVISION= 6
CATEGORIES= x11-fonts gnome
-MASTER_SITES= GOOGLE_CODE
-MAINTAINER= lichray@gmail.com
+MAINTAINER= portmaster@bsdforge.com
COMMENT= Font management application for the GNOME desktop
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN= Unfetchable (google code has gone away)
-
-LIB_DEPENDS= libsqlite3.so:databases/sqlite3
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libsqlite3.so:databases/sqlite3
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/libxml2.py:textproc/py-libxml2 \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3
+USE_GITHUB= yes
+GH_ACCOUNT= FontManager
+GH_PROJECT= master
+
USE_GNOME= pygtk2
GNU_CONFIGURE= yes
USES= gmake pkgconfig python:2 tar:bzip2
@@ -27,9 +30,13 @@ PORTDATA= *
OPTIONS_DEFINE= NLS
-OPTIONS_SUB= yes
+OPTIONS_SUB= yes
-NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext
+NLS_USES_OFF= gettext-runtime
+
+pre-configure:
+ @${CHMOD} 0544 ${WRKSRC}/configure ${WRKSRC}/po/pogen.sh
.include <bsd.port.mk>
diff --git a/x11-fonts/font-manager/distinfo b/x11-fonts/font-manager/distinfo
index 6bd5aad86ca9..407693f20ece 100644
--- a/x11-fonts/font-manager/distinfo
+++ b/x11-fonts/font-manager/distinfo
@@ -1,2 +1,3 @@
-SHA256 (font-manager-0.5.7.tar.bz2) = 794a3d98e50ab7e515d8216ad42300c13b0ec13ab972bdf71c3657de4b306228
-SIZE (font-manager-0.5.7.tar.bz2) = 771460
+TIMESTAMP = 1487073947
+SHA256 (FontManager-master-0.5.7_GH0.tar.gz) = a95f65ef2df03a1dd8989e063a717768d6066f8e86ac9f9550f95f234b29adc3
+SIZE (FontManager-master-0.5.7_GH0.tar.gz) = 818484
diff --git a/x11-fonts/font-manager/files/patch-Makefile.in b/x11-fonts/font-manager/files/patch-Makefile.in
index 8429ad89b900..e1cc85e9dec5 100644
--- a/x11-fonts/font-manager/files/patch-Makefile.in
+++ b/x11-fonts/font-manager/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in.orig 2010-12-20 19:01:26.000000000 -0600
-+++ Makefile.in 2011-03-26 00:38:02.410403185 -0500
+--- Makefile.in.orig 2015-05-29 06:45:34 UTC
++++ Makefile.in
@@ -552,8 +552,9 @@ compile_po:
install_mo:
for mo in `$(FIND) po -name $(PACKAGE_NAME).mo`; \
diff --git a/x11-fonts/font-manager/files/patch-src-constants.py.in b/x11-fonts/font-manager/files/patch-src-constants.py.in
index 161f542cc6fa..739c94e00fae 100644
--- a/x11-fonts/font-manager/files/patch-src-constants.py.in
+++ b/x11-fonts/font-manager/files/patch-src-constants.py.in
@@ -1,5 +1,5 @@
---- src/constants.py.in.orig 2011-09-25 22:42:09.742559932 -0500
-+++ src/constants.py.in 2011-09-25 22:43:06.091693624 -0500
+--- src/constants.py.in.orig 2015-05-29 06:45:34 UTC
++++ src/constants.py.in
@@ -51,7 +51,7 @@ import gettext
try:
locale.setlocale(locale.LC_ALL, '')
diff --git a/x11-fonts/font-manager/files/patch-src_lib_fm-fontutils.c b/x11-fonts/font-manager/files/patch-src_lib_fm-fontutils.c
index 71612ca413df..c72ce43bf495 100644
--- a/x11-fonts/font-manager/files/patch-src_lib_fm-fontutils.c
+++ b/x11-fonts/font-manager/files/patch-src_lib_fm-fontutils.c
@@ -1,5 +1,5 @@
---- src/lib/fm-fontutils.c~ 2010-12-23 21:48:30.000000000 -0600
-+++ src/lib/fm-fontutils.c 2012-05-30 17:04:54.303401685 -0500
+--- src/lib/fm-fontutils.c.orig 2015-05-29 06:45:34 UTC
++++ src/lib/fm-fontutils.c
@@ -24,6 +24,7 @@
#include <glib.h>
#include <glib/gprintf.h>
diff --git a/x11-fonts/font-manager/pkg-descr b/x11-fonts/font-manager/pkg-descr
index 02ffd790aad1..c2652fb73053 100644
--- a/x11-fonts/font-manager/pkg-descr
+++ b/x11-fonts/font-manager/pkg-descr
@@ -1,9 +1,9 @@
-Font Manager is not intended to be a professional-grade font management
-solution, but rather a simple application suitable for the needs of most
-desktop users.
+Font Manager is not intended to be a professional-grade
+font management solution, but rather a simple application
+suitable for the needs of most desktop users.
-Although designed with the GNOME desktop environment in mind, it should
-work well with most major desktop environments such as Xfce, Enlightenment,
-and even KDE.
+Although designed with the GNOME desktop environment in mind,
+it should work well with most major desktop environments such
+as Xfce, Enlightenment, and even KDE.
-WWW: https://code.google.com/p/font-manager/
+WWW: http://fontmanager.github.io/