aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-07-14 05:01:52 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-07-14 05:01:52 +0000
commit71fda6e697435f898693916d7185fc89f6126b67 (patch)
treed2faac7bc4f15bdb435e1dc83d5c57b573d01375 /x11-fonts
parentc6a9d2cb37d6a1915f48480768b70b172a24fb84 (diff)
downloadports-71fda6e697435f898693916d7185fc89f6126b67.tar.gz
ports-71fda6e697435f898693916d7185fc89f6126b67.zip
Notes
Diffstat (limited to 'x11-fonts')
-rw-r--r--x11-fonts/libXft/Makefile7
-rw-r--r--x11-fonts/libXft/distinfo6
-rw-r--r--x11-fonts/libXft/files/patch-ltmain.sh51
-rw-r--r--x11-fonts/libXft/files/patch-xftfreetype.c12
4 files changed, 5 insertions, 71 deletions
diff --git a/x11-fonts/libXft/Makefile b/x11-fonts/libXft/Makefile
index 9c83072f3137..73ebfd176669 100644
--- a/x11-fonts/libXft/Makefile
+++ b/x11-fonts/libXft/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= libXft
-PORTVERSION= 2.1.6
-PORTREVISION= 1
+PORTVERSION= 2.1.7
CATEGORIES= x11-fonts
-MASTER_SITES= http://freedesktop.org/~ajax/xlibs-release/
+MASTER_SITES= http://xlibs.freedesktop.org/release/
MAINTAINER= gnome@FreeBSD.org
COMMENT= A client-sided font API for X applications
@@ -21,7 +20,7 @@ USE_GMAKE= yes
USE_X_PREFIX= yes
INSTALLS_SHLIB= yes
USE_GNOME= gnomehack gnometarget
-GNU_CONFIGURE= yes
+USE_LIBTOOL_VER=15
CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
LDFLAGS="-L${X11BASE}/lib"
diff --git a/x11-fonts/libXft/distinfo b/x11-fonts/libXft/distinfo
index 1c7aa7ef318b..588f2141eaeb 100644
--- a/x11-fonts/libXft/distinfo
+++ b/x11-fonts/libXft/distinfo
@@ -1,4 +1,2 @@
-MD5 (libXft-2.1.6.tar.bz2) = ba10c9c3f4758f304f04f8d48e2f81a4
-SIZE (libXft-2.1.6.tar.bz2) = 234117
-MD5 (cjk-patch-libXft-20041115.diff.gz) = a642c3e2cd08ac738a1be0aa4ba4e38d
-SIZE (cjk-patch-libXft-20041115.diff.gz) = 3261
+MD5 (libXft-2.1.7.tar.bz2) = 3e311b4095283d59488b95c8bd772521
+SIZE (libXft-2.1.7.tar.bz2) = 237056
diff --git a/x11-fonts/libXft/files/patch-ltmain.sh b/x11-fonts/libXft/files/patch-ltmain.sh
deleted file mode 100644
index dc508a25a122..000000000000
--- a/x11-fonts/libXft/files/patch-ltmain.sh
+++ /dev/null
@@ -1,51 +0,0 @@
---- ltmain.sh.orig Sat Apr 19 21:11:30 2003
-+++ ltmain.sh Wed May 14 16:05:31 2003
-@@ -1277,7 +1277,7 @@
- esac
- elif test "X$arg" = "X-lc_r"; then
- case $host in
-- *-*-openbsd* | *-*-freebsd*)
-+ *-*-openbsd* | *-*-freebsd4*)
- # Do not include libc_r directly, use -pthread flag.
- continue
- ;;
-@@ -1287,8 +1287,16 @@
- continue
- ;;
-
-+ -pthread)
-+ compile_command="$compile_command -pthread"
-+ finalize_command="$finalize_command -pthread"
-+ compiler_flags="$compiler_flags -pthread"
-+ continue
-+ ;;
-+
- -module)
- module=yes
-+ build_old_libs=no
- continue
- ;;
-
-@@ -2997,6 +3005,9 @@
- # problems, so we reset it completely
- verstring=
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- verstring="0.0"
- ;;
-@@ -5425,10 +5436,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/x11-fonts/libXft/files/patch-xftfreetype.c b/x11-fonts/libXft/files/patch-xftfreetype.c
deleted file mode 100644
index 2868f3d52a1f..000000000000
--- a/x11-fonts/libXft/files/patch-xftfreetype.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- xftfreetype.c.orig Sun Mar 27 18:51:12 2005
-+++ xftfreetype.c Sun Mar 27 18:51:53 2005
-@@ -289,7 +289,8 @@ _XftReleaseFile (XftFtFile *f)
- if (f->face)
- FT_Done_Face (f->face);
- }
-- XftMemFree (XFT_MEM_FILE, sizeof (XftFtFile) + strlen (f->file) + 1);
-+ XftMemFree (XFT_MEM_FILE,
-+ sizeof (XftFtFile) + (f->file ? strlen (f->file) + 1 : 0));
- free (f);
- }
-