aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2011-03-30 00:20:37 +0000
committerWen Heping <wen@FreeBSD.org>2011-03-30 00:20:37 +0000
commit548f209bcbfb782179e0d8b1fef4132a4da00072 (patch)
treee33c469367e32c101b81ee7e0ffe13cbcc720102 /x11-fonts
parent7820ddae48bc4975264ee6f9a039e2343a435b35 (diff)
downloadports-548f209bcbfb782179e0d8b1fef4132a4da00072.tar.gz
ports-548f209bcbfb782179e0d8b1fef4132a4da00072.zip
Notes
Diffstat (limited to 'x11-fonts')
-rw-r--r--x11-fonts/Makefile1
-rw-r--r--x11-fonts/font-manager/Makefile46
-rw-r--r--x11-fonts/font-manager/distinfo2
-rw-r--r--x11-fonts/font-manager/files/patch-Makefile.in33
-rw-r--r--x11-fonts/font-manager/pkg-descr9
-rw-r--r--x11-fonts/font-manager/pkg-plist136
6 files changed, 227 insertions, 0 deletions
diff --git a/x11-fonts/Makefile b/x11-fonts/Makefile
index 27c92f43be26..5d6b4aa2a123 100644
--- a/x11-fonts/Makefile
+++ b/x11-fonts/Makefile
@@ -53,6 +53,7 @@
SUBDIR += font-ibm-type1
SUBDIR += font-isas-misc
SUBDIR += font-jis-misc
+ SUBDIR += font-manager
SUBDIR += font-micro-misc
SUBDIR += font-misc-cyrillic
SUBDIR += font-misc-ethiopic
diff --git a/x11-fonts/font-manager/Makefile b/x11-fonts/font-manager/Makefile
new file mode 100644
index 000000000000..7fa58c255476
--- /dev/null
+++ b/x11-fonts/font-manager/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: font-manager
+# Date created: 2011-03-25
+# Whom: Zhihao Yuan <lichray@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= font-manager
+PORTVERSION= 0.5.7
+CATEGORIES= x11-fonts gnome
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= lichray@gmail.com
+COMMENT= A font management application for the GNOME desktop
+
+LIB_DEPENDS= sqlite3:${PORTSDIR}/databases/sqlite3
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/libxml2.py:${PORTSDIR}/textproc/py-libxml2
+
+USE_BZIP2= yes
+USE_PYTHON= 2.6-2.7
+USE_GNOME= pygtk2
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+MAKE_JOBS_SAFE= yes
+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+OPTIONS= REPORTLAB "Enable font-sampler (PDF sample sheet)" off \
+ NLS "Enable Native Language Support" on
+
+.include <bsd.port.options.mk>
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+CONFIGURE_ARGS+= --enable-nls
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.if defined(WITH_REPORTLAB)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/reportlab/:${PORTSDIR}/print/py-reportlab2
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/font-manager/distinfo b/x11-fonts/font-manager/distinfo
new file mode 100644
index 000000000000..6bd5aad86ca9
--- /dev/null
+++ b/x11-fonts/font-manager/distinfo
@@ -0,0 +1,2 @@
+SHA256 (font-manager-0.5.7.tar.bz2) = 794a3d98e50ab7e515d8216ad42300c13b0ec13ab972bdf71c3657de4b306228
+SIZE (font-manager-0.5.7.tar.bz2) = 771460
diff --git a/x11-fonts/font-manager/files/patch-Makefile.in b/x11-fonts/font-manager/files/patch-Makefile.in
new file mode 100644
index 000000000000..8429ad89b900
--- /dev/null
+++ b/x11-fonts/font-manager/files/patch-Makefile.in
@@ -0,0 +1,33 @@
+--- Makefile.in.orig 2010-12-20 19:01:26.000000000 -0600
++++ Makefile.in 2011-03-26 00:38:02.410403185 -0500
+@@ -552,8 +552,9 @@ compile_po:
+ install_mo:
+ for mo in `$(FIND) po -name $(PACKAGE_NAME).mo`; \
+ do \
+- newpath=$${mo/#po\//$(INST_LOC_DIR)\/}; \
+- langdir=$${newpath/%$(PACKAGE_NAME).mo//}; \
++ safe_mo=$$mo/ ;\
++ newpath=$(INST_LOC_DIR)/$${safe_mo#po/}; \
++ langdir=$${newpath%$(PACKAGE_NAME).mo/}; \
+ $(INSTALL_DIR) $$langdir; \
+ $(INSTALL_FILE) $$mo $$langdir; \
+ done
+@@ -583,12 +584,14 @@ make-install-dirs:
+ $(INSTALL_BIN) $(SRC_DIR)/$(PACKAGE_NAME) $(INST_BIN_DIR)/
+ $(INSTALL_BIN) $(SRC_DIR)/$(SAMPLER) $(INST_BIN_DIR)/
+ $(INSTALL_FILE) $(SRC_DIR)/$(DE_FILES) $(INST_APPS_DIR)/
+- $(INSTALL_FILE) $(SRC_DIR)/$(PyFiles) $(INST_DATA_DIR)/
+- $(INSTALL_FILE) $(SRC_CORE_DIR)/$(PyFiles) $(INST_DATA_DIR)/core/
+ $(INSTALL_FILE) $(SRC_DATA_DIR)/$(PNG_FILES) $(INST_DATA_DIR)/data/
+ $(INSTALL_FILE) $(SRC_DATA_DIR)/$(UI_FILES) $(INST_DATA_DIR)/data/
+- $(INSTALL_FILE) $(SRC_UI_DIR)/$(PyFiles) $(INST_DATA_DIR)/ui/
+- $(INSTALL_FILE) $(SRC_UTILS_DIR)/$(PyFiles) $(INST_DATA_DIR)/utils/
++ for pysufx in py pyc pyo; do \
++ $(INSTALL_FILE) $(SRC_DIR)/*.$$pysufx $(INST_DATA_DIR)/ ;\
++ $(INSTALL_FILE) $(SRC_CORE_DIR)/*.$$pysufx $(INST_DATA_DIR)/core/ ;\
++ $(INSTALL_FILE) $(SRC_UI_DIR)/*.$$pysufx $(INST_DATA_DIR)/ui/ ;\
++ $(INSTALL_FILE) $(SRC_UTILS_DIR)/*.$$pysufx $(INST_DATA_DIR)/utils/ ;\
++ done
+ @$(FIND) help -type f -exec chmod 644 '{}' \;
+ @$(FIND) help -type d -exec chmod 755 '{}' \;
+ cp -Rv help $(INST_DATA_DIR)/
diff --git a/x11-fonts/font-manager/pkg-descr b/x11-fonts/font-manager/pkg-descr
new file mode 100644
index 000000000000..7b6d5461f0af
--- /dev/null
+++ b/x11-fonts/font-manager/pkg-descr
@@ -0,0 +1,9 @@
+Font Manager is not intended to be a professional-grade font management
+solution, but rather a simple application suitable for the needs of most
+desktop users.
+
+Although designed with the GNOME desktop environment in mind, it should
+work well with most major desktop environments such as Xfce, Enlightenment,
+and even KDE.
+
+WWW: https://code.google.com/p/font-manager/
diff --git a/x11-fonts/font-manager/pkg-plist b/x11-fonts/font-manager/pkg-plist
new file mode 100644
index 000000000000..98c2c7219862
--- /dev/null
+++ b/x11-fonts/font-manager/pkg-plist
@@ -0,0 +1,136 @@
+bin/font-manager
+bin/font-sampler
+lib/font-manager/fontutils.so
+share/applications/font-manager.desktop
+share/applications/font-sampler.desktop
+@dirrmtry share/applications
+%%DATADIR%%/__init__.py
+%%DATADIR%%/__init__.pyc
+%%DATADIR%%/__init__.pyo
+%%DATADIR%%/constants.py
+%%DATADIR%%/constants.pyc
+%%DATADIR%%/constants.pyo
+%%DATADIR%%/core/__init__.py
+%%DATADIR%%/core/__init__.pyc
+%%DATADIR%%/core/__init__.pyo
+%%DATADIR%%/core/database.py
+%%DATADIR%%/core/database.pyc
+%%DATADIR%%/core/database.pyo
+%%DATADIR%%/core/fonts.py
+%%DATADIR%%/core/fonts.pyc
+%%DATADIR%%/core/fonts.pyo
+%%DATADIR%%/core/service.py
+%%DATADIR%%/core/service.pyc
+%%DATADIR%%/core/service.pyo
+%%DATADIR%%/data/actions.ui
+%%DATADIR%%/data/bdf.png
+%%DATADIR%%/data/blank.png
+%%DATADIR%%/data/bmp.png
+%%DATADIR%%/data/cff.png
+%%DATADIR%%/data/fnt.png
+%%DATADIR%%/data/font-information.ui
+%%DATADIR%%/data/font-janitor.ui
+%%DATADIR%%/data/font-manager.ui
+%%DATADIR%%/data/font-sampler.ui
+%%DATADIR%%/data/menus.ui
+%%DATADIR%%/data/opentype.png
+%%DATADIR%%/data/pcf.png
+%%DATADIR%%/data/pfr.png
+%%DATADIR%%/data/truetype.png
+%%DATADIR%%/data/type1.png
+%%DATADIR%%/data/type42.png
+%%DATADIR%%/help/C/about.page
+%%DATADIR%%/help/C/actions.page
+%%DATADIR%%/help/C/alias.page
+%%DATADIR%%/help/C/charmap.page
+%%DATADIR%%/help/C/compare.page
+%%DATADIR%%/help/C/directories.page
+%%DATADIR%%/help/C/export.page
+%%DATADIR%%/help/C/figures/add.png
+%%DATADIR%%/help/C/figures/charmap.png
+%%DATADIR%%/help/C/figures/clear.png
+%%DATADIR%%/help/C/figures/color-select.png
+%%DATADIR%%/help/C/figures/disable.png
+%%DATADIR%%/help/C/figures/enable.png
+%%DATADIR%%/help/C/figures/export.png
+%%DATADIR%%/help/C/figures/family-pane.png
+%%DATADIR%%/help/C/figures/font-preferences.png
+%%DATADIR%%/help/C/figures/fontinfo-dialog.png
+%%DATADIR%%/help/C/figures/fontinfo.png
+%%DATADIR%%/help/C/figures/logo.png
+%%DATADIR%%/help/C/figures/main-window.png
+%%DATADIR%%/help/C/figures/manage.png
+%%DATADIR%%/help/C/figures/preferences.png
+%%DATADIR%%/help/C/figures/preview-pane.png
+%%DATADIR%%/help/C/figures/remove.png
+%%DATADIR%%/help/C/figures/side-pane.png
+%%DATADIR%%/help/C/figures/statusbar.png
+%%DATADIR%%/help/C/fontconfig.page
+%%DATADIR%%/help/C/fontinfo.page
+%%DATADIR%%/help/C/index.page
+%%DATADIR%%/help/C/install.page
+%%DATADIR%%/help/C/introduction.page
+%%DATADIR%%/help/C/issues.page
+%%DATADIR%%/help/C/manage.page
+%%DATADIR%%/help/C/organize.page
+%%DATADIR%%/help/C/preview.page
+%%DATADIR%%/help/C/remove.page
+%%DATADIR%%/help/C/search.page
+%%DATADIR%%/help/C/ui.page
+%%DATADIR%%/main.py
+%%DATADIR%%/main.pyc
+%%DATADIR%%/main.pyo
+%%DATADIR%%/ui/__init__.py
+%%DATADIR%%/ui/__init__.pyc
+%%DATADIR%%/ui/__init__.pyo
+%%DATADIR%%/ui/actions.py
+%%DATADIR%%/ui/actions.pyc
+%%DATADIR%%/ui/actions.pyo
+%%DATADIR%%/ui/custom.py
+%%DATADIR%%/ui/custom.pyc
+%%DATADIR%%/ui/custom.pyo
+%%DATADIR%%/ui/export.py
+%%DATADIR%%/ui/export.pyc
+%%DATADIR%%/ui/export.pyo
+%%DATADIR%%/ui/fontconfig.py
+%%DATADIR%%/ui/fontconfig.pyc
+%%DATADIR%%/ui/fontconfig.pyo
+%%DATADIR%%/ui/fontinfo.py
+%%DATADIR%%/ui/fontinfo.pyc
+%%DATADIR%%/ui/fontinfo.pyo
+%%DATADIR%%/ui/janitor.py
+%%DATADIR%%/ui/janitor.pyc
+%%DATADIR%%/ui/janitor.pyo
+%%DATADIR%%/ui/library.py
+%%DATADIR%%/ui/library.pyc
+%%DATADIR%%/ui/library.pyo
+%%DATADIR%%/ui/preferences.py
+%%DATADIR%%/ui/preferences.pyc
+%%DATADIR%%/ui/preferences.pyo
+%%DATADIR%%/ui/previews.py
+%%DATADIR%%/ui/previews.pyc
+%%DATADIR%%/ui/previews.pyo
+%%DATADIR%%/ui/treeviews.py
+%%DATADIR%%/ui/treeviews.pyc
+%%DATADIR%%/ui/treeviews.pyo
+%%DATADIR%%/utils/__init__.py
+%%DATADIR%%/utils/__init__.pyc
+%%DATADIR%%/utils/__init__.pyo
+%%DATADIR%%/utils/common.py
+%%DATADIR%%/utils/common.pyc
+%%DATADIR%%/utils/common.pyo
+%%DATADIR%%/utils/xmlutils.py
+%%DATADIR%%/utils/xmlutils.pyc
+%%DATADIR%%/utils/xmlutils.pyo
+%%NLS%%share/locale/it/LC_MESSAGES/font-manager.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/font-manager.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/font-manager.mo
+@dirrm %%DATADIR%%/utils
+@dirrm %%DATADIR%%/ui
+@dirrm %%DATADIR%%/help/C/figures
+@dirrm %%DATADIR%%/help/C
+@dirrm %%DATADIR%%/help
+@dirrm %%DATADIR%%/data
+@dirrm %%DATADIR%%/core
+@dirrm %%DATADIR%%
+@dirrm lib/font-manager