aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-09-21 11:42:26 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-09-21 11:42:26 +0000
commitaaf3dc4ebb5678dc0d637a4e18479b8180f4955d (patch)
tree7144db1b8cae3af814fd977df912704577d17b25 /x11-fonts
parent5da283f4ec5e8a45af3d6ef9a6b6655c751b05be (diff)
downloadports-aaf3dc4ebb5678dc0d637a4e18479b8180f4955d.tar.gz
ports-aaf3dc4ebb5678dc0d637a4e18479b8180f4955d.zip
Notes
Diffstat (limited to 'x11-fonts')
-rw-r--r--x11-fonts/Makefile1
-rw-r--r--x11-fonts/spleen/Makefile54
-rw-r--r--x11-fonts/spleen/distinfo3
-rw-r--r--x11-fonts/spleen/pkg-descr7
-rw-r--r--x11-fonts/spleen/pkg-plist11
5 files changed, 76 insertions, 0 deletions
diff --git a/x11-fonts/Makefile b/x11-fonts/Makefile
index 12f6a6939ef1..9d05c7f40339 100644
--- a/x11-fonts/Makefile
+++ b/x11-fonts/Makefile
@@ -177,6 +177,7 @@
SUBDIR += sourcecodepro-ttf
SUBDIR += sourcesanspro-ttf
SUBDIR += sourceserifpro-ttf
+ SUBDIR += spleen
SUBDIR += stix-fonts
SUBDIR += suxus
SUBDIR += symbola
diff --git a/x11-fonts/spleen/Makefile b/x11-fonts/spleen/Makefile
new file mode 100644
index 000000000000..e5cbe8e63cd8
--- /dev/null
+++ b/x11-fonts/spleen/Makefile
@@ -0,0 +1,54 @@
+# $FreeBSD$
+
+PORTNAME= spleen
+DISTVERSION= 1.0.0
+CATEGORIES= x11-fonts
+MASTER_SITES= https://github.com/fcambus/spleen/releases/download/${DISTVERSION}/
+PKGNAMESUFFIX= -font
+
+MAINTAINER= tobik@FreeBSD.org
+COMMENT= Monospaced bitmap fonts for Xorg and vt(4)
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+NO_ARCH= yes
+
+OPTIONS_DEFINE= DOCS X11
+OPTIONS_DEFAULT= X11
+OPTIONS_SUB= yes
+
+X11_BUILD_DEPENDS= bdftopcf:x11-fonts/bdftopcf
+X11_USES= fonts
+X11_USES_OFF= fonts:none
+
+post-patch:
+ @${REINPLACE_CMD} -E 's/^FONT "(.*)"$$/FONT \1/g' ${WRKSRC}/*.bdf
+
+do-build:
+# 32x64 appears to be too large for vtfontcvt: Unsupported wbytes 4!
+.for sz in 5x8 8x16 12x24 16x32
+ vtfontcvt ${sz:S/^/-w /:S/x/ -h /} \
+ ${WRKSRC}/spleen-${sz}.bdf ${WRKSRC}/spleen-${sz}.fnt
+.endfor
+
+do-build-X11-on:
+.for sz in 5x8 8x16 12x24 16x32 32x64
+ bdftopcf -t -o ${WRKSRC}/spleen-${sz}.pcf ${WRKSRC}/spleen-${sz}.bdf
+.endfor
+ ${GZIP_CMD} ${WRKSRC}/*.pcf
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${FONTSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.fnt ${STAGEDIR}${FONTSDIR}
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
+
+do-install-X11-on:
+ ${INSTALL_DATA} ${WRKSRC}/fonts.alias-spleen \
+ ${STAGEDIR}${FONTSDIR}/fonts.alias
+ ${INSTALL_DATA} ${WRKSRC}/*.pcf.gz ${STAGEDIR}${FONTSDIR}
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/spleen/distinfo b/x11-fonts/spleen/distinfo
new file mode 100644
index 000000000000..88d3e65ca463
--- /dev/null
+++ b/x11-fonts/spleen/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1537396175
+SHA256 (spleen-1.0.0.tar.gz) = b4bf78e646f8b9c85f0ee870e6472506ccf5e144548e3f209ebb57faf90d6fa0
+SIZE (spleen-1.0.0.tar.gz) = 45088
diff --git a/x11-fonts/spleen/pkg-descr b/x11-fonts/spleen/pkg-descr
new file mode 100644
index 000000000000..107e186d722f
--- /dev/null
+++ b/x11-fonts/spleen/pkg-descr
@@ -0,0 +1,7 @@
+Spleen is a monospaced bitmap font for consoles and terminals.
+It is available in 5 sizes: 5x8, 8x16, 12x24, 16x32, and 32x64.
+
+The font is provided in PCF format for use in Xorg and as vt(4)
+console fonts.
+
+WWW: https://github.com/fcambus/spleen
diff --git a/x11-fonts/spleen/pkg-plist b/x11-fonts/spleen/pkg-plist
new file mode 100644
index 000000000000..77ac740c4d88
--- /dev/null
+++ b/x11-fonts/spleen/pkg-plist
@@ -0,0 +1,11 @@
+%%PORTDOCS%%%%DOCSDIR%%/README.md
+%%X11%%%%FONTSDIR%%/fonts.alias
+%%FONTSDIR%%/spleen-12x24.fnt
+%%X11%%%%FONTSDIR%%/spleen-12x24.pcf.gz
+%%FONTSDIR%%/spleen-16x32.fnt
+%%X11%%%%FONTSDIR%%/spleen-16x32.pcf.gz
+%%X11%%%%FONTSDIR%%/spleen-32x64.pcf.gz
+%%FONTSDIR%%/spleen-5x8.fnt
+%%X11%%%%FONTSDIR%%/spleen-5x8.pcf.gz
+%%FONTSDIR%%/spleen-8x16.fnt
+%%X11%%%%FONTSDIR%%/spleen-8x16.pcf.gz