aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2005-11-12 20:03:07 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2005-11-12 20:03:07 +0000
commitd7ddb40ab5dd542dff19d60f79c50a54836a832a (patch)
tree1db81ced2b4f5362c6bbb43fe335ca49d5899c1b /x11-fonts
parent4af64e9b9911b5c11d04f318d1cb126617b379bf (diff)
downloadports-d7ddb40ab5dd542dff19d60f79c50a54836a832a.tar.gz
ports-d7ddb40ab5dd542dff19d60f79c50a54836a832a.zip
Notes
Diffstat (limited to 'x11-fonts')
-rw-r--r--x11-fonts/webfonts/Makefile71
-rw-r--r--x11-fonts/webfonts/distinfo2
-rw-r--r--x11-fonts/webfonts/files/fonts.dir1
-rw-r--r--x11-fonts/webfonts/files/tahoma.dir74
-rw-r--r--x11-fonts/webfonts/pkg-descr2
-rw-r--r--x11-fonts/webfonts/pkg-message4
-rw-r--r--x11-fonts/webfonts/pkg-plist2
7 files changed, 132 insertions, 24 deletions
diff --git a/x11-fonts/webfonts/Makefile b/x11-fonts/webfonts/Makefile
index f3a6ecca99bc..5f3b6c3d60e6 100644
--- a/x11-fonts/webfonts/Makefile
+++ b/x11-fonts/webfonts/Makefile
@@ -6,22 +6,30 @@
#
PORTNAME= webfonts
-PORTVERSION= 0.21
-PORTREVISION= 3
+PORTVERSION= 0.30
CATEGORIES= x11-fonts
-MASTER_SITES= ${MASTER_SITE_NETBSD:S/%SUBDIR%/ms-ttf/} \
- ${MASTER_SITE_SOURCEFORGE:S/%SUBDIR%/corefonts/} \
- ftp://ftp.uni-koeln.de/pc/win32/msoft/ \
- ftp://ftp.extra.ouh.nl/studie/alg/hulp/win/fonts/ \
- ftp://ftp.vn.ua/pub/win/freefont/ \
- ftp://ftp.vsu.ru/pub/tex/font-packs/mscore/ \
- ftp://ftp.directnet.ru/pub/fonts-win/ \
- ftp://ftp.sinn.ru/pub/win95/fonts/ \
- ftp://ftp.lexa.ru/pub/mirrors/ftp.vsu.ru/pub/tex/font-packs/mscore/ \
- ftp://ftp.botik.ru/rented/znamensk/distributions/ftp.vsu.ru/pub/tex/font-packs/mscore/
-DISTFILES= andale32.exe trebuc32.exe georgi32.exe verdan32.exe \
- comic32.exe arialb32.exe impact32.exe arial32.exe \
- times32.exe courie32.exe webdin32.exe
+MASTER_SITES= ${MASTER_SITE_NETBSD:S/%SUBDIR%/ms-ttf/}:group1 \
+ ${MASTER_SITE_SOURCEFORGE:S/%SUBDIR%/corefonts/}:group1 \
+ ftp://ftp.uni-koeln.de/pc/win32/msoft/:group1 \
+ ftp://ftp.extra.ouh.nl/studie/alg/hulp/win/fonts/:group1 \
+ ftp://ftp.vn.ua/pub/win/freefont/:group1 \
+ ftp://ftp.vsu.ru/pub/tex/font-packs/mscore/:group1 \
+ ftp://ftp.directnet.ru/pub/fonts-win/:group1 \
+ ftp://ftp.sinn.ru/pub/win95/fonts/:group1 \
+ ftp://ftp.lexa.ru/pub/mirrors/ftp.vsu.ru/pub/tex/font-packs/mscore/:group1 \
+ ftp://ftp.botik.ru/rented/znamensk/distributions/ftp.vsu.ru/pub/tex/font-packs/mscore/:group1 \
+ http://download.microsoft.com/download/ie6sp1/finrel/6_sp1/W98NT42KMeXP/EN-US/:group2 \
+ http://www.zeuscat.com/andrew/software/corefonts/:group2 \
+ ftp://ftp.isu.edu.tw/pub/MsDownload/ie6sp1/en/:group2
+DISTFILES= andale32.exe:group1 arial32.exe:group1 arialb32.exe:group1 \
+ comic32.exe:group1 courie32.exe:group1 georgi32.exe:group1 \
+ impact32.exe:group1 times32.exe:group1 trebuc32.exe:group1 \
+ verdan32.exe:group1 webdin32.exe:group1
+
+.if defined(HAVE_MSWINDOWS_LICENSE)
+DISTFILES+= ielpkth.cab:group2
+.endif
+
DIST_SUBDIR= ${PORTNAME}
MAINTAINER= kkonstan@duth.gr
@@ -36,8 +44,8 @@ NO_CDROM= "Restrictive license - cannot sell for profit"
NO_PACKAGE= "Restrictive license - cannot distribute in modified form"
EXTRACT_CMD= ${LOCALBASE}/bin/cabextract
-EXTRACT_BEFORE_ARGS= --lowercase --quiet
-EXTRACT_AFTER_ARGS= -d ${WRKSRC}
+EXTRACT_BEFORE_ARGS= -qLF '*.ttf' -d ${WRKSRC}
+EXTRACT_AFTER_ARGS=
#
# Local variables
@@ -53,6 +61,8 @@ PLIST_SUB= FONTNAME="${FONTNAME}" \
MSG_FILE= ${PKGDIR}/pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
+FONTS_FILE= ${WRKDIR}/fonts.dir
+
.include <bsd.port.pre.mk>
.if ${X_WINDOW_SYSTEM:L} == xfree86-3
@@ -72,13 +82,32 @@ PLIST_SUB+= FCACHE="" \
# Post-extract
#
post-extract:
- ${RM} -f ${WRKSRC}/*.dll ${WRKSRC}/*.exe ${WRKSRC}/*.inf
+ ${EXTRACT_CMD} -qLF '*.txt' -d ${WRKSRC} ${_DISTDIR}/webdin32.exe
#
# Post-patch
#
post-patch:
- ${SED} 's|%%FONTSDIR%%|${FONTSDIR}|g' ${MSG_FILE} > ${PKGMESSAGE}
+ ${SED} -e 's|%%FONTSDIR%%|${FONTSDIR}|g' \
+ -e 's|%%DOCSDIR%%|${DOCSDIR}|g' \
+ ${MSG_FILE} > ${PKGMESSAGE}
+.if defined(HAVE_MSWINDOWS_LICENSE)
+ ${SORT} ${FILESDIR}/fonts.dir ${FILESDIR}/tahoma.dir > ${FONTS_FILE}
+.else
+ ${CP} ${FILESDIR}/fonts.dir ${FONTS_FILE}
+.endif
+ ${PRINTF} "1i\n%u\n.\nwq\n" `wc -l < ${FONTS_FILE}` | \
+ ed -s ${FONTS_FILE}
+
+#
+# Pre-install
+#
+pre-install:
+.if defined(HAVE_MSWINDOWS_LICENSE)
+PLIST_SUB+= EXTRAFONTS=""
+.else
+PLIST_SUB+= EXTRAFONTS="@comment "
+.endif
#
# Install
@@ -86,8 +115,8 @@ post-patch:
do-install:
${MKDIR} ${FONTSDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/*.ttf ${FONTSDIR}
- ${INSTALL_DATA} ${FILESDIR}/fonts.dir ${FONTSDIR}
- ${INSTALL_DATA} ${FILESDIR}/fonts.dir ${FONTSDIR}/fonts.scale
+ ${INSTALL_DATA} ${FONTS_FILE} ${FONTSDIR}
+ ${INSTALL_DATA} ${FONTS_FILE} ${FONTSDIR}/fonts.scale
${INSTALL_DATA} ${WRKSRC}/licen.txt ${DOCSDIR}/LICENSE
.if ${X_WINDOW_SYSTEM:L} == xfree86-3
${LN} -fs ${FONTSDIR} ${TTFONTSDIR}/${FONTNAME}
diff --git a/x11-fonts/webfonts/distinfo b/x11-fonts/webfonts/distinfo
index 08ec6cf5b8b6..37b7f98a0ed8 100644
--- a/x11-fonts/webfonts/distinfo
+++ b/x11-fonts/webfonts/distinfo
@@ -20,3 +20,5 @@ MD5 (webfonts/courie32.exe) = 4e412c772294403ab62fb2d247d85c60
SIZE (webfonts/courie32.exe) = 646368
MD5 (webfonts/webdin32.exe) = 230a1d13a365b22815f502eb24d9149b
SIZE (webfonts/webdin32.exe) = 185072
+MD5 (webfonts/ielpkth.cab) = 358584cddb75ac90472c25f01b308ebe
+SIZE (webfonts/ielpkth.cab) = 411248
diff --git a/x11-fonts/webfonts/files/fonts.dir b/x11-fonts/webfonts/files/fonts.dir
index e741304511c0..0f8e8e85dfc8 100644
--- a/x11-fonts/webfonts/files/fonts.dir
+++ b/x11-fonts/webfonts/files/fonts.dir
@@ -1,4 +1,3 @@
-839
andalemo.ttf -monotype-andale mono-book-r-monospaced--0-0-0-0-m-0-adobe-standard
andalemo.ttf -monotype-andale mono-book-r-monospaced--0-0-0-0-m-0-ansi-1251
andalemo.ttf -monotype-andale mono-book-r-monospaced--0-0-0-0-m-0-ascii-0
diff --git a/x11-fonts/webfonts/files/tahoma.dir b/x11-fonts/webfonts/files/tahoma.dir
new file mode 100644
index 000000000000..58f13daec8c7
--- /dev/null
+++ b/x11-fonts/webfonts/files/tahoma.dir
@@ -0,0 +1,74 @@
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-adobe-standard
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-ansi-1251
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-ascii-0
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-fcd8859-15
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-iso10646-1
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-iso8859-1
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-iso8859-10
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-iso8859-11
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-iso8859-13
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-iso8859-15
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-iso8859-16
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-iso8859-2
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-iso8859-3
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-iso8859-4
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-iso8859-5
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-iso8859-6
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-iso8859-7
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-iso8859-8
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-iso8859-9
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-koi8-e
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-koi8-r
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-koi8-ru
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-koi8-u
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-koi8-uni
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-microsoft-ansi
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-microsoft-cp1250
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-microsoft-cp1251
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-microsoft-cp1252
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-mulearabic-0
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-mulearabic-1
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-mulearabic-2
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-tcvn-0
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-tis620-0
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-tis620-2
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-tis620.2529-1
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-tis620.2533-0
+tahoma.ttf -microsoft-tahoma-medium-r-even width--0-0-0-0-p-0-tis620.2533-1
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-adobe-standard
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-ansi-1251
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-ascii-0
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-fcd8859-15
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-iso10646-1
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-iso8859-1
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-iso8859-10
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-iso8859-11
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-iso8859-13
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-iso8859-15
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-iso8859-16
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-iso8859-2
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-iso8859-3
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-iso8859-4
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-iso8859-5
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-iso8859-6
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-iso8859-7
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-iso8859-8
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-iso8859-9
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-koi8-e
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-koi8-r
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-koi8-ru
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-koi8-u
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-koi8-uni
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-microsoft-ansi
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-microsoft-cp1250
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-microsoft-cp1251
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-microsoft-cp1252
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-mulearabic-0
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-mulearabic-1
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-mulearabic-2
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-tcvn-0
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-tis620-0
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-tis620-2
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-tis620.2529-1
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-tis620.2533-0
+tahomabd.ttf -microsoft-tahoma-bold-r-even width--0-0-0-0-p-0-tis620.2533-1
diff --git a/x11-fonts/webfonts/pkg-descr b/x11-fonts/webfonts/pkg-descr
index 11cda0095c68..34ce79deadd0 100644
--- a/x11-fonts/webfonts/pkg-descr
+++ b/x11-fonts/webfonts/pkg-descr
@@ -10,4 +10,6 @@ encodings:
ISO 8859-1, 2, 3, 4, 5, 6, 7, 8, 9, 10 and 15
KOI8-R and -RU
+Tahoma can also be installed as an option, but a Windows License is required.
+
-- Konstantinos Konstantinidis
diff --git a/x11-fonts/webfonts/pkg-message b/x11-fonts/webfonts/pkg-message
index 520c95a1cd1d..24bd8862edf3 100644
--- a/x11-fonts/webfonts/pkg-message
+++ b/x11-fonts/webfonts/pkg-message
@@ -1,7 +1,7 @@
IMPORTANT - READ CAREFULLY: You may not use these fonts if you do not agree to
the terms of the Microsoft End-User License Agreement ("EULA"). You will find
-the EULA at %%FONTSDIR%%/LICENSE. If you read and agree
-to the EULA, you can start using the fonts by following these insructions:
+the EULA at %%DOCSDIR%%/LICENSE. If you read and agree
+to the EULA, you can start using the fonts by following these instructions:
--- XFree86 4.x.x (using the freetype module)
diff --git a/x11-fonts/webfonts/pkg-plist b/x11-fonts/webfonts/pkg-plist
index d4b4fdccdde7..1f703b8c0698 100644
--- a/x11-fonts/webfonts/pkg-plist
+++ b/x11-fonts/webfonts/pkg-plist
@@ -19,6 +19,8 @@
%%FONTSDIR%%/georgiai.ttf
%%FONTSDIR%%/georgiaz.ttf
%%FONTSDIR%%/impact.ttf
+%%EXTRAFONTS%%%%FONTSDIR%%/tahoma.ttf
+%%EXTRAFONTS%%%%FONTSDIR%%/tahomabd.ttf
%%FONTSDIR%%/times.ttf
%%FONTSDIR%%/timesbd.ttf
%%FONTSDIR%%/timesbi.ttf