aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-01 22:21:13 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-01 22:21:13 +0000
commitbfc12e6f942426e206766a895c394e4a58c9fad0 (patch)
tree5564a0326f0ffba00489020ae6b19c2ab9e6d3fc /x11-fonts
parentff0f78c1bba8d0b5da3da37cfe4efe7a8b27983c (diff)
downloadports-bfc12e6f942426e206766a895c394e4a58c9fad0.tar.gz
ports-bfc12e6f942426e206766a895c394e4a58c9fad0.zip
Notes
Diffstat (limited to 'x11-fonts')
-rw-r--r--x11-fonts/Makefile1
-rw-r--r--x11-fonts/montecarlo_fonts/Makefile34
-rw-r--r--x11-fonts/montecarlo_fonts/distinfo3
-rw-r--r--x11-fonts/montecarlo_fonts/pkg-descr7
4 files changed, 45 insertions, 0 deletions
diff --git a/x11-fonts/Makefile b/x11-fonts/Makefile
index b1f4d5f58026..87c28de7717a 100644
--- a/x11-fonts/Makefile
+++ b/x11-fonts/Makefile
@@ -102,6 +102,7 @@
SUBDIR += mkfontdir
SUBDIR += mkfontscale
SUBDIR += mkitalic
+ SUBDIR += montecarlo_fonts
SUBDIR += mozilla-fonts
SUBDIR += nexfontsel
SUBDIR += nucleus
diff --git a/x11-fonts/montecarlo_fonts/Makefile b/x11-fonts/montecarlo_fonts/Makefile
new file mode 100644
index 000000000000..8f16445e1af4
--- /dev/null
+++ b/x11-fonts/montecarlo_fonts/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: montecarlo_fonts
+# Date Created: 20 Okt 2008
+# Whom: Dennis Herrmann <adox@mcx2.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= montecarlo_fonts
+PORTVERSION= 1.0
+CATEGORIES= x11-fonts
+MASTER_SITES= http://bok.net/MonteCarlo/downloads/
+DISTNAME= MonteCarlo-PCF
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= adox@mcx2.org
+COMMENT= A monospace font
+
+RUN_DEPENDS= mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir
+
+USE_XORG= x11
+NO_BUILD= yes
+FONTDIR= ${PREFIX}/lib/X11/fonts/montecarlo
+
+PLIST_FILES= lib/X11/fonts/montecarlo/fonts.dir \
+ lib/X11/fonts/montecarlo//MonteCarloBold.pcf \
+ lib/X11/fonts/montecarlo//MonteCarloMedium.pcf
+PLIST_DIRS= lib/X11/fonts/montecarlo
+
+do-install:
+ @${MKDIR} ${FONTDIR}
+ @${INSTALL_DATA} ${WRKSRC}/*.pcf ${FONTDIR}
+ @(cd ${FONTDIR}; mkfontdir)
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/montecarlo_fonts/distinfo b/x11-fonts/montecarlo_fonts/distinfo
new file mode 100644
index 000000000000..72e335e6075c
--- /dev/null
+++ b/x11-fonts/montecarlo_fonts/distinfo
@@ -0,0 +1,3 @@
+MD5 (MonteCarlo-PCF.tgz) = 503ecb321266fdd2b2baa0a052d8543c
+SHA256 (MonteCarlo-PCF.tgz) = dc0380aad8dc72f4a98d2ae7dc110311f61f484eda748e16a942ccbb4486063a
+SIZE (MonteCarlo-PCF.tgz) = 5749
diff --git a/x11-fonts/montecarlo_fonts/pkg-descr b/x11-fonts/montecarlo_fonts/pkg-descr
new file mode 100644
index 000000000000..fea1be7d2d64
--- /dev/null
+++ b/x11-fonts/montecarlo_fonts/pkg-descr
@@ -0,0 +1,7 @@
+MonteCarlo is a bitmap font suitable for code editors. All the characters
+have the same width, which is ideal for alignment. It is loosely derived
+from the look of the Monaco screen font that was available on the old MacOS
+systems. Some changes have been made to make it easier to differentiate
+certain symbols.
+
+WWW: http://bok.net/MonteCarlo/