aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-03-07 17:47:01 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-03-07 18:10:52 +0000
commit0b805f476da20a3def50a321f0e3bc02854e0ff4 (patch)
treedf95893bd6ba8f75fa00c53604081ef02a15f6f9 /x11-fonts
parentf6656e1d8323b17d1fe3bfd49b9d0d872d343cdc (diff)
downloadports-0b805f476da20a3def50a321f0e3bc02854e0ff4.tar.gz
ports-0b805f476da20a3def50a321f0e3bc02854e0ff4.zip
x11-fonts/py-afdko: Add py-afdko 3.8.1
The Adobe Font Development Kit for OpenType (AFDKO) is a set of tools for building OpenType font files from PostScript and TrueType font data. WWW: https://github.com/adobe-type-tools/afdko
Diffstat (limited to 'x11-fonts')
-rw-r--r--x11-fonts/Makefile1
-rw-r--r--x11-fonts/py-afdko/Makefile40
-rw-r--r--x11-fonts/py-afdko/distinfo3
-rw-r--r--x11-fonts/py-afdko/files/patch-setup.py60
-rw-r--r--x11-fonts/py-afdko/pkg-descr4
5 files changed, 108 insertions, 0 deletions
diff --git a/x11-fonts/Makefile b/x11-fonts/Makefile
index 46e1afbf65ca..66104094926a 100644
--- a/x11-fonts/Makefile
+++ b/x11-fonts/Makefile
@@ -213,6 +213,7 @@
SUBDIR += proggy_fonts-ttf
SUBDIR += psftools
SUBDIR += py-QtAwesome
+ SUBDIR += py-afdko
SUBDIR += py-babelfont
SUBDIR += py-bdflib
SUBDIR += py-booleanOperations
diff --git a/x11-fonts/py-afdko/Makefile b/x11-fonts/py-afdko/Makefile
new file mode 100644
index 000000000000..e97347ef7d2c
--- /dev/null
+++ b/x11-fonts/py-afdko/Makefile
@@ -0,0 +1,40 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= afdko
+PORTVERSION= 3.8.1
+CATEGORIES= x11-fonts python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Adobe Font Development Kit for OpenType
+
+LICENSE= APACHE20
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=0:devel/py-setuptools_scm@${PY_FLAVOR}
+# print/py-fonttools[woff]: archivers/py-brotli and archivers/py-zopfli
+# x11-fonts/py-defcon[pens]: print/py-fontpens
+RUN_DEPENDS= afdko>=${PORTVERSION}:x11-fonts/afdko \
+ ${PYTHON_PKGNAMEPREFIX}booleanOperations>=0:x11-fonts/py-booleanOperations@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}brotli>=1.0.1:archivers/py-brotli@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}defcon>=0:x11-fonts/py-defcon@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}fontMath>=0:x11-fonts/py-fontMath@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}fontpens>=0.1.0:print/py-fontpens@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}fonttools>=0:print/py-fonttools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}lxml>=4.8.0:devel/py-lxml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}psautohint>=0:print/py-psautohint@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tqdm>=0:misc/py-tqdm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}ufonormalizer>=0:x11-fonts/py-ufonormalizer@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}ufoprocessor>=0:x11-fonts/py-ufoprocessor@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zopfli>=0:archivers/py-zopfli@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+post-patch:
+ @${RM} ${WRKSRC}/CMakeLists.txt
+ @${RM} -r ${WRKSRC}/c/ ${WRKSRC}/cmake/
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/py-afdko/distinfo b/x11-fonts/py-afdko/distinfo
new file mode 100644
index 000000000000..4569e86fa5e7
--- /dev/null
+++ b/x11-fonts/py-afdko/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1646057844
+SHA256 (afdko-3.8.1.tar.gz) = 05a4a9c3b4e2072982be83f4ff3d73ca758a4091ff3e36db19ff39648f4b399c
+SIZE (afdko-3.8.1.tar.gz) = 14329149
diff --git a/x11-fonts/py-afdko/files/patch-setup.py b/x11-fonts/py-afdko/files/patch-setup.py
new file mode 100644
index 000000000000..3dc22638f46b
--- /dev/null
+++ b/x11-fonts/py-afdko/files/patch-setup.py
@@ -0,0 +1,60 @@
+--- setup.py.orig 2022-02-24 19:28:27 UTC
++++ setup.py
+@@ -8,31 +8,10 @@ from distutils.dep_util import newer
+ from distutils.util import convert_path
+ from distutils.util import get_platform
+
++from setuptools import setup
+ import setuptools.command.install
+
+-from skbuild import setup
+
+-try:
+- from wheel.bdist_wheel import bdist_wheel
+-
+- class CustomBDistWheel(bdist_wheel):
+- """Mark the wheel as python 3, yet platform-specific,
+- since it contains native C executables.
+- """
+-
+- def finalize_options(self):
+- bdist_wheel.finalize_options(self)
+- self.root_is_pure = False
+-
+- def get_tag(self):
+- return ('py3', 'none',) + bdist_wheel.get_tag(self)[2:]
+-
+-except ImportError:
+- print("afdko: setup.py requires that the Python package 'wheel' be "
+- "installed. Try the command 'pip install wheel'.")
+- sys.exit(1)
+-
+-
+ class InstallPlatlib(setuptools.command.install.install):
+ """This is to force installing all the modules to the non-pure, platform-
+ specific lib directory, even though we haven't defined any 'ext_modules'.
+@@ -194,24 +173,17 @@ def main():
+ zip_safe=False,
+ python_requires='>=3.7',
+ setup_requires=[
+- 'wheel',
+ 'setuptools_scm',
+- 'scikit-build',
+- 'cmake',
+- 'ninja'
+ ],
+ tests_require=[
+ 'pytest',
+ ],
+ install_requires=_get_requirements(),
+- scripts=_get_scripts(),
+ entry_points={
+ 'console_scripts': _get_console_scripts(),
+ },
+ cmdclass={
+ 'build_scripts': CustomBuildScripts,
+- 'bdist_wheel': CustomBDistWheel,
+- 'install': InstallPlatlib,
+ },
+ )
+
diff --git a/x11-fonts/py-afdko/pkg-descr b/x11-fonts/py-afdko/pkg-descr
new file mode 100644
index 000000000000..90ae5c42fa11
--- /dev/null
+++ b/x11-fonts/py-afdko/pkg-descr
@@ -0,0 +1,4 @@
+The Adobe Font Development Kit for OpenType (AFDKO) is a set of tools for
+building OpenType font files from PostScript and TrueType font data.
+
+WWW: https://github.com/adobe-type-tools/afdko