aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-03-07 17:46:38 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-03-07 18:10:50 +0000
commit602fe741724a7a973b6dac6e49494db18920c046 (patch)
treedd9e2e7d371fbb3d005ca4fcf047584f8e6a17aa /x11-fonts
parent9ef94208e6f1c80400c94136215c26bd65ea868a (diff)
downloadports-602fe741724a7a973b6dac6e49494db18920c046.tar.gz
ports-602fe741724a7a973b6dac6e49494db18920c046.zip
x11-fonts/afdko: Add afdko 3.8.1
The Adobe Font Development Kit for OpenType (AFDKO) is a set of tools for building OpenType font files from PostScript and TrueType font data. WWW: https://github.com/adobe-type-tools/afdko
Diffstat (limited to 'x11-fonts')
-rw-r--r--x11-fonts/Makefile1
-rw-r--r--x11-fonts/afdko/Makefile17
-rw-r--r--x11-fonts/afdko/distinfo3
-rw-r--r--x11-fonts/afdko/files/patch-CMakeLists.txt26
-rw-r--r--x11-fonts/afdko/pkg-descr4
-rw-r--r--x11-fonts/afdko/pkg-plist8
6 files changed, 59 insertions, 0 deletions
diff --git a/x11-fonts/Makefile b/x11-fonts/Makefile
index b923d9718dca..46e1afbf65ca 100644
--- a/x11-fonts/Makefile
+++ b/x11-fonts/Makefile
@@ -2,6 +2,7 @@
SUBDIR += 3270font
SUBDIR += Hasklig
+ SUBDIR += afdko
SUBDIR += agave
SUBDIR += alef
SUBDIR += alegreya
diff --git a/x11-fonts/afdko/Makefile b/x11-fonts/afdko/Makefile
new file mode 100644
index 000000000000..0b3d5a836f45
--- /dev/null
+++ b/x11-fonts/afdko/Makefile
@@ -0,0 +1,17 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= afdko
+PORTVERSION= 3.8.1
+CATEGORIES= x11-fonts
+MASTER_SITES= https://github.com/adobe-type-tools/afdko/releases/download/${PORTVERSION}/
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Adobe Font Development Kit for OpenType (AFDKO)
+
+LICENSE= APACHE20
+
+USES= cmake compiler:c++11-lang
+
+CMAKE_OFF= SKBUILD
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/afdko/distinfo b/x11-fonts/afdko/distinfo
new file mode 100644
index 000000000000..4569e86fa5e7
--- /dev/null
+++ b/x11-fonts/afdko/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1646057844
+SHA256 (afdko-3.8.1.tar.gz) = 05a4a9c3b4e2072982be83f4ff3d73ca758a4091ff3e36db19ff39648f4b399c
+SIZE (afdko-3.8.1.tar.gz) = 14329149
diff --git a/x11-fonts/afdko/files/patch-CMakeLists.txt b/x11-fonts/afdko/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..40e75ae8639b
--- /dev/null
+++ b/x11-fonts/afdko/files/patch-CMakeLists.txt
@@ -0,0 +1,26 @@
+--- CMakeLists.txt.orig 2022-02-24 19:28:27 UTC
++++ CMakeLists.txt
+@@ -36,13 +36,13 @@ list(APPEND CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_D
+ # https://www.antlr.org/download/antlr4-cpp-runtime-4.9.2-source.zip
+ # set(ANTLR4_ZIP_REPOSITORY "/path_to_antlr4_archive/a4.zip")
+
+-add_definitions(-DANTLR4CPP_STATIC)
+-set(ANTLR4_WITH_STATIC_CRT OFF)
++#add_definitions(-DANTLR4CPP_STATIC)
++#set(ANTLR4_WITH_STATIC_CRT OFF)
+ # Use slightly more recent commit than 4.9.2 to deal with utfcpp test
+ # compilation problems
+ # set(ANTLR4_TAG tags/4.9.2)
+-set(ANTLR4_TAG 916f03366edf15bf8b50010b11d479c189bf9f96)
+-include(ExternalAntlr4Cpp)
++#set(ANTLR4_TAG 916f03366edf15bf8b50010b11d479c189bf9f96)
++#include(ExternalAntlr4Cpp)
+
+ # sanitizer support
+ # work around https://github.com/pypa/setuptools/issues/1928 with environment
+@@ -78,4 +78,4 @@ add_subdirectory(c/sfntedit/source)
+ add_subdirectory(c/spot/source)
+ add_subdirectory(c/tx/source)
+ add_subdirectory(c/type1/source)
+-add_subdirectory(c/makeotf)
++#add_subdirectory(c/makeotf)
diff --git a/x11-fonts/afdko/pkg-descr b/x11-fonts/afdko/pkg-descr
new file mode 100644
index 000000000000..90ae5c42fa11
--- /dev/null
+++ b/x11-fonts/afdko/pkg-descr
@@ -0,0 +1,4 @@
+The Adobe Font Development Kit for OpenType (AFDKO) is a set of tools for
+building OpenType font files from PostScript and TrueType font data.
+
+WWW: https://github.com/adobe-type-tools/afdko
diff --git a/x11-fonts/afdko/pkg-plist b/x11-fonts/afdko/pkg-plist
new file mode 100644
index 000000000000..b6d4a04009ec
--- /dev/null
+++ b/x11-fonts/afdko/pkg-plist
@@ -0,0 +1,8 @@
+bin/detype1
+bin/mergefonts
+bin/rotatefont
+bin/sfntdiff
+bin/sfntedit
+bin/spot
+bin/tx
+bin/type1