aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2014-01-26 23:15:37 +0000
committerThierry Thomas <thierry@FreeBSD.org>2014-01-26 23:15:37 +0000
commit0da24155ee65efeb63ad73d403d58c91224b0133 (patch)
tree5f315f2a93eae2ced96a711905eda15f0b2e7f07 /x11-fonts
parent2fa6c06782b5f9b6b82caf44d81486e652c13bd4 (diff)
downloadports-0da24155ee65efeb63ad73d403d58c91224b0133.tar.gz
ports-0da24155ee65efeb63ad73d403d58c91224b0133.zip
Notes
Diffstat (limited to 'x11-fonts')
-rw-r--r--x11-fonts/gnu-unifont-ttf/Makefile20
-rw-r--r--x11-fonts/gnu-unifont-ttf/distinfo4
-rw-r--r--x11-fonts/gnu-unifont-ttf/pkg-descr2
-rw-r--r--x11-fonts/gnu-unifont/Makefile25
-rw-r--r--x11-fonts/gnu-unifont/distinfo4
-rw-r--r--x11-fonts/gnu-unifont/pkg-descr2
6 files changed, 26 insertions, 31 deletions
diff --git a/x11-fonts/gnu-unifont-ttf/Makefile b/x11-fonts/gnu-unifont-ttf/Makefile
index da2868f85301..cc733f958a70 100644
--- a/x11-fonts/gnu-unifont-ttf/Makefile
+++ b/x11-fonts/gnu-unifont-ttf/Makefile
@@ -2,26 +2,24 @@
# $FreeBSD$
PORTNAME= gnu-unifont-ttf
-PORTVERSION= 20080907
+PORTVERSION= 20131020
CATEGORIES= x11-fonts
-MASTER_SITES= http://unifoundry.com/ \
- http://chirashi-no-ura.net/files/
-DISTNAME= unifont-5.1.${PORTVERSION}.ttf
+MASTER_SITES= http://unifoundry.com/pub/unifont-6.3.${PORTVERSION}/font-builds/
+DISTNAME= unifont-6.3.${PORTVERSION}.ttf
EXTRACT_SUFX= .gz
MAINTAINER= bsdports@gmail.com
COMMENT= Unicode TrueType Font
+EXTRACT_CMD= ${GZIP_CMD}
+EXTRACT_BEFORE_ARGS= -dc
+EXTRACT_AFTER_ARGS= > ${WRKDIR}/${DISTNAME}
+
+NO_WRKSUBDIR= yes
NO_BUILD= yes
PLIST_FILES= lib/X11/fonts/local/unifont.ttf
-NO_STAGE= yes
-do-extract:
- ${MKDIR} ${WRKDIR}
- ${CP} ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ${WRKDIR}
- ${GUNZIP_CMD} ${WRKDIR}/${DISTNAME}${EXTRACT_SUFX}
-
do-install:
- ${CP} ${WRKDIR}/${DISTNAME} ${LOCALBASE}/lib/X11/fonts/local/unifont.ttf
+ ${INSTALL_DATA} ${WRKSRC}/${DISTNAME} ${STAGEDIR}${PREFIX}/lib/X11/fonts/local/unifont.ttf
.include <bsd.port.mk>
diff --git a/x11-fonts/gnu-unifont-ttf/distinfo b/x11-fonts/gnu-unifont-ttf/distinfo
index 8b06c7b6b068..afaf23e8eb1c 100644
--- a/x11-fonts/gnu-unifont-ttf/distinfo
+++ b/x11-fonts/gnu-unifont-ttf/distinfo
@@ -1,2 +1,2 @@
-SHA256 (unifont-5.1.20080907.ttf.gz) = bccb547b59aa2006f2fb78053627eced4de1339cc6d612facfca2b0b9dee5a0f
-SIZE (unifont-5.1.20080907.ttf.gz) = 3105352
+SHA256 (unifont-6.3.20131020.ttf.gz) = 2ed6b629cb03ae0f58cdf6c3a8538499d20c1618abfcfbcdabf9649067c4d251
+SIZE (unifont-6.3.20131020.ttf.gz) = 3080523
diff --git a/x11-fonts/gnu-unifont-ttf/pkg-descr b/x11-fonts/gnu-unifont-ttf/pkg-descr
index 332b739e8ee8..fe450201ce60 100644
--- a/x11-fonts/gnu-unifont-ttf/pkg-descr
+++ b/x11-fonts/gnu-unifont-ttf/pkg-descr
@@ -4,5 +4,5 @@ using an intermediate bitmapped font format.
This is converted to TrueType.
-Auther: Paul Hardy <unifoundry@unifoundry.com>
+Author: Paul Hardy <unifoundry@unifoundry.com>
WWW: http://unifoundry.com/unifont.html
diff --git a/x11-fonts/gnu-unifont/Makefile b/x11-fonts/gnu-unifont/Makefile
index 0a28818cc032..e69d73480c7c 100644
--- a/x11-fonts/gnu-unifont/Makefile
+++ b/x11-fonts/gnu-unifont/Makefile
@@ -2,29 +2,26 @@
# $FreeBSD$
PORTNAME= gnu-unifont
-PORTVERSION= 20080820
+PORTVERSION= 20131020
CATEGORIES= x11-fonts
-MASTER_SITES= http://unifoundry.com/ \
- http://chirashi-no-ura.net/files/
-DISTNAME= unifont-5.1.${PORTVERSION}.bdf
+MASTER_SITES= http://unifoundry.com/pub/unifont-6.3.${PORTVERSION}/font-builds/
+DISTNAME= unifont-6.3.${PORTVERSION}.pcf
EXTRACT_SUFX= .gz
+EXTRACT_ONLY=
MAINTAINER= bsdports@gmail.com
COMMENT= Unicode Font
-BUILD_DEPENDS= bdftopcf:${PORTSDIR}/x11-fonts/bdftopcf
+BUILD_DEPENDS= mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir
+RUN_DEPENDS= mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir
NO_BUILD= yes
-PLIST_FILES= lib/X11/fonts/local/unifont.pcf.gz
-
-NO_STAGE= yes
-do-extract:
- ${MKDIR} ${WRKDIR}
- ${CP} ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ${WRKDIR}
- ${GUNZIP_CMD} ${WRKDIR}/${DISTNAME}${EXTRACT_SUFX}
+PLIST_FILES= "@unexec mkfontdir %D/lib/X11/fonts/local 2>/dev/null || true" \
+ lib/X11/fonts/local/unifont.pcf.gz \
+ "@exec mkfontdir %D/lib/X11/fonts/local 2>/dev/null || true"
do-install:
- ${LOCALBASE}/bin/bdftopcf ${WRKDIR}/${DISTNAME} | ${GZIP_CMD} > ${WRKDIR}/unifont.pcf.gz
- ${CP} ${WRKDIR}/unifont.pcf.gz ${LOCALBASE}/lib/X11/fonts/local/unifont.pcf.gz
+ ${INSTALL_DATA} ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} \
+ ${STAGEDIR}${PREFIX}/lib/X11/fonts/local/unifont.pcf.gz
.include <bsd.port.mk>
diff --git a/x11-fonts/gnu-unifont/distinfo b/x11-fonts/gnu-unifont/distinfo
index bb6c6baa1d8d..ca4adf5e9028 100644
--- a/x11-fonts/gnu-unifont/distinfo
+++ b/x11-fonts/gnu-unifont/distinfo
@@ -1,2 +1,2 @@
-SHA256 (unifont-5.1.20080820.bdf.gz) = bd3bb03b6efb6d40641f84ce70ac69bf24d1cba58b738b041648186b9c731868
-SIZE (unifont-5.1.20080820.bdf.gz) = 1313836
+SHA256 (unifont-6.3.20131020.pcf.gz) = 6510709cb485a1393852b7e3540787a31f55137126d679fde47344bbf1349c53
+SIZE (unifont-6.3.20131020.pcf.gz) = 1353939
diff --git a/x11-fonts/gnu-unifont/pkg-descr b/x11-fonts/gnu-unifont/pkg-descr
index 797b49995386..a72c1a0f67db 100644
--- a/x11-fonts/gnu-unifont/pkg-descr
+++ b/x11-fonts/gnu-unifont/pkg-descr
@@ -2,5 +2,5 @@ GNU Unifont is a free bitmap font that covers
the Unicode Basic Multilingual Plane (BMP),
using an intermediate bitmapped font format.
-Auther: Paul Hardy <unifoundry@unifoundry.com>
+Author: Paul Hardy <unifoundry@unifoundry.com>
WWW: http://unifoundry.com/unifont.html