aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-05-24 02:56:56 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-05-24 02:56:56 +0000
commitc6694263206b498f0a6ed2c9e571d62c093ab07c (patch)
treeda5ab31c7db324ba9ff11ab84fe0ea6f92150ee4 /x11-fonts
parent08b4e6af85cf80720cb957005bfc96c50bd399c4 (diff)
downloadports-c6694263206b498f0a6ed2c9e571d62c093ab07c.tar.gz
ports-c6694263206b498f0a6ed2c9e571d62c093ab07c.zip
Notes
Diffstat (limited to 'x11-fonts')
-rw-r--r--x11-fonts/Makefile1
-rw-r--r--x11-fonts/firacode/Makefile26
-rw-r--r--x11-fonts/firacode/distinfo3
-rw-r--r--x11-fonts/firacode/pkg-descr12
-rw-r--r--x11-fonts/firacode/pkg-plist5
5 files changed, 47 insertions, 0 deletions
diff --git a/x11-fonts/Makefile b/x11-fonts/Makefile
index 150d45f8b7af..6376da7e9ff0 100644
--- a/x11-fonts/Makefile
+++ b/x11-fonts/Makefile
@@ -42,6 +42,7 @@
SUBDIR += farsifonts
SUBDIR += fifteen
SUBDIR += fira
+ SUBDIR += firacode
SUBDIR += fntsample
SUBDIR += font-adobe-100dpi
SUBDIR += font-adobe-75dpi
diff --git a/x11-fonts/firacode/Makefile b/x11-fonts/firacode/Makefile
new file mode 100644
index 000000000000..78c23b71d967
--- /dev/null
+++ b/x11-fonts/firacode/Makefile
@@ -0,0 +1,26 @@
+# Created by: Dave Cottlehuber <dch@skunkwerks.at>
+# $FreeBSD$
+
+PORTNAME= firacode
+PORTVERSION= 1.102
+CATEGORIES= x11-fonts
+MASTER_SITES= https://github.com/tonsky/FiraCode/releases/download/${PORTVERSION}/
+DISTNAME= FiraCode_${PORTVERSION}
+
+MAINTAINER= dch@skunkwerks.at
+COMMENT= Monospaced font with programming ligatures derived from Fira
+
+LICENSE= OFL11
+
+USES= fonts zip
+USE_XORG= x11
+NO_ARCH= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${FONTSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/FiraCode_${PORTVERSION}/*.otf \
+ ${STAGEDIR}${FONTSDIR}
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/firacode/distinfo b/x11-fonts/firacode/distinfo
new file mode 100644
index 000000000000..760482ba0a82
--- /dev/null
+++ b/x11-fonts/firacode/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1463555079
+SHA256 (FiraCode_1.102.zip) = fe3dc4af0c7e44d715b6f9a1bfc1adb5fee76a533016c0a2b0c3b3da8efb996d
+SIZE (FiraCode_1.102.zip) = 484946
diff --git a/x11-fonts/firacode/pkg-descr b/x11-fonts/firacode/pkg-descr
new file mode 100644
index 000000000000..0d21c43afc04
--- /dev/null
+++ b/x11-fonts/firacode/pkg-descr
@@ -0,0 +1,12 @@
+Fira Code is a version of Mozilla's Fira Mono font with additional
+ligatures.
+
+It is an extension of the Fira Mono font containing a set of ligatures
+for common programming multi-character combinations in languages
+like erlang, elixir, haskell, ocaml, clojure, scala etc where these
+symbols crop up frequently. This is just a font rendering feature:
+underlying code remains ASCII-compatible. This helps to read and
+understand code faster. For some frequent sequences like .. or //,
+ligatures allow us to correct spacing.
+
+WWW: https://github.com/tonsky/FiraCode
diff --git a/x11-fonts/firacode/pkg-plist b/x11-fonts/firacode/pkg-plist
new file mode 100644
index 000000000000..af48b432a48c
--- /dev/null
+++ b/x11-fonts/firacode/pkg-plist
@@ -0,0 +1,5 @@
+%%FONTSDIR%%/FiraCode-Bold.otf
+%%FONTSDIR%%/FiraCode-Light.otf
+%%FONTSDIR%%/FiraCode-Medium.otf
+%%FONTSDIR%%/FiraCode-Regular.otf
+%%FONTSDIR%%/FiraCode-Retina.otf