aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2017-05-05 13:47:23 +0000
committerMartin Wilke <miwi@FreeBSD.org>2017-05-05 13:47:23 +0000
commitaf7b03764fa88ba85b68624e277b46944baccc4c (patch)
treeca95dc6ee9aad0f700d5835235c4fe7699bdd40b /x11-fonts
parentdf1ade811419fac89385612edf295c0ecc68df9f (diff)
downloadports-af7b03764fa88ba85b68624e277b46944baccc4c.tar.gz
ports-af7b03764fa88ba85b68624e277b46944baccc4c.zip
- Update to 0.6.0
PR: 217289 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=440152
Diffstat (limited to 'x11-fonts')
-rw-r--r--x11-fonts/fontmatrix/Makefile15
-rw-r--r--x11-fonts/fontmatrix/distinfo5
-rw-r--r--x11-fonts/fontmatrix/files/patch-cmake__modules__FREETYPEConfig.cmake17
-rw-r--r--x11-fonts/fontmatrix/files/patch-src__CMakeLists.txt10
-rw-r--r--x11-fonts/fontmatrix/files/patch-src__prefspaneldialog.h4
-rw-r--r--x11-fonts/fontmatrix/pkg-plist135
6 files changed, 159 insertions, 27 deletions
diff --git a/x11-fonts/fontmatrix/Makefile b/x11-fonts/fontmatrix/Makefile
index f5bddfc645c7..8bfd8ffa16e2 100644
--- a/x11-fonts/fontmatrix/Makefile
+++ b/x11-fonts/fontmatrix/Makefile
@@ -1,11 +1,9 @@
# $FreeBSD$
PORTNAME= fontmatrix
-DISTVERSION= 0.4.2
-DISTVERSIONSUFFIX= -Source
-PORTREVISION= 4
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.6.0
CATEGORIES= x11-fonts
-MASTER_SITES= http://www.fontmatrix.net/archives/
MAINTAINER= ports@FreeBSD.org
COMMENT= Graphical font manager
@@ -17,9 +15,14 @@ RUN_DEPENDS= ${LOCALBASE}/share/icons/hicolor/index.theme:misc/hicolor-icon-them
LIB_DEPENDS= libfreetype.so:print/freetype2 \
libfontconfig.so:x11-fonts/fontconfig
-USES= cmake
-USE_QT4= corelib xml gui svg network moc_build uic_build rcc_build qmake_build linguisttools_build
+USE_GITHUB= yes
+GH_ACCOUNT= fontmatrix
+
+USES= cmake execinfo
+USE_QT4= corelib xml gui svg network moc_build uic_build rcc_build qmake_build \
+ linguisttools_build opengl sql webkit
INSTALLS_ICONS= yes
+MANDIRS= ${PREFIX}/share/man/man1
OPTIONS_DEFINE= FONTFORGE
FONTFORGE_DESC= Install FontForge editor
diff --git a/x11-fonts/fontmatrix/distinfo b/x11-fonts/fontmatrix/distinfo
index fbf019651281..94cfbf1cfe21 100644
--- a/x11-fonts/fontmatrix/distinfo
+++ b/x11-fonts/fontmatrix/distinfo
@@ -1,2 +1,3 @@
-SHA256 (fontmatrix-0.4.2-Source.tar.gz) = 3b5ad1e27b33d81fea610d4748a9a42107006a36bff277529eb3377670600075
-SIZE (fontmatrix-0.4.2-Source.tar.gz) = 656806
+TIMESTAMP = 1487605409
+SHA256 (fontmatrix-fontmatrix-v0.6.0_GH0.tar.gz) = fa3ca2b189115c24c628f15334e0b506298d7a16e294bcc21bde79cba9c44a84
+SIZE (fontmatrix-fontmatrix-v0.6.0_GH0.tar.gz) = 2448848
diff --git a/x11-fonts/fontmatrix/files/patch-cmake__modules__FREETYPEConfig.cmake b/x11-fonts/fontmatrix/files/patch-cmake__modules__FREETYPEConfig.cmake
deleted file mode 100644
index edea542d4bba..000000000000
--- a/x11-fonts/fontmatrix/files/patch-cmake__modules__FREETYPEConfig.cmake
+++ /dev/null
@@ -1,17 +0,0 @@
---- cmake/modules/FREETYPEConfig.cmake.orig 2008-04-07 20:45:10 UTC
-+++ cmake/modules/FREETYPEConfig.cmake
-@@ -1,10 +1,10 @@
- #
- # Find the native FREETYPE includes and library
- # (from Scribus)
-- FIND_PATH(FREETYPE_INCLUDE_DIR_FT2BUILD ft2build.h
-- /usr/include/
-- /usr/local/include/
-- /usr/X11R6/include/
-+ FIND_PATH(FREETYPE_INCLUDE_DIR_FT2BUILD freetype2/ft2build.h
-+ /usr/include
-+ /usr/local/include
-+ /usr/X11R6/include
- NO_CMAKE_SYSTEM_PATH
- )
-
diff --git a/x11-fonts/fontmatrix/files/patch-src__CMakeLists.txt b/x11-fonts/fontmatrix/files/patch-src__CMakeLists.txt
new file mode 100644
index 000000000000..3ec9243865b0
--- /dev/null
+++ b/x11-fonts/fontmatrix/files/patch-src__CMakeLists.txt
@@ -0,0 +1,10 @@
+--- src/CMakeLists.txt.orig 2009-07-03 15:17:39 UTC
++++ src/CMakeLists.txt
+@@ -265,6 +265,7 @@ IF(UNIX AND NOT APPLE)
+ )
+
+ target_link_libraries(fontmatrix harfbuzz hyphenate
++ execinfo
+ ${PYTHONQT_LIB}
+ ${QT_LIBRARIES}
+ ${FREETYPE_LIBRARIES}
diff --git a/x11-fonts/fontmatrix/files/patch-src__prefspaneldialog.h b/x11-fonts/fontmatrix/files/patch-src__prefspaneldialog.h
index b3e1fdbd76f7..9f9acb5c9b1a 100644
--- a/x11-fonts/fontmatrix/files/patch-src__prefspaneldialog.h
+++ b/x11-fonts/fontmatrix/files/patch-src__prefspaneldialog.h
@@ -1,4 +1,4 @@
---- src/prefspaneldialog.h.orig 2008-04-07 20:45:09 UTC
+--- src/prefspaneldialog.h.orig 2009-07-03 15:17:39 UTC
+++ src/prefspaneldialog.h
@@ -12,7 +12,7 @@
#ifndef PREFSPANELDIALOG_H
@@ -8,4 +8,4 @@
+#include <QDialog>
#include <ui_prefs_panel.h>
-
+ class QStandardItemModel;
diff --git a/x11-fonts/fontmatrix/pkg-plist b/x11-fonts/fontmatrix/pkg-plist
index e0388266fa42..beeccab9dbd3 100644
--- a/x11-fonts/fontmatrix/pkg-plist
+++ b/x11-fonts/fontmatrix/pkg-plist
@@ -1,3 +1,138 @@
bin/fontmatrix
share/applications/fontmatrix.desktop
share/icons/hicolor/48x48/apps/fontmatrix.png
+share/man/man1/fontmatrix.1.gz
+%%DATADIR%%/help/en/additional.html
+%%DATADIR%%/help/en/additional_db_check.html
+%%DATADIR%%/help/en/additional_editing_panose.html
+%%DATADIR%%/help/en/additional_export_for_packaging.html
+%%DATADIR%%/help/en/additional_extracting_fonts.html
+%%DATADIR%%/help/en/additional_ttf_tables.html
+%%DATADIR%%/help/en/basics.html
+%%DATADIR%%/help/en/comparisons.html
+%%DATADIR%%/help/en/comparisons_fonts.html
+%%DATADIR%%/help/en/comparisons_glyphs.html
+%%DATADIR%%/help/en/contributing.html
+%%DATADIR%%/help/en/contributing_programming.html
+%%DATADIR%%/help/en/contributing_testing.html
+%%DATADIR%%/help/en/contributing_translating.html
+%%DATADIR%%/help/en/creating_font_books.html
+%%DATADIR%%/help/en/export_fonts.html
+%%DATADIR%%/help/en/external_tools.html
+%%DATADIR%%/help/en/font_book_templates.html
+%%DATADIR%%/help/en/font_books.html
+%%DATADIR%%/help/en/images/browse-fonts-folders-tab.png
+%%DATADIR%%/help/en/images/browse-fonts-names-tab.png
+%%DATADIR%%/help/en/images/browse-fonts-previews-tab.png
+%%DATADIR%%/help/en/images/close_to_system_tray_warning.png
+%%DATADIR%%/help/en/images/extracted-font-compact-encoding.png
+%%DATADIR%%/help/en/images/extracted-font-copyright-info.png
+%%DATADIR%%/help/en/images/extracted-font-editing.png
+%%DATADIR%%/help/en/images/font_book_export_dialog.png
+%%DATADIR%%/help/en/images/font_book_in_evince.png
+%%DATADIR%%/help/en/images/glyphs_comparison_metrics.png
+%%DATADIR%%/help/en/images/glyphs_comparison_offset_to_line_up.png
+%%DATADIR%%/help/en/images/glyphs_comparison_offset_to_line_up_2.png
+%%DATADIR%%/help/en/images/glyphs_comparison_points_and_controls.png
+%%DATADIR%%/help/en/images/glyphs_comparison_two_glyphs_of_same_font.png
+%%DATADIR%%/help/en/images/glyphs_comparison_typical_view.png
+%%DATADIR%%/help/en/images/glyphs_comparison_typical_view_th.png
+%%DATADIR%%/help/en/images/imported_fonts_list.png
+%%DATADIR%%/help/en/images/importing_set_tags_1.png
+%%DATADIR%%/help/en/images/importing_set_tags_2.png
+%%DATADIR%%/help/en/images/list_of_tags.png
+%%DATADIR%%/help/en/images/splash-screen.png
+%%DATADIR%%/help/en/index.html
+%%DATADIR%%/help/en/interface.html
+%%DATADIR%%/help/en/management.html
+%%DATADIR%%/help/en/management_activation.html
+%%DATADIR%%/help/en/management_importing.html
+%%DATADIR%%/help/en/management_tags.html
+%%DATADIR%%/help/en/menu.xml
+%%DATADIR%%/help/en/news.html
+%%DATADIR%%/help/en/output.html
+%%DATADIR%%/help/en/printing_fonts.html
+%%DATADIR%%/help/en/resources.html
+%%DATADIR%%/help/en/scripting.html
+%%DATADIR%%/help/en/search.html
+%%DATADIR%%/help/en/search_in_generic_metadata.html
+%%DATADIR%%/help/en/search_in_panose.html
+%%DATADIR%%/help/en/search_using_bitmap_samples.html
+%%DATADIR%%/help/en/setting_up.html
+%%DATADIR%%/help/en/setting_up_layout_engine_options.html
+%%DATADIR%%/help/en/setting_up_preferences.html
+%%DATADIR%%/help/en/setting_up_preferences_display.html
+%%DATADIR%%/help/en/setting_up_preferences_files_and_folders.html
+%%DATADIR%%/help/en/setting_up_preferences_general.html
+%%DATADIR%%/help/en/setting_up_preferences_samples_collection.html
+%%DATADIR%%/help/en/setting_up_preferences_service.html
+%%DATADIR%%/help/en/setting_up_preferences_shortcuts.html
+%%DATADIR%%/help/en/setting_up_preferences_system_tray.html
+%%DATADIR%%/help/en/style.css
+%%DATADIR%%/help/en/viewing.html
+%%DATADIR%%/help/en/viewing_glyphs_chart.html
+%%DATADIR%%/help/en/viewing_overview.html
+%%DATADIR%%/help/en/viewing_sample_text.html
+%%DATADIR%%/help/en/what_fonts_are.html
+%%DATADIR%%/help/en/why_fontmatrix.html
+%%DATADIR%%/help/en/why_management.html
+%%DATADIR%%/qm/fontmatrix-cs.qm
+%%DATADIR%%/qm/fontmatrix-da.qm
+%%DATADIR%%/qm/fontmatrix-de.qm
+%%DATADIR%%/qm/fontmatrix-en.qm
+%%DATADIR%%/qm/fontmatrix-fi.qm
+%%DATADIR%%/qm/fontmatrix-fr.qm
+%%DATADIR%%/qm/fontmatrix-hi.qm
+%%DATADIR%%/qm/fontmatrix-nb.qm
+%%DATADIR%%/qm/fontmatrix-nl.qm
+%%DATADIR%%/qm/fontmatrix-no.qm
+%%DATADIR%%/qm/fontmatrix-ru.qm
+%%DATADIR%%/qm/fontmatrix-sr.qm
+%%DATADIR%%/qm/fontmatrix-sv.qm
+%%DATADIR%%/qm/fontmatrix-uk.qm
+%%DATADIR%%/qm/fontmatrix-zh_CN.qm
+%%DATADIR%%/qm/fontmatrix-zh_TW.qm
+%%DATADIR%%/resources/Samples/bn/sample
+%%DATADIR%%/resources/Samples/de/sample
+%%DATADIR%%/resources/Samples/fr/Mamere
+%%DATADIR%%/resources/Samples/gu/sample
+%%DATADIR%%/resources/Samples/he/sample
+%%DATADIR%%/resources/Samples/hi/sample
+%%DATADIR%%/resources/Samples/kn/sample
+%%DATADIR%%/resources/Samples/ml/sample
+%%DATADIR%%/resources/Samples/mr/sample
+%%DATADIR%%/resources/Samples/or/sample
+%%DATADIR%%/resources/Samples/pa/sample
+%%DATADIR%%/resources/Samples/ru/Гоголь
+%%DATADIR%%/resources/Samples/ta/sample
+%%DATADIR%%/resources/Samples/te/sample
+%%DATADIR%%/resources/Samples/udm/sample
+%%DATADIR%%/resources/Scripts/fontforge_subset.py
+%%DATADIR%%/resources/Scripts/fonttools_showxml.py
+%%DATADIR%%/resources/Scripts/import_tags.py
+%%DATADIR%%/resources/Scripts/xetex_fontbook.py
+%%DATADIR%%/resources/css-info-property.png
+%%DATADIR%%/resources/css-info-propertyname.png
+%%DATADIR%%/resources/css-shadow.png
+%%DATADIR%%/resources/css-tech-info.png
+%%DATADIR%%/resources/fontmatrix.js
+%%DATADIR%%/resources/info.css
+%%DATADIR%%/resources/template_default.png
+%%DATADIR%%/resources/template_default.xml
+%%DATADIR%%/resources/template_oneline.png
+%%DATADIR%%/resources/template_oneline.xml
+%%DATADIR%%/resources/welcome_da.html
+%%DATADIR%%/resources/welcome_de.html
+%%DATADIR%%/resources/welcome_en.html
+%%DATADIR%%/resources/welcome_fi.html
+%%DATADIR%%/resources/welcome_fr.html
+%%DATADIR%%/resources/welcome_hi.html
+%%DATADIR%%/resources/welcome_nb.html
+%%DATADIR%%/resources/welcome_nl.html
+%%DATADIR%%/resources/welcome_no.html
+%%DATADIR%%/resources/welcome_ru.html
+%%DATADIR%%/resources/welcome_sr.html
+%%DATADIR%%/resources/welcome_sv.html
+%%DATADIR%%/resources/welcome_uk.html
+%%DATADIR%%/resources/welcome_zh_CN.html
+%%DATADIR%%/resources/welcome_zh_TW.html