aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2007-05-25 16:13:51 +0000
committerThierry Thomas <thierry@FreeBSD.org>2007-05-25 16:13:51 +0000
commitf1a76cdb4b10a294e3c22bd7aa2054f6df6561df (patch)
treed70e1a1aba3c987a81d2a84354243a2e23d25bee /x11-fonts
parentbf2c93f066bf5a0f0ac5afc9c50081b44ffaec46 (diff)
downloadports-f1a76cdb4b10a294e3c22bd7aa2054f6df6561df.tar.gz
ports-f1a76cdb4b10a294e3c22bd7aa2054f6df6561df.zip
Notes
Diffstat (limited to 'x11-fonts')
-rw-r--r--x11-fonts/Makefile1
-rw-r--r--x11-fonts/liberation-fonts-ttf/Makefile52
-rw-r--r--x11-fonts/liberation-fonts-ttf/distinfo3
-rw-r--r--x11-fonts/liberation-fonts-ttf/files/pkg-message.in10
-rw-r--r--x11-fonts/liberation-fonts-ttf/pkg-descr10
-rw-r--r--x11-fonts/liberation-fonts-ttf/pkg-plist18
6 files changed, 94 insertions, 0 deletions
diff --git a/x11-fonts/Makefile b/x11-fonts/Makefile
index e98e92ae4b97..d7e05e9eaa44 100644
--- a/x11-fonts/Makefile
+++ b/x11-fonts/Makefile
@@ -85,6 +85,7 @@
SUBDIR += lfpfonts-fix
SUBDIR += lfpfonts-var
SUBDIR += libFS
+ SUBDIR += liberation-fonts-ttf
SUBDIR += libfontenc
SUBDIR += libXfont
SUBDIR += libXfontcache
diff --git a/x11-fonts/liberation-fonts-ttf/Makefile b/x11-fonts/liberation-fonts-ttf/Makefile
new file mode 100644
index 000000000000..2b01eb790753
--- /dev/null
+++ b/x11-fonts/liberation-fonts-ttf/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: Liberation fonts
+# Date created: 17 May 2007
+# Whom: Thierry Thomas <thierry@pompo.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= liberation-fonts-ttf
+PORTVERSION= 2
+CATEGORIES= x11-fonts
+MASTER_SITES= https://www.redhat.com/f/fonts/
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Liberation fonts from Red Hat to replace MS TTF fonts
+
+BUILD_DEPENDS= mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale \
+ mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir
+
+USE_X_PREFIX= yes
+NO_WRKSUBDIR= yes
+
+PLIST_SUB= FONTDIR="${FONTDIR:S|${PREFIX}/||}"
+
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+SUB_LIST= FONTDIR=${FONTDIR}
+
+FONTNAME= Liberation
+FONTDIR= ${PREFIX}/lib/X11/fonts/${FONTNAME}
+INSTDAT= License.txt fonts.dir fonts.scale
+
+MKFONTSCL_CMD= ${X11BASE}/bin/mkfontscale
+MKFONTDIR_CMD= ${X11BASE}/bin/mkfontdir
+
+do-build:
+ cd ${WRKSRC} && \
+ ${MKFONTSCL_CMD}
+ ${REINPLACE_CMD} -e 's|-misc-|-redhat-|' ${WRKSRC}/fonts.scale
+ cd ${WRKSRC} && \
+ ${MKFONTDIR_CMD}
+
+do-install:
+ ${MKDIR} ${FONTDIR}
+ cd ${WRKSRC} && \
+ ${INSTALL_DATA} ${INSTDAT} *.ttf ${FONTDIR}
+
+post-install:
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/liberation-fonts-ttf/distinfo b/x11-fonts/liberation-fonts-ttf/distinfo
new file mode 100644
index 000000000000..79cc0539347e
--- /dev/null
+++ b/x11-fonts/liberation-fonts-ttf/distinfo
@@ -0,0 +1,3 @@
+MD5 (liberation-fonts-ttf-2.tar.gz) = 360dee2d73159522db3be6af8ec23294
+SHA256 (liberation-fonts-ttf-2.tar.gz) = 9393307bcd1c318dc8f8c5efe176eacd1e3998eccee03baeffd793da8ad94d9b
+SIZE (liberation-fonts-ttf-2.tar.gz) = 650283
diff --git a/x11-fonts/liberation-fonts-ttf/files/pkg-message.in b/x11-fonts/liberation-fonts-ttf/files/pkg-message.in
new file mode 100644
index 000000000000..9c1334d88b56
--- /dev/null
+++ b/x11-fonts/liberation-fonts-ttf/files/pkg-message.in
@@ -0,0 +1,10 @@
+You can start using the fonts by following these instructions:
+
+Make sure that the freetype module is loaded. If it is not, add the following
+line to the "Modules" section of your X11 / x.org configuration file:
+
+ Load "freetype"
+
+Add the following line to the "Files" section:
+
+ FontPath "%%FONTDIR%%/"
diff --git a/x11-fonts/liberation-fonts-ttf/pkg-descr b/x11-fonts/liberation-fonts-ttf/pkg-descr
new file mode 100644
index 000000000000..55a523df5fc5
--- /dev/null
+++ b/x11-fonts/liberation-fonts-ttf/pkg-descr
@@ -0,0 +1,10 @@
+LIBERATION font software consists of TrueType-OpenType formatted font software
+for rendering LIBERATION typefaces in sans serif, serif, and monospaced
+character styles.
+
+There are three sets: Sans (a substitute for Arial, Albany, Helvetica, Nimbus
+Sans L, and Bitstream Vera Sans), Serif (a substitute for Times New Roman,
+Thorndale, Nimbus Roman, and Bitstream Vera Serif) and Mono (a substitute for
+Courier New, Cumberland, Courier, Nimbus Mono L, and Bitstream Vera Sans Mono).
+
+WWW: https://www.redhat.com/promo/fonts/
diff --git a/x11-fonts/liberation-fonts-ttf/pkg-plist b/x11-fonts/liberation-fonts-ttf/pkg-plist
new file mode 100644
index 000000000000..7e5bb9fb0440
--- /dev/null
+++ b/x11-fonts/liberation-fonts-ttf/pkg-plist
@@ -0,0 +1,18 @@
+@comment $FreeBSD$
+%%FONTDIR%%/LiberationMono-Bold.ttf
+%%FONTDIR%%/LiberationMono-BoldItalic.ttf
+%%FONTDIR%%/LiberationMono-Italic.ttf
+%%FONTDIR%%/LiberationMono-Regular.ttf
+%%FONTDIR%%/LiberationSans-Bold.ttf
+%%FONTDIR%%/LiberationSans-BoldItalic.ttf
+%%FONTDIR%%/LiberationSans-Italic.ttf
+%%FONTDIR%%/LiberationSans-Regular.ttf
+%%FONTDIR%%/LiberationSerif-Bold.ttf
+%%FONTDIR%%/LiberationSerif-BoldItalic.ttf
+%%FONTDIR%%/LiberationSerif-Italic.ttf
+%%FONTDIR%%/LiberationSerif-Regular.ttf
+%%FONTDIR%%/License.txt
+%%FONTDIR%%/fonts.dir
+%%FONTDIR%%/fonts.scale
+@unexec rm %D/%%FONTDIR%%/fonts.cache-1 2>/dev/null || true
+@dirrm %%FONTDIR%%