aboutsummaryrefslogtreecommitdiff
path: root/x11-servers/xorg-server
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2012-12-14 11:02:48 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2012-12-14 11:02:48 +0000
commitfa8e22320455457ad3424f03cfcbc222695577b1 (patch)
tree2b50078136e2b59e7581d3b3e071a107e6922b9f /x11-servers/xorg-server
parentb0e7b6c04c9faa34424b3b477f56c50e317396fe (diff)
downloadports-fa8e22320455457ad3424f03cfcbc222695577b1.tar.gz
ports-fa8e22320455457ad3424f03cfcbc222695577b1.zip
Notes
Diffstat (limited to 'x11-servers/xorg-server')
-rw-r--r--x11-servers/xorg-server/Makefile5
-rw-r--r--x11-servers/xorg-server/files/extra-clang53
2 files changed, 56 insertions, 2 deletions
diff --git a/x11-servers/xorg-server/Makefile b/x11-servers/xorg-server/Makefile
index 6a7d08f273b2..ac6e6fe5202e 100644
--- a/x11-servers/xorg-server/Makefile
+++ b/x11-servers/xorg-server/Makefile
@@ -26,10 +26,11 @@ SLAVE_PORT?= no
.if defined(WITH_NEW_XORG)
XORG_VERSION= 1.10.6
-XORG_REVISION= 1
+XORG_REVISION= 2
PLIST_SUB+= OLD="@comment " NEW=""
EXTRA_PATCHES+= ${FILESDIR}/extra-hw_dmx_glxProxy_compsize.h \
- ${FILESDIR}/extra-hw_dmx_glxProxy_glxcmds.h
+ ${FILESDIR}/extra-hw_dmx_glxProxy_glxcmds.h \
+ ${FILESDIR}/extra-clang
.else
XORG_VERSION= 1.7.7
XORG_REVISION= 6
diff --git a/x11-servers/xorg-server/files/extra-clang b/x11-servers/xorg-server/files/extra-clang
new file mode 100644
index 000000000000..82817592415a
--- /dev/null
+++ b/x11-servers/xorg-server/files/extra-clang
@@ -0,0 +1,53 @@
+--- hw/xfree86/common/xf86Xinput.c.orig 2012-12-13 23:58:55.673738569 +0100
++++ hw/xfree86/common/xf86Xinput.c 2012-12-13 23:59:52.528738525 +0100
+@@ -479,7 +479,7 @@
+ MatchAttrToken(const char *attr, struct list *patterns,
+ int (*compare)(const char *attr, const char *pattern))
+ {
+- const xf86MatchGroup *group;
++ const xf86MatchGroup *group = NULL;
+
+ /* If there are no patterns, accept the match */
+ if (list_is_empty(patterns))
+--- hw/xfree86/parser/InputClass.c.orig 2012-12-14 00:03:07.149734651 +0100
++++ hw/xfree86/parser/InputClass.c 2012-12-14 00:04:09.522735172 +0100
+@@ -338,7 +338,8 @@
+ XF86ConfInputClassPtr prev;
+
+ while (ptr) {
+- xf86MatchGroup *group, *next;
++ xf86MatchGroup *group = NULL;
++ xf86MatchGroup *next;
+ char **list;
+
+ TestFree(ptr->identifier);
+--- hw/xfree86/dri2/dri2.c.orig 2012-12-14 00:06:39.680738243 +0100
++++ hw/xfree86/dri2/dri2.c 2012-12-14 00:08:14.310729622 +0100
+@@ -201,7 +201,7 @@
+ static DRI2DrawableRefPtr
+ DRI2LookupDrawableRef(DRI2DrawablePtr pPriv, XID id)
+ {
+- DRI2DrawableRefPtr ref;
++ DRI2DrawableRefPtr ref = NULL;
+
+ list_for_each_entry(ref, &pPriv->reference_list, link) {
+ if (ref->id == id)
+@@ -267,7 +267,8 @@
+ {
+ DRI2DrawablePtr pPriv = p;
+ DRI2ScreenPtr ds = pPriv->dri2_screen;
+- DRI2DrawableRefPtr ref, next;
++ DRI2DrawableRefPtr ref = NULL;
++ DRI2DrawableRefPtr next;
+ WindowPtr pWin;
+ PixmapPtr pPixmap;
+ DrawablePtr pDraw;
+@@ -534,7 +535,7 @@
+ DRI2InvalidateDrawable(DrawablePtr pDraw)
+ {
+ DRI2DrawablePtr pPriv = DRI2GetDrawable(pDraw);
+- DRI2DrawableRefPtr ref;
++ DRI2DrawableRefPtr ref = NULL;
+
+ if (!pPriv)
+ return;