aboutsummaryrefslogtreecommitdiff
path: root/x11-servers
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2017-02-11 18:31:47 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2017-02-11 18:31:47 +0000
commitd70b127b51503450f202881c246ddc680840ba88 (patch)
tree87ac16ae0ef38dd22d3149b9896a7627d6e7860b /x11-servers
parentbe5779eecc0b8c402fd4a31738394a8c88ef9c3a (diff)
downloadports-d70b127b51503450f202881c246ddc680840ba88.tar.gz
ports-d70b127b51503450f202881c246ddc680840ba88.zip
XWayland is an X Server running as a Wayland client, thus capable of displaying
native X11 client applications in a Wayland compositor environment. WWW: https://wayland.freedesktop.org/xserver.html
Notes
Notes: svn path=/head/; revision=433900
Diffstat (limited to 'x11-servers')
-rw-r--r--x11-servers/Makefile1
-rw-r--r--x11-servers/xephyr/Makefile2
-rw-r--r--x11-servers/xorg-dmx/Makefile3
-rw-r--r--x11-servers/xorg-nestserver/Makefile3
-rw-r--r--x11-servers/xorg-server/Makefile7
-rw-r--r--x11-servers/xorg-vfbserver/Makefile3
-rw-r--r--x11-servers/xwayland/Makefile34
-rw-r--r--x11-servers/xwayland/distinfo3
-rw-r--r--x11-servers/xwayland/pkg-descr4
9 files changed, 53 insertions, 7 deletions
diff --git a/x11-servers/Makefile b/x11-servers/Makefile
index 84ed43583146..fbcd958eda91 100644
--- a/x11-servers/Makefile
+++ b/x11-servers/Makefile
@@ -12,5 +12,6 @@
SUBDIR += xorg-nestserver
SUBDIR += xorg-server
SUBDIR += xorg-vfbserver
+ SUBDIR += xwayland
.include <bsd.port.subdir.mk>
diff --git a/x11-servers/xephyr/Makefile b/x11-servers/xephyr/Makefile
index 78c57511c7a0..1677ff5b5ed6 100644
--- a/x11-servers/xephyr/Makefile
+++ b/x11-servers/xephyr/Makefile
@@ -21,7 +21,7 @@ OPTIONS_EXCLUDE=DEVD HAL SUID
USE_XORG= x11 xcb
CONFIGURE_ARGS+=--enable-xephyr --disable-dmx --disable-xnest --disable-xvfb \
- --enable-kdrive
+ --enable-kdrive --disable-xwayland
PLIST_FILES= bin/Xephyr man/man1/Xephyr.1.gz
diff --git a/x11-servers/xorg-dmx/Makefile b/x11-servers/xorg-dmx/Makefile
index 46753306568f..ff7c3a1096b6 100644
--- a/x11-servers/xorg-dmx/Makefile
+++ b/x11-servers/xorg-dmx/Makefile
@@ -15,7 +15,8 @@ OPTIONS_EXCLUDE=DEVD HAL SUID
USE_XORG= dmx dmxproto x11 xaw7 xext xfixes xi xmu xpm xrender xres xt xtst
-CONFIGURE_ARGS+=--enable-dmx --disable-xephyr --disable-xnest --disable-xvfb
+CONFIGURE_ARGS+=--enable-dmx --disable-xephyr --disable-xnest --disable-xvfb \
+ --disable-xwayland
do-install:
cd ${WRKSRC}/hw/dmx; DESTDIR=${STAGEDIR} ${MAKE} install
diff --git a/x11-servers/xorg-nestserver/Makefile b/x11-servers/xorg-nestserver/Makefile
index eb5ed8138b2c..2f5132fec5cc 100644
--- a/x11-servers/xorg-nestserver/Makefile
+++ b/x11-servers/xorg-nestserver/Makefile
@@ -21,7 +21,8 @@ OPTIONS_EXCLUDE=DEVD HAL SUID
USE_XORG= x11 xext xfont2
-CONFIGURE_ARGS+=--enable-xnest --disable-dmx --disable-xephyr --disable-xvfb
+CONFIGURE_ARGS+=--enable-xnest --disable-dmx --disable-xephyr --disable-xvfb \
+ --disable-xwayland
PLIST_FILES= bin/Xnest man/man1/Xnest.1.gz
diff --git a/x11-servers/xorg-server/Makefile b/x11-servers/xorg-server/Makefile
index 2d1908986be8..4f2478b93a7f 100644
--- a/x11-servers/xorg-server/Makefile
+++ b/x11-servers/xorg-server/Makefile
@@ -44,10 +44,10 @@ USE_XORG+= bigreqsproto compositeproto damageproto dri2proto dri3proto \
xineramaproto xkbfile xproto xshmfence xtrans
CONFIGURE_ARGS+=--without-doxygen --without-xmlto --without-fop \
--localstatedir=/var --with-shared-memory-dir=/tmp \
- --without-dtrace --disable-xwayland --enable-glamor
+ --without-dtrace --enable-glamor
INSTALL_TARGET= install-strip
-.if ${SLAVE_PORT} == "no" || ${PORTNAME} == "xephyr"
+.if ${SLAVE_PORT} == "no" || ${PORTNAME} == "xephyr" || ${PORTNAME} == "xwayland"
LIB_DEPENDS+= libdrm.so:graphics/libdrm \
libepoxy.so:graphics/libepoxy
.else
@@ -57,7 +57,8 @@ BUILD_DEPENDS+= libepoxy>0:graphics/libepoxy # only for configure
.if ${SLAVE_PORT} == "no"
USE_GL+= gbm
USE_XORG+= pciaccess xf86dgaproto xf86vidmodeproto
-CONFIGURE_ARGS+=--disable-dmx --disable-xephyr --disable-xnest --disable-xvfb
+CONFIGURE_ARGS+=--disable-dmx --disable-xephyr --disable-xnest --disable-xvfb \
+ --disable-xwayland
SUB_FILES= pkg-install pkg-deinstall
.else
CONFIGURE_ARGS+=--disable-xorg
diff --git a/x11-servers/xorg-vfbserver/Makefile b/x11-servers/xorg-vfbserver/Makefile
index 679c8f702f4e..edf861a908e6 100644
--- a/x11-servers/xorg-vfbserver/Makefile
+++ b/x11-servers/xorg-vfbserver/Makefile
@@ -19,7 +19,8 @@ OPTIONS_EXCLUDE=DEVD HAL SUID
USE_XORG= xfont2
-CONFIGURE_ARGS+=--enable-xvfb --disable-dmx --disable-xephyr --disable-xnest
+CONFIGURE_ARGS+=--enable-xvfb --disable-dmx --disable-xephyr --disable-xnest \
+ --disable-xwayland
PLIST_FILES= bin/Xvfb man/man1/Xvfb.1.gz
diff --git a/x11-servers/xwayland/Makefile b/x11-servers/xwayland/Makefile
new file mode 100644
index 000000000000..5a83d704dba0
--- /dev/null
+++ b/x11-servers/xwayland/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= xwayland
+PORTVERSION= 1.19.1
+
+COMMENT= X Clients under Wayland
+
+LICENSE= MIT
+
+BUILD_DEPENDS= /usr/local/libdata/pkgconfig/wayland-protocols.pc:graphics/wayland-protocols
+LIB_DEPENDS= libwayland-client.so:graphics/wayland \
+ libinput.so:x11/libinput
+
+MASTERDIR= ${.CURDIR}/../xorg-server
+DESCR= ${.CURDIR}/pkg-descr
+DISTINFO_FILE= ${.CURDIR}/distinfo
+PATCHDIR= ${.CURDIR}/files
+
+SLAVE_PORT= yes
+OPTIONS_EXCLUDE=DEVD HAL SUID
+
+USE_XORG= x11 xext xfont2
+USE_GL+= egl gbm
+
+CONFIGURE_ARGS+= --disable-docs --disable-devel-docs \
+ --enable-xwayland --disable-xorg --disable-xvfb --disable-xnest \
+ --disable-xquartz --disable-xwin
+
+PLIST_FILES= bin/Xwayland
+
+do-install:
+ cd ${WRKSRC}/hw/xwayland; DESTDIR=${STAGEDIR} ${MAKE_CMD} install
+
+.include "${MASTERDIR}/Makefile"
diff --git a/x11-servers/xwayland/distinfo b/x11-servers/xwayland/distinfo
new file mode 100644
index 000000000000..2083f2d9a628
--- /dev/null
+++ b/x11-servers/xwayland/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1484388904
+SHA256 (xorg/xserver/xorg-server-1.19.1.tar.bz2) = 79ae2cf39d3f6c4a91201d8dad549d1d774b3420073c5a70d390040aa965a7fb
+SIZE (xorg/xserver/xorg-server-1.19.1.tar.bz2) = 6041792
diff --git a/x11-servers/xwayland/pkg-descr b/x11-servers/xwayland/pkg-descr
new file mode 100644
index 000000000000..425a0ee992a4
--- /dev/null
+++ b/x11-servers/xwayland/pkg-descr
@@ -0,0 +1,4 @@
+XWayland is an X Server running as a Wayland client, thus capable of displaying
+native X11 client applications in a Wayland compositor environment.
+
+WWW: https://wayland.freedesktop.org/xserver.html