aboutsummaryrefslogtreecommitdiff
path: root/x11-servers
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-01-25 16:26:41 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-01-25 16:26:41 +0000
commit78328a98958b9dc53bcc04119d3e02259f27290d (patch)
tree224053494f701093e155dc8b19bcb22f3862c1ee /x11-servers
parent4b23f7b9b5ead0aaddbc702bd3cff87e961ba32a (diff)
downloadports-78328a98958b9dc53bcc04119d3e02259f27290d.tar.gz
ports-78328a98958b9dc53bcc04119d3e02259f27290d.zip
x11-servers/xorg-server: expose UDEV support for evdev hotplug
UDEV builds Xorg against libudev-devd, allowing automatic detection of /dev/input/* (evdev) devices with xf86-input-libinput or xf86-input-evdev. PR: 222609 Submitted by: Greg V <greg@unrelenting.technology> Tested by: Ivan <bsd@abinet.ru>, manu Approved by: x11 (bapt via IRC)
Notes
Notes: svn path=/head/; revision=524048
Diffstat (limited to 'x11-servers')
-rw-r--r--x11-servers/xephyr/Makefile2
-rw-r--r--x11-servers/xorg-dmx/Makefile2
-rw-r--r--x11-servers/xorg-nestserver/Makefile2
-rw-r--r--x11-servers/xorg-server/Makefile12
-rw-r--r--x11-servers/xorg-server/pkg-plist1
-rw-r--r--x11-servers/xorg-vfbserver/Makefile2
-rw-r--r--x11-servers/xwayland/Makefile2
7 files changed, 16 insertions, 7 deletions
diff --git a/x11-servers/xephyr/Makefile b/x11-servers/xephyr/Makefile
index 1677ff5b5ed6..38b5a720316c 100644
--- a/x11-servers/xephyr/Makefile
+++ b/x11-servers/xephyr/Makefile
@@ -16,7 +16,7 @@ MASTERDIR= ${.CURDIR}/../xorg-server
DESCR= ${.CURDIR}/pkg-descr
SLAVE_PORT= yes
-OPTIONS_EXCLUDE=DEVD HAL SUID
+OPTIONS_EXCLUDE=DEVD HAL SUID UDEV
USE_XORG= x11 xcb
diff --git a/x11-servers/xorg-dmx/Makefile b/x11-servers/xorg-dmx/Makefile
index 5e13159778cf..f78c64797b8b 100644
--- a/x11-servers/xorg-dmx/Makefile
+++ b/x11-servers/xorg-dmx/Makefile
@@ -11,7 +11,7 @@ MASTERDIR= ${.CURDIR}/../xorg-server
DESCR= ${.CURDIR}/pkg-descr
SLAVE_PORT= yes
-OPTIONS_EXCLUDE=DEVD HAL SUID
+OPTIONS_EXCLUDE=DEVD HAL SUID UDEV
USE_XORG= dmx xorgproto x11 xaw7 xext xfixes xi xmu xpm xrender xres xt xtst
diff --git a/x11-servers/xorg-nestserver/Makefile b/x11-servers/xorg-nestserver/Makefile
index 349fc778b02e..0c2f122987ba 100644
--- a/x11-servers/xorg-nestserver/Makefile
+++ b/x11-servers/xorg-nestserver/Makefile
@@ -17,7 +17,7 @@ PATCHDIR= ${.CURDIR}/files
RUN_DEPENDS= xkeyboard-config>=2.5:x11/xkeyboard-config
SLAVE_PORT= yes
-OPTIONS_EXCLUDE=DEVD HAL SUID
+OPTIONS_EXCLUDE=DEVD HAL SUID UDEV
USE_XORG= x11 xext xfont2
diff --git a/x11-servers/xorg-server/Makefile b/x11-servers/xorg-server/Makefile
index 837bbd612407..f392309b28b0 100644
--- a/x11-servers/xorg-server/Makefile
+++ b/x11-servers/xorg-server/Makefile
@@ -22,9 +22,10 @@ SLAVE_PORT?= no
OPTIONS_SUB= yes
OPTIONS_DEFINE= SUID
OPTIONS_RADIO= CONF
-OPTIONS_RADIO_CONF= DEVD HAL
+OPTIONS_RADIO_CONF= DEVD HAL UDEV
DEVD_DESC= Use devd for autoconfiguration of input devices
HAL_DESC= Use hald for autoconfiguration of input devices
+UDEV_DESC= Use udev via libudev-devd for autoconfiguration of input devices
SUID_DESC= Install the Xorg server with setuid bit set
OPTIONS_DEFAULT=DEVD SUID
@@ -52,7 +53,7 @@ USE_XORG+= pixman xau xdmcp xfont xkbfile xorgproto xshmfence xtrans
CONFIGURE_ARGS+=--without-doxygen --without-xmlto --without-fop \
--with-default-font-path="$$(${DEFAULT_FONTPATH_CMD})" \
--localstatedir=/var --with-shared-memory-dir=/tmp \
- --disable-config-udev --disable-config-udev-kms \
+ --disable-config-udev-kms --disable-systemd-logind \
--without-dtrace --enable-glamor
INSTALL_TARGET= install-strip
@@ -92,6 +93,13 @@ CONFIGURE_ARGS+= --enable-config-hal
CONFIGURE_ARGS+= --disable-config-hal
.endif
+.if ${PORT_OPTIONS:MUDEV}
+LIB_DEPENDS+= libudev.so:devel/libudev-devd
+CONFIGURE_ARGS+= --enable-config-udev
+.else
+CONFIGURE_ARGS+= --disable-config-udev
+.endif
+
# We handle Xorg setuid in the plist. This allows to build xorg-server as a user.
CONFIGURE_ARGS+=--disable-install-setuid
diff --git a/x11-servers/xorg-server/pkg-plist b/x11-servers/xorg-server/pkg-plist
index def8c4adeac2..cf97beb10ddc 100644
--- a/x11-servers/xorg-server/pkg-plist
+++ b/x11-servers/xorg-server/pkg-plist
@@ -185,6 +185,7 @@ man/man4/fbdevhw.4.gz
man/man4/modesetting.4.gz
man/man5/xorg.conf.5.gz
man/man5/xorg.conf.d.5.gz
+%%UDEV%%share/X11/xorg.conf.d/10-quirks.conf
share/aclocal/xorg-server.m4
@dir etc/X11/xorg.conf.d
@dir %%FONTPATHD%%
diff --git a/x11-servers/xorg-vfbserver/Makefile b/x11-servers/xorg-vfbserver/Makefile
index 53e91d1d08d9..69e5110818d7 100644
--- a/x11-servers/xorg-vfbserver/Makefile
+++ b/x11-servers/xorg-vfbserver/Makefile
@@ -15,7 +15,7 @@ DISTINFO_FILE= ${.CURDIR}/distinfo
PATCHDIR= ${.CURDIR}/files
SLAVE_PORT= yes
-OPTIONS_EXCLUDE=DEVD HAL SUID
+OPTIONS_EXCLUDE=DEVD HAL SUID UDEV
USE_XORG= xfont2
diff --git a/x11-servers/xwayland/Makefile b/x11-servers/xwayland/Makefile
index d71bff405d72..d929f631b54d 100644
--- a/x11-servers/xwayland/Makefile
+++ b/x11-servers/xwayland/Makefile
@@ -21,7 +21,7 @@ DISTINFO_FILE= ${.CURDIR}/distinfo
PATCHDIR= ${.CURDIR}/files
SLAVE_PORT= yes
-OPTIONS_EXCLUDE=DEVD HAL SUID
+OPTIONS_EXCLUDE=DEVD HAL SUID UDEV
USE_XORG= x11 xext xfont2
USE_GL+= egl gbm