aboutsummaryrefslogtreecommitdiff
path: root/x11-servers
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-05-29 10:14:51 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-05-29 10:14:51 +0000
commit87724382074b0d08d33bd8f6ac15cdcebf16b44b (patch)
treee6555ba8f0c0fa2795051cd3e51e7e9dda393e0d /x11-servers
parent2f19aa57df7f9784979bb25ec8d41a709accfbbf (diff)
downloadports-87724382074b0d08d33bd8f6ac15cdcebf16b44b.tar.gz
ports-87724382074b0d08d33bd8f6ac15cdcebf16b44b.zip
x11-servers/xwayland-devel: simplify r536952
Notes
Notes: svn path=/head/; revision=536962
Diffstat (limited to 'x11-servers')
-rw-r--r--x11-servers/xwayland-devel/Makefile2
-rw-r--r--x11-servers/xwayland-devel/files/patch-hw_xwayland_xwayland-glx.c11
2 files changed, 5 insertions, 8 deletions
diff --git a/x11-servers/xwayland-devel/Makefile b/x11-servers/xwayland-devel/Makefile
index 49a542fb6edd..51ea9f0093dc 100644
--- a/x11-servers/xwayland-devel/Makefile
+++ b/x11-servers/xwayland-devel/Makefile
@@ -4,7 +4,7 @@ PORTNAME= xwayland
DISTVERSIONPREFIX= xorg-server-
DISTVERSION= 1.20.0-655
DISTVERSIONSUFFIX= -g${GL_COMMIT:C/(.{12}).*/\1/}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-servers
PKGNAMESUFFIX= -devel
diff --git a/x11-servers/xwayland-devel/files/patch-hw_xwayland_xwayland-glx.c b/x11-servers/xwayland-devel/files/patch-hw_xwayland_xwayland-glx.c
index 30b6b529dd3d..74ad9d2cbdae 100644
--- a/x11-servers/xwayland-devel/files/patch-hw_xwayland_xwayland-glx.c
+++ b/x11-servers/xwayland-devel/files/patch-hw_xwayland_xwayland-glx.c
@@ -2,24 +2,21 @@ https://gitlab.freedesktop.org/xorg/xserver/-/issues/1032
--- hw/xwayland/xwayland-glx.c.orig 2020-05-20 07:13:28 UTC
+++ hw/xwayland/xwayland-glx.c
-@@ -343,6 +343,10 @@ egl_screen_probe(ScreenPtr pScreen)
+@@ -343,6 +343,9 @@ egl_screen_probe(ScreenPtr pScreen)
struct xwl_screen *xwl_screen = xwl_screen_get(pScreen);
__GLXscreen *base;
-+#ifdef XWL_HAS_EGLSTREAM
-+ return NULL;
-+#endif
++ if (xwl_screen->egl_backend == &xwl_screen->eglstream_backend)
++ return NULL;
+
if (enableIndirectGLX)
return NULL; /* not implemented */
-@@ -353,6 +357,9 @@ egl_screen_probe(ScreenPtr pScreen)
+@@ -353,6 +356,7 @@ egl_screen_probe(ScreenPtr pScreen)
base->destroy = egl_screen_destroy;
base->createDrawable = egl_create_glx_drawable;
/* base.swapInterval = NULL; */
-+#ifndef XWL_HAS_EGLSTREAM
+ base->glvnd = strdup("mesa");
-+#endif
screen->display = xwl_screen->glamor_ctx->display;