aboutsummaryrefslogtreecommitdiff
path: root/x11-servers
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-05-29 08:40:01 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-05-29 08:40:01 +0000
commit1c76ca5124d2bb3537d8b04cab02fd8833090b71 (patch)
treea4fcd8f5db9838c1aefef957f9f62747bb2a0d7a /x11-servers
parent0f54fba793c7b19a11bed03fedcc0b60ee4ebd2c (diff)
downloadports-1c76ca5124d2bb3537d8b04cab02fd8833090b71.tar.gz
ports-1c76ca5124d2bb3537d8b04cab02fd8833090b71.zip
Notes
Diffstat (limited to 'x11-servers')
-rw-r--r--x11-servers/xwayland-devel/Makefile1
-rw-r--r--x11-servers/xwayland-devel/files/patch-hw_xwayland_xwayland-glx.c25
2 files changed, 26 insertions, 0 deletions
diff --git a/x11-servers/xwayland-devel/Makefile b/x11-servers/xwayland-devel/Makefile
index cd8a1a084deb..49a542fb6edd 100644
--- a/x11-servers/xwayland-devel/Makefile
+++ b/x11-servers/xwayland-devel/Makefile
@@ -4,6 +4,7 @@ PORTNAME= xwayland
DISTVERSIONPREFIX= xorg-server-
DISTVERSION= 1.20.0-655
DISTVERSIONSUFFIX= -g${GL_COMMIT:C/(.{12}).*/\1/}
+PORTREVISION= 1
CATEGORIES= x11-servers
PKGNAMESUFFIX= -devel
diff --git a/x11-servers/xwayland-devel/files/patch-hw_xwayland_xwayland-glx.c b/x11-servers/xwayland-devel/files/patch-hw_xwayland_xwayland-glx.c
new file mode 100644
index 000000000000..30b6b529dd3d
--- /dev/null
+++ b/x11-servers/xwayland-devel/files/patch-hw_xwayland_xwayland-glx.c
@@ -0,0 +1,25 @@
+https://gitlab.freedesktop.org/xorg/xserver/-/issues/1032
+
+--- hw/xwayland/xwayland-glx.c.orig 2020-05-20 07:13:28 UTC
++++ hw/xwayland/xwayland-glx.c
+@@ -343,6 +343,10 @@ egl_screen_probe(ScreenPtr pScreen)
+ struct xwl_screen *xwl_screen = xwl_screen_get(pScreen);
+ __GLXscreen *base;
+
++#ifdef XWL_HAS_EGLSTREAM
++ return NULL;
++#endif
++
+ if (enableIndirectGLX)
+ return NULL; /* not implemented */
+
+@@ -353,6 +357,9 @@ egl_screen_probe(ScreenPtr pScreen)
+ base->destroy = egl_screen_destroy;
+ base->createDrawable = egl_create_glx_drawable;
+ /* base.swapInterval = NULL; */
++#ifndef XWL_HAS_EGLSTREAM
++ base->glvnd = strdup("mesa");
++#endif
+
+ screen->display = xwl_screen->glamor_ctx->display;
+