aboutsummaryrefslogtreecommitdiff
path: root/x11-servers
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2005-11-30 07:52:59 +0000
committerEric Anholt <anholt@FreeBSD.org>2005-11-30 07:52:59 +0000
commit4e4688a5ea4630fde39dc063162f4b144ca4e934 (patch)
tree5f8b2c0d0400bf3ee15d6147c47aae477462b940 /x11-servers
parentbcd70679f704808a8bf90d16df8f062930d5563e (diff)
downloadports-4e4688a5ea4630fde39dc063162f4b144ca4e934.tar.gz
ports-4e4688a5ea4630fde39dc063162f4b144ca4e934.zip
Notes
Diffstat (limited to 'x11-servers')
-rw-r--r--x11-servers/xorg-server/Makefile2
-rw-r--r--x11-servers/xorg-server/files/patch-nv_hw.c22
2 files changed, 23 insertions, 1 deletions
diff --git a/x11-servers/xorg-server/Makefile b/x11-servers/xorg-server/Makefile
index adae25b80c89..77687d270a0c 100644
--- a/x11-servers/xorg-server/Makefile
+++ b/x11-servers/xorg-server/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xorg-server
PORTVERSION= 6.8.2
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= x11-servers
MASTER_SITES= ${MASTER_SITE_XORG}
MASTER_SITE_SUBDIR= X11R${PORTVERSION}/src
diff --git a/x11-servers/xorg-server/files/patch-nv_hw.c b/x11-servers/xorg-server/files/patch-nv_hw.c
new file mode 100644
index 000000000000..bd3a12b8aa3b
--- /dev/null
+++ b/x11-servers/xorg-server/files/patch-nv_hw.c
@@ -0,0 +1,22 @@
+--- programs/Xserver/hw/xfree86/drivers/nv/nv_hw.c.orig Sat Oct 8 20:13:06 2005
++++ programs/Xserver/hw/xfree86/drivers/nv/nv_hw.c Sat Oct 8 20:14:53 2005
+@@ -915,7 +915,7 @@
+ RIVA_HW_STATE *state
+ )
+ {
+- int i;
++ int i, j;
+
+ pNv->PMC[0x0140/4] = 0x00000000;
+ pNv->PMC[0x0200/4] = 0xFFFF00FF;
+@@ -1162,6 +1162,10 @@
+ pNv->PGRAPH[0x008C/4] = 0x60de8051;
+ pNv->PGRAPH[0x0090/4] = 0x00008000;
+ pNv->PGRAPH[0x0610/4] = 0x00be3c5f;
++
++ j = pNv->REGS[0x1540/4] & 0xff;
++ for(i = 0; !(j & 1); j >>= 1, i++);
++ pNv->PGRAPH[0x5000/4] = i;
+
+ if((pNv->Chipset & 0xfff0) == 0x0040) {
+ pNv->PGRAPH[0x09b0/4] = 0x83280fff;