aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/gtk-bluecurve-theme/Makefile
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2003-06-26 22:58:32 +0000
committerAde Lovett <ade@FreeBSD.org>2003-06-26 22:58:32 +0000
commitb2fd75e43812932b61dab72c80fedba5f9715b82 (patch)
treec06ec55813ad4aa528be251b248e0309e8332282 /x11-themes/gtk-bluecurve-theme/Makefile
parent061c49565fbb5c5cfff7bc561b07c79fbade8f24 (diff)
downloadports-b2fd75e43812932b61dab72c80fedba5f9715b82.tar.gz
ports-b2fd75e43812932b61dab72c80fedba5f9715b82.zip
Notes
Diffstat (limited to 'x11-themes/gtk-bluecurve-theme/Makefile')
-rw-r--r--x11-themes/gtk-bluecurve-theme/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/x11-themes/gtk-bluecurve-theme/Makefile b/x11-themes/gtk-bluecurve-theme/Makefile
index db525cf87a5d..0b58b28473f8 100644
--- a/x11-themes/gtk-bluecurve-theme/Makefile
+++ b/x11-themes/gtk-bluecurve-theme/Makefile
@@ -15,14 +15,14 @@ DISTFILES= redhat-artwork-${PORTVERSION}-${RH_SUBVERSION}.src.rpm
MAINTAINER= rzheka@users.sourceforge.net
COMMENT= Bluecurve unified-look theme for GTK1 and GTK2 from RedHat 8.0
-BUILD_DEPENDS= rpm2cpio:${PORTSDIR}/archivers/rpm2cpio \
- libtool:${PORTSDIR}/devel/libtool
+BUILD_DEPENDS= rpm2cpio:${PORTSDIR}/archivers/rpm2cpio
WRKSRC= ${WRKDIR}/redhat-artwork-${PORTVERSION}
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_GNOME= gdkpixbuf
USE_REINPLACE= yes
+USE_LIBTOOL= yes
RH_SUBVERSION= 1
THEMES_SUBDIRS= ${WRKSRC}/art/gtk/Bluecurve1
@@ -57,6 +57,9 @@ post-patch:
@${REINPLACE_CMD} -e 's#-O2#${CFLAGS}#' ${WRKSRC}/art/gtk/Bluecurve1/Makefile
@${REINPLACE_CMD} -e 's#-O2#${CFLAGS}#' ${WRKSRC}/art/gtk/Bluecurve/Makefile
+do-configure:
+ @${DO_NADA}
+
do-build:
@for theme_dir in ${THEMES_SUBDIRS};do \
(cd $$theme_dir; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}); \