aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/gtk-bluecurve-theme
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2007-03-08 16:35:08 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2007-03-08 16:35:08 +0000
commitc0da0587116803d6159b5dc17eabf0bdc51cbae6 (patch)
tree4c4eaee654aedb2bbb2eb50969ec9855098ea94a /x11-themes/gtk-bluecurve-theme
parent7f0694bcb06ab4d3425c928a218dfd3b35101fd9 (diff)
downloadports-c0da0587116803d6159b5dc17eabf0bdc51cbae6.tar.gz
ports-c0da0587116803d6159b5dc17eabf0bdc51cbae6.zip
Notes
Diffstat (limited to 'x11-themes/gtk-bluecurve-theme')
-rw-r--r--x11-themes/gtk-bluecurve-theme/Makefile62
-rw-r--r--x11-themes/gtk-bluecurve-theme/pkg-descr4
2 files changed, 21 insertions, 45 deletions
diff --git a/x11-themes/gtk-bluecurve-theme/Makefile b/x11-themes/gtk-bluecurve-theme/Makefile
index 45226e7d0807..2f8949a45a0c 100644
--- a/x11-themes/gtk-bluecurve-theme/Makefile
+++ b/x11-themes/gtk-bluecurve-theme/Makefile
@@ -6,30 +6,14 @@
#
PORTNAME= gtk-bluecurve-theme
-PORTREVISION= 2
-COMMENT= The Bluecurve GTK+ 1.x and 2.x themes
+COMMENT= The Bluecurve GTK+ themes
MASTERDIR= ${.CURDIR}/../bluecurve-themes
-EXTRA_PATCHES= ${WRKDIR}/redhat-artwork-0.122-padding-fix.patch
-PATCH_STRIP= -p1
-
-# GTK+ 1.x theme engine
-USE_GNOME+= gdkpixbuf
-GTK1_CFLAGS= `${LOCALBASE}/bin/gdk-pixbuf-config --cflags`
-GTK1_LIBS= `${LOCALBASE}/bin/gdk-pixbuf-config --libs`
-GTK1_WRKSRC= ${WRKSRC}/art/gtk/Bluecurve1
-GTK1_RCDIR= gtk
-GTK1_SOURCES= bluecurve1_theme_main.c bluecurve1_theme_draw.c
-GTK1_ENGINEDIR= lib/gtk/themes/engines
-
-# GTK+ 2.x theme engine
USE_GNOME+= gtk20
GTK2_CFLAGS= `${LOCALBASE}/bin/pkg-config --cflags gtk+-2.0`
GTK2_LIBS= `${LOCALBASE}/bin/pkg-config --libs gtk+-2.0`
-GTK2_WRKSRC= ${WRKSRC}/art/gtk/Bluecurve
-GTK2_RCDIR= gtk-2.0
GTK2_SOURCES= bluecurve_rc_style.c bluecurve_style.c bluecurve_theme_main.c
GTK2_ENGINEDIR= lib/gtk-2.0/${GTK2_VERSION}/engines
@@ -37,31 +21,25 @@ PLIST= ${WRKDIR}/pkg-plist
EXTRA_STYLES= BerriesAndCream Gnome Grape Lime Slate Strawberry Tangerine
post-patch:
-.for v in 1 2
-. for s in ${EXTRA_STYLES}
+.for s in ${EXTRA_STYLES}
@${REINPLACE_CMD} -e 's|/usr|${LOCALBASE}|' \
- ${WRKSRC}/art/gtk/Bluecurve-${s}/${GTK${v}_RCDIR}/gtkrc
-. endfor
+ ${WRKSRC}/art/gtk/Bluecurve-${s}/gtk-2.0/gtkrc
.endfor
do-build:
-.for v in 1 2
- cd ${GTK${v}_WRKSRC} && \
+ cd ${WRKSRC}/art/gtk/Bluecurve && \
${CC} ${CFLAGS} -Wl,-export-dynamic -shared -fPIC \
- ${GTK${v}_CFLAGS} ${GTK${v}_LIBS} -o libbluecurve.so \
- ${GTK${v}_SOURCES}
-.endfor
+ ${GTK2_CFLAGS} ${GTK2_LIBS} -o libbluecurve.so \
+ ${GTK2_SOURCES}
pre-install:
@${RM} -f ${PLIST}
-.for v in 1 2
- @${ECHO_CMD} "${GTK${v}_ENGINEDIR}/libbluecurve.so" >> ${PLIST}
- @${ECHO_CMD} "share/themes/Bluecurve/${GTK${v}_RCDIR}/gtkrc" >> ${PLIST}
- @${ECHO_CMD} "@dirrm share/themes/Bluecurve/${GTK${v}_RCDIR}" >> ${PLIST}
-. for s in ${EXTRA_STYLES}
- @${ECHO_CMD} "share/themes/Bluecurve-${s}/${GTK${v}_RCDIR}/gtkrc" >> ${PLIST}
- @${ECHO_CMD} "@dirrm share/themes/Bluecurve-${s}/${GTK${v}_RCDIR}" >> ${PLIST}
-. endfor
+ @${ECHO_CMD} "${GTK2_ENGINEDIR}/libbluecurve.so" >> ${PLIST}
+ @${ECHO_CMD} "share/themes/Bluecurve/gtk-2.0/gtkrc" >> ${PLIST}
+ @${ECHO_CMD} "@dirrm share/themes/Bluecurve/gtk-2.0" >> ${PLIST}
+.for s in ${EXTRA_STYLES}
+ @${ECHO_CMD} "share/themes/Bluecurve-${s}/gtk-2.0/gtkrc" >> ${PLIST}
+ @${ECHO_CMD} "@dirrm share/themes/Bluecurve-${s}/gtk-2.0" >> ${PLIST}
.endfor
@${ECHO_CMD} "@dirrmtry share/themes/Bluecurve" >> ${PLIST}
.for s in ${EXTRA_STYLES}
@@ -69,15 +47,13 @@ pre-install:
.endfor
do-install:
-.for v in 1 2
- ${MKDIR} ${PREFIX}/${GTK${v}_ENGINEDIR}
- ${INSTALL_PROGRAM} ${GTK${v}_WRKSRC}/libbluecurve.so ${PREFIX}/${GTK${v}_ENGINEDIR}
- ${MKDIR} ${PREFIX}/share/themes/Bluecurve/${GTK${v}_RCDIR}
- ${INSTALL_DATA} ${GTK${v}_WRKSRC}/${GTK${v}_RCDIR}/gtkrc ${PREFIX}/share/themes/Bluecurve/${GTK${v}_RCDIR}
-. for s in ${EXTRA_STYLES}
- ${MKDIR} ${PREFIX}/share/themes/Bluecurve-${s}/${GTK${v}_RCDIR}
- ${INSTALL_DATA} ${WRKSRC}/art/gtk/Bluecurve-${s}/${GTK${v}_RCDIR}/gtkrc ${PREFIX}/share/themes/Bluecurve-${s}/${GTK${v}_RCDIR}
-. endfor
+ ${MKDIR} ${PREFIX}/${GTK2_ENGINEDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/art/gtk/Bluecurve/libbluecurve.so ${PREFIX}/${GTK2_ENGINEDIR}
+ ${MKDIR} ${PREFIX}/share/themes/Bluecurve/gtk-2.0
+ ${INSTALL_DATA} ${WRKSRC}/art/gtk/Bluecurve/gtk-2.0/gtkrc ${PREFIX}/share/themes/Bluecurve/gtk-2.0
+.for s in ${EXTRA_STYLES}
+ ${MKDIR} ${PREFIX}/share/themes/Bluecurve-${s}/gtk-2.0
+ ${INSTALL_DATA} ${WRKSRC}/art/gtk/Bluecurve-${s}/gtk-2.0/gtkrc ${PREFIX}/share/themes/Bluecurve-${s}/gtk-2.0
.endfor
.include "${MASTERDIR}/Makefile"
diff --git a/x11-themes/gtk-bluecurve-theme/pkg-descr b/x11-themes/gtk-bluecurve-theme/pkg-descr
index 007846ce2d9c..766ed5e49e9f 100644
--- a/x11-themes/gtk-bluecurve-theme/pkg-descr
+++ b/x11-themes/gtk-bluecurve-theme/pkg-descr
@@ -1,9 +1,9 @@
Bluecurve is a set of themes created by the Red Hat Artwork project.
It attempts to provide an unified look for the open source desktop.
-This port contains the Bluecurve GTK+ 1.x and 2.x themes.
+This port contains the Bluecurve GTK+ themes.
-WWW: http://fedora.redhat.com/projects/artwork/
+WWW: http://fedoraproject.org/wiki/Artwork/
- Ryzhyk Eugeney
rzheka@users.sourceforge.net