aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/gtk-engines2/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>1998-12-28 15:54:54 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>1998-12-28 15:54:54 +0000
commit05fca6308aba2ef83ef34438152f345529b7c2b6 (patch)
treeae0f52568a6732b0835dd5502dc00263151be0f6 /x11-themes/gtk-engines2/Makefile
parentd68cc2a8ccee2c49d6da1b03fdb778da51e4db23 (diff)
Notes
Diffstat (limited to 'x11-themes/gtk-engines2/Makefile')
-rw-r--r--x11-themes/gtk-engines2/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/x11-themes/gtk-engines2/Makefile b/x11-themes/gtk-engines2/Makefile
new file mode 100644
index 000000000000..a02a0e2b6231
--- /dev/null
+++ b/x11-themes/gtk-engines2/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: gtk-engines
+# Version required: 0.1
+# Date Created: 23 Dec 1998
+# Whom: Vanilla I. Shu <vanilla@FreeBSD.ORG>
+#
+# $Id$
+#
+
+DISTNAME= gtk-engines-0.1
+CATEGORIES= x11-toolkits
+MASTER_SITES= ftp://ftp.jimpick.com/pub/mirrors/gnome/sources/ \
+ ftp://ftp.gnome.org/pub/GNOME/sources/
+
+MAINTAINER= vanilla@FreeBSD.ORG
+
+LIB_DEPENDS= gtk11d.1:${PORTSDIR}/x11-toolkits/gtk11-devel \
+ gdk_imlib.1:${PORTSDIR}/graphics/imlib
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= GTK_CONFIG="${X11BASE}/bin/gtk11d-config" \
+ GLIB_CONFIG="${LOCALBASE}/bin/glib11d-config"
+
+post-install:
+ @${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
+
+.include <bsd.port.mk>