aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/gtk-engines2
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 04:53:48 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 04:53:48 +0000
commite18151212d3326dbf04797c6d5300fb1211ee875 (patch)
tree1ca56d6a4227efdb653cc8e2b2cbedbbc8de3d88 /x11-themes/gtk-engines2
parentcc0f3248a2eb77d7e3df88333fd25eb8594223dc (diff)
downloadports-e18151212d3326dbf04797c6d5300fb1211ee875.tar.gz
ports-e18151212d3326dbf04797c6d5300fb1211ee875.zip
Notes
Diffstat (limited to 'x11-themes/gtk-engines2')
-rw-r--r--x11-themes/gtk-engines2/Makefile6
-rw-r--r--x11-themes/gtk-engines2/distinfo4
-rw-r--r--x11-themes/gtk-engines2/files/patch-clearlooks-symbol-conflict54
-rw-r--r--x11-themes/gtk-engines2/files/patch-engines_crux_src_crux-draw.c20
4 files changed, 80 insertions, 4 deletions
diff --git a/x11-themes/gtk-engines2/Makefile b/x11-themes/gtk-engines2/Makefile
index 45e178f6bb6f..d2272c2458e0 100644
--- a/x11-themes/gtk-engines2/Makefile
+++ b/x11-themes/gtk-engines2/Makefile
@@ -3,10 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/x11-themes/gtk-engines2/Makefile,v 1.10 2005/09/07 05:44:23 marcus Exp $
#
PORTNAME= gtk-engines2
-PORTVERSION= 2.6.4
+PORTVERSION= 2.6.5
+PORTREVISION= 2
CATEGORIES= x11-themes
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.6
@@ -21,7 +23,7 @@ CONFLICTS= gtk-smooth-engine-[0-9]* clearlooks-[0-9]*
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_GNOME= gnomehack gtk20
PLIST_SUB= GTK_VERSION="2.4.0"
diff --git a/x11-themes/gtk-engines2/distinfo b/x11-themes/gtk-engines2/distinfo
index de098903150a..f9922ae6e745 100644
--- a/x11-themes/gtk-engines2/distinfo
+++ b/x11-themes/gtk-engines2/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gtk-engines-2.6.4.tar.bz2) = 3389a92b62b9c8b916fbb52c4529f072
-SIZE (gnome2/gtk-engines-2.6.4.tar.bz2) = 477425
+MD5 (gnome2/gtk-engines-2.6.5.tar.bz2) = 28469a797ba1e6aaa3f7eea4c9f5f9b7
+SIZE (gnome2/gtk-engines-2.6.5.tar.bz2) = 477897
diff --git a/x11-themes/gtk-engines2/files/patch-clearlooks-symbol-conflict b/x11-themes/gtk-engines2/files/patch-clearlooks-symbol-conflict
new file mode 100644
index 000000000000..0d742c2ec86f
--- /dev/null
+++ b/x11-themes/gtk-engines2/files/patch-clearlooks-symbol-conflict
@@ -0,0 +1,54 @@
+--- engines/clearlooks/src/clearlooks_style.c.orig Wed Sep 7 01:41:42 2005
++++ engines/clearlooks/src/clearlooks_style.c Wed Sep 7 01:41:49 2005
+@@ -178,7 +178,7 @@ clearlooks_draw_arrow (GtkStyle *st
+
+ sanitize_size (window, &width, &height);
+
+- if (is_combo_box (widget))
++ if (is_combo_box_cl (widget))
+ {
+ width = 7;
+ height = 5;
+--- engines/clearlooks/src/support.c.orig Wed Sep 7 01:40:25 2005
++++ engines/clearlooks/src/support.c Wed Sep 7 01:40:59 2005
+@@ -959,7 +959,7 @@ GdkColor *get_parent_bgcolor (GtkWidget
+ }
+
+ GtkWidget *
+-find_combo_box_widget (GtkWidget * widget)
++find_combo_box_widget_cl (GtkWidget * widget)
+ {
+ GtkWidget *result = NULL;
+
+@@ -968,14 +968,14 @@ find_combo_box_widget (GtkWidget * widge
+ if (GTK_IS_COMBO_BOX (widget))
+ result = widget;
+ else
+- result = find_combo_box_widget(widget->parent);
++ result = find_combo_box_widget_cl(widget->parent);
+ }
+
+ return result;
+ }
+
+ gboolean
+-is_combo_box (GtkWidget * widget)
++is_combo_box_cl (GtkWidget * widget)
+ {
+- return (find_combo_box_widget(widget) != NULL);
++ return (find_combo_box_widget_cl(widget) != NULL);
+ }
+--- engines/clearlooks/src/support.h.orig Wed Sep 7 01:41:03 2005
++++ engines/clearlooks/src/support.h Wed Sep 7 01:41:17 2005
+@@ -102,9 +102,9 @@ GtkWidget *get_parent_window (GtkWidget
+
+ GdkColor *get_parent_bgcolor (GtkWidget *widget);
+
+-gboolean is_combo_box (GtkWidget * widget);
++gboolean is_combo_box_cl (GtkWidget * widget);
+
+-GtkWidget *find_combo_box_widget (GtkWidget * widget);
++GtkWidget *find_combo_box_widget_cl (GtkWidget * widget);
+
+ void gtk_clist_get_header_index (GtkCList *clist, GtkWidget *button,
+ gint *column_index, gint *columns);
diff --git a/x11-themes/gtk-engines2/files/patch-engines_crux_src_crux-draw.c b/x11-themes/gtk-engines2/files/patch-engines_crux_src_crux-draw.c
new file mode 100644
index 000000000000..371abad8e669
--- /dev/null
+++ b/x11-themes/gtk-engines2/files/patch-engines_crux_src_crux-draw.c
@@ -0,0 +1,20 @@
+--- engines/crux/src/crux-draw.c.orig Wed Aug 24 12:45:47 2005
++++ engines/crux/src/crux-draw.c Wed Aug 24 12:46:08 2005
+@@ -2323,6 +2323,8 @@ draw_extension (GtkStyle *style,
+ GdkRectangle rect;
+
+ eazel_theme_data *theme_data;
++ GtkWidget* parent_widget;
++ gint relative_x;
+
+ g_return_if_fail (style != NULL);
+ g_return_if_fail (window != NULL);
+@@ -2334,8 +2336,6 @@ draw_extension (GtkStyle *style,
+ detail, state_type, shadow_type, x, y, width, height);
+
+ /* Get x relative to parent widget, not window */
+- GtkWidget* parent_widget;
+- gint relative_x;
+ if (widget != NULL)
+ {
+ parent_widget = gtk_widget_get_parent(widget);