aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/gtk3-oxygen-engine
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-12-15 20:18:01 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-12-15 20:18:01 +0000
commit5e0cfcad8d068586229c50894b529b3695cf43a1 (patch)
treecca73bd721213f25078b60510501f2072a45d2b8 /x11-themes/gtk3-oxygen-engine
parent1b98765c007f6cdaf5f81119acc21947c1e791f0 (diff)
downloadports-5e0cfcad8d068586229c50894b529b3695cf43a1.tar.gz
ports-5e0cfcad8d068586229c50894b529b3695cf43a1.zip
Notes
Diffstat (limited to 'x11-themes/gtk3-oxygen-engine')
-rw-r--r--x11-themes/gtk3-oxygen-engine/Makefile9
-rw-r--r--x11-themes/gtk3-oxygen-engine/distinfo4
-rw-r--r--x11-themes/gtk3-oxygen-engine/files/patch-git_f2ac11760
-rw-r--r--x11-themes/gtk3-oxygen-engine/pkg-plist2
4 files changed, 8 insertions, 67 deletions
diff --git a/x11-themes/gtk3-oxygen-engine/Makefile b/x11-themes/gtk3-oxygen-engine/Makefile
index 6de1a02749fa..5ce22f69e416 100644
--- a/x11-themes/gtk3-oxygen-engine/Makefile
+++ b/x11-themes/gtk3-oxygen-engine/Makefile
@@ -1,10 +1,10 @@
# $FreeBSD$
PORTNAME= oxygen
-PORTVERSION= 1.2.0
+PORTVERSION= 1.2.1
CATEGORIES= x11-themes
MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= stable/${PORTNAME}-gtk3/${PORTVERSION}/src/
+MASTER_SITE_SUBDIR= stable/${PORTNAME}-gtk3/${PORTVERSION}/src
PKGNAMEPREFIX= gtk3-
PKGNAMESUFFIX= -engine
DISTNAME= ${PORTNAME}-gtk3-${PORTVERSION}
@@ -14,12 +14,11 @@ COMMENT= Oxygen GTK+ 3 engine and theme
LICENSE= LGPL21
-LIB_DEPENDS= cairo:${PORTSDIR}/graphics/cairo \
- dbus-glib-1:${PORTSDIR}/devel/dbus-glib
+LIB_DEPENDS= libcairo.so:${PORTSDIR}/graphics/cairo \
+ libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
USE_BZIP2= yes
USE_GNOME= gtk30
USES= cmake:outsource pkgconfig
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/x11-themes/gtk3-oxygen-engine/distinfo b/x11-themes/gtk3-oxygen-engine/distinfo
index 861a32feb414..d0d04b5aedab 100644
--- a/x11-themes/gtk3-oxygen-engine/distinfo
+++ b/x11-themes/gtk3-oxygen-engine/distinfo
@@ -1,2 +1,2 @@
-SHA256 (oxygen-gtk3-1.2.0.tar.bz2) = ea550bd215614c89704501d44479e0b3373db033d6026ce2244b70593241c61f
-SIZE (oxygen-gtk3-1.2.0.tar.bz2) = 190583
+SHA256 (oxygen-gtk3-1.2.1.tar.bz2) = 91b8a3a024c224b2d0963e7ab2cab807e4361251129f843f6f2876f070950171
+SIZE (oxygen-gtk3-1.2.1.tar.bz2) = 189296
diff --git a/x11-themes/gtk3-oxygen-engine/files/patch-git_f2ac117 b/x11-themes/gtk3-oxygen-engine/files/patch-git_f2ac117
deleted file mode 100644
index 36f09b055a5c..000000000000
--- a/x11-themes/gtk3-oxygen-engine/files/patch-git_f2ac117
+++ /dev/null
@@ -1,60 +0,0 @@
-commit f2ac117f0343f8f18b7c43eb875c2d4f8faef722
-Author: Raphael Kubo da Costa <rakuco@FreeBSD.org>
-Date: Sat Aug 31 16:12:49 2013 +0300
-
- Use g_mkdir() instead of different versions of mkdir().
-
- The current code was erroneously relying on the _POSIX_C_SOURCE macro to
- decide whether to use mkdir() with the signature present in POSIX-compliant
- systems or with the Windows signature.
-
- It turns out POSIX.1 expects the applications to define _POSIX_C_SOURCE to
- certain values. Only glibc resorts to defining it to a value by default,
- opposing what the standard says. It would then break systems that use
- another libc, such as the BSDs, OS X and maybe even other Linux libc
- implementations.
-
- Work around the issue by just relying on glib's g_mkdir(), which has the
- proper means to decide which mkdir() function to call. We still need to
- check for whether we are on Windows, though, since some of the mode
- constants are not defined on it.
-
- REVIEW: 112402
-
-diff --git a/src/oxygenqtsettings.cpp b/src/oxygenqtsettings.cpp
-index b9fdaea..9ad648c 100644
---- src/oxygenqtsettings.cpp
-+++ src/oxygenqtsettings.cpp
-@@ -26,6 +26,8 @@
- #include "oxygentimeline.h"
- #include "config.h"
-
-+#include <glib.h>
-+#include <glib/gstdio.h>
- #include <gtk/gtk.h>
-
- #include <algorithm>
-@@ -36,7 +38,6 @@
- #include <fstream>
- #include <iostream>
- #include <sstream>
--#include <unistd.h>
-
- namespace Oxygen
- {
-@@ -327,10 +328,12 @@ namespace Oxygen
- struct stat st;
- if( stat( _userConfigDir.c_str(), &st ) != 0 )
- {
-- #if _POSIX_C_SOURCE
-- mkdir( _userConfigDir.c_str(), S_IRWXU|S_IRWXG|S_IRWXO );
-+ #ifdef G_OS_WIN32
-+ // S_IRWXG and S_IRWXO are undefined on Windows, and g_mkdir()
-+ // ignores its second parameter on Windows anyway.
-+ g_mkdir( _userConfigDir.c_str(), 0 );
- #else
-- mkdir( _userConfigDir.c_str() );
-+ g_mkdir( _userConfigDir.c_str(), S_IRWXU|S_IRWXG|S_IRWXO );
- #endif
- }
-
diff --git a/x11-themes/gtk3-oxygen-engine/pkg-plist b/x11-themes/gtk3-oxygen-engine/pkg-plist
index 0c0476c70ed6..b0bae8d21b71 100644
--- a/x11-themes/gtk3-oxygen-engine/pkg-plist
+++ b/x11-themes/gtk3-oxygen-engine/pkg-plist
@@ -13,3 +13,5 @@ share/themes/oxygen-gtk/gtk-3.0/special-icons/standardbutton-closetab-hover-16.p
@dirrmtry share/themes/oxygen-gtk
@dirrmtry share/themes
@dirrmtry lib/gtk-3.0/%%GTK3_VERSION%%/theming-engines
+@dirrmtry lib/gtk-3.0/%%GTK3_VERSION%%
+@dirrmtry lib/gtk-3.0