aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/gtk3-oxygen-engine
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2011-06-26 23:01:33 +0000
committerBeech Rintoul <beech@FreeBSD.org>2011-06-26 23:01:33 +0000
commit982b42ce85d9c08cb853aa1fb4a351c711f6f234 (patch)
tree47631e60be1840c8e430eb416532600d35e8624e /x11-themes/gtk3-oxygen-engine
parente740da6e1fa95e7142dbc8062fb770c3ac4203ff (diff)
downloadports-982b42ce85d9c08cb853aa1fb4a351c711f6f234.tar.gz
ports-982b42ce85d9c08cb853aa1fb4a351c711f6f234.zip
Notes
Diffstat (limited to 'x11-themes/gtk3-oxygen-engine')
-rw-r--r--x11-themes/gtk3-oxygen-engine/Makefile14
-rw-r--r--x11-themes/gtk3-oxygen-engine/files/extra-patch-demo-oxygengtkdeco_main.cpp11
2 files changed, 23 insertions, 2 deletions
diff --git a/x11-themes/gtk3-oxygen-engine/Makefile b/x11-themes/gtk3-oxygen-engine/Makefile
index 62061e64fe83..0816c274e33a 100644
--- a/x11-themes/gtk3-oxygen-engine/Makefile
+++ b/x11-themes/gtk3-oxygen-engine/Makefile
@@ -7,6 +7,7 @@
PORTNAME= oxygen
PORTVERSION= 1.1.0
+PORTREVISION= 1
CATEGORIES= x11-themes
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTNAME}-gtk/${PORTVERSION}/src/
@@ -17,11 +18,20 @@ DISTNAME= ${PORTNAME}-gtk-${PORTVERSION}
MAINTAINER= kubito@gmail.com
COMMENT= Oxygen-Gtk engine and theme
-LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo
+LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo \
+ dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
USE_BZIP2= yes
USE_GNOME= gtk20 pkgconfig
USE_CMAKE= yes
MAKE_JOBS_SAFE= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+# FreeBSD SVN r205606 was only MFC'ed to 8.1+, so we need to match
+# the old function signature on previous versions.
+.if ${OSVERSION} < 801000
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-demo-oxygengtkdeco_main.cpp
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-themes/gtk3-oxygen-engine/files/extra-patch-demo-oxygengtkdeco_main.cpp b/x11-themes/gtk3-oxygen-engine/files/extra-patch-demo-oxygengtkdeco_main.cpp
new file mode 100644
index 000000000000..43a8adc64f18
--- /dev/null
+++ b/x11-themes/gtk3-oxygen-engine/files/extra-patch-demo-oxygengtkdeco_main.cpp
@@ -0,0 +1,11 @@
+--- demo/oxygengtkdeco_main.cpp~ 2011-06-26 11:15:05.000000000 -0300
++++ demo/oxygengtkdeco_main.cpp 2011-06-26 11:16:02.000000000 -0300
+@@ -118,7 +118,7 @@ int dh=0;
+ gboolean initLib()
+ {
+ void* library;
+- char* error=0;
++ const char* error=0;
+ char* moduleDir=gtk_rc_get_module_dir();
+ if(moduleDir)
+ {