aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/lxappearance/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-06-20 18:27:16 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-06-20 18:27:16 +0000
commit44ff5a958f4da87416e55a7bf528755c92c8c088 (patch)
tree72bc21ca949791cf866d970f7b2c9394cf2c7ee3 /x11-themes/lxappearance/Makefile
parentfe648ae4c9e1f760e302ef4b66ff19812bd2e561 (diff)
downloadports-44ff5a958f4da87416e55a7bf528755c92c8c088.tar.gz
ports-44ff5a958f4da87416e55a7bf528755c92c8c088.zip
Notes
Diffstat (limited to 'x11-themes/lxappearance/Makefile')
-rw-r--r--x11-themes/lxappearance/Makefile31
1 files changed, 22 insertions, 9 deletions
diff --git a/x11-themes/lxappearance/Makefile b/x11-themes/lxappearance/Makefile
index 9ee0cb17a1df..7486223e53c2 100644
--- a/x11-themes/lxappearance/Makefile
+++ b/x11-themes/lxappearance/Makefile
@@ -8,23 +8,36 @@ CATEGORIES= x11-themes gnome
MASTER_SITES= SF/lxde/LXAppearance
MAINTAINER= pawel@FreeBSD.org
-COMMENT= A desktop-independent theme switcher for GTK+
+COMMENT= Desktop-independent theme switcher for GTK+
LICENSE= GPLv2
-USE_GNOME= gnomehack gtk20 intlhack
-USES= gettext
-USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack gtk20 intlhack
MAKE_JOBS_SAFE= yes
MAN1= lxappearance.1
-.include <bsd.port.pre.mk>
+PORTDOCS= AUTHORS README
+
+OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
+
+NLS_USES= gettext
+
+.include <bsd.port.options.mk>
+
+post-patch:
+.if ! ${PORT_OPTIONS:MNLS}
+ @${REINPLACE_CMD} -e 's|man po|man|' \
+ ${WRKSRC}/Makefile.in
+.endif
-# earlier versions don't have mkdtemp(3) in stdlib.h
-.if ${OSVERSION} < 800000
-EXTRA_PATCHES+= ${FILESDIR}/extra-src-utils.c
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>