aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/lxappearance
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-10-27 01:15:17 +0000
committerWen Heping <wen@FreeBSD.org>2010-10-27 01:15:17 +0000
commit38ca080f915e648a951d17390275677179921eee (patch)
tree587d93e3594826b2eaeebe0b3767e47fd79c4d14 /x11-themes/lxappearance
parent2d307ad708e47b217b1ac94a26110bdeeb7bce2a (diff)
Notes
Diffstat (limited to 'x11-themes/lxappearance')
-rw-r--r--x11-themes/lxappearance/Makefile12
-rw-r--r--x11-themes/lxappearance/files/extra-src-utils.c11
2 files changed, 21 insertions, 2 deletions
diff --git a/x11-themes/lxappearance/Makefile b/x11-themes/lxappearance/Makefile
index c0f3534aa9bc..3e65fb24b095 100644
--- a/x11-themes/lxappearance/Makefile
+++ b/x11-themes/lxappearance/Makefile
@@ -7,18 +7,26 @@
PORTNAME= lxappearance
PORTVERSION= 0.5.0
+PORTREVISION= 1
CATEGORIES= x11-themes gnome
MASTER_SITES= SF/lxde/LXAppearance
MAINTAINER= c0rn@o2.pl
COMMENT= A desktop-independent theme switcher for GTK+
+LICENSE= GPLv2
+
USE_GNOME= gnomehack gtk20 intlhack
USE_GETTEXT= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
-LICENSE= GPLv2
+.include <bsd.port.pre.mk>
+
+# earlier versions don't have mkdtemp(3) in stdlib.h
+.if ${OSVERSION} < 800000
+EXTRA_PATCHES+= ${FILESDIR}/extra-src-utils.c
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-themes/lxappearance/files/extra-src-utils.c b/x11-themes/lxappearance/files/extra-src-utils.c
new file mode 100644
index 000000000000..5075b6406729
--- /dev/null
+++ b/x11-themes/lxappearance/files/extra-src-utils.c
@@ -0,0 +1,11 @@
+--- src/utils.c.orig 2010-10-26 20:54:31.000000000 +0200
++++ src/utils.c 2010-10-26 20:55:09.000000000 +0200
+@@ -27,7 +27,7 @@
+ #include <sys/wait.h>
+ #include <stdlib.h>
+ #include <glib/gstdio.h>
+-
++#include <unistd.h>
+ #include "icon-theme.h"
+
+ static void on_pid_exit(GPid pid, gint status, gpointer user_data)