aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/polymer/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2006-10-31 05:53:28 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2006-10-31 05:53:28 +0000
commit1afba16ba45730bcf66a1ab1227531476f9e5ff8 (patch)
treea28c133881d441cad7f5e89ed2bff416f9534f5c /x11-themes/polymer/Makefile
parenta192d61138737a08c73ff89afdeb54caef622d0d (diff)
downloadports-1afba16ba45730bcf66a1ab1227531476f9e5ff8.tar.gz
ports-1afba16ba45730bcf66a1ab1227531476f9e5ff8.zip
Notes
Diffstat (limited to 'x11-themes/polymer/Makefile')
-rw-r--r--x11-themes/polymer/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/x11-themes/polymer/Makefile b/x11-themes/polymer/Makefile
new file mode 100644
index 000000000000..32a65f457780
--- /dev/null
+++ b/x11-themes/polymer/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: Qt port of Plastik
+# Date Created: 30 Oct 2006
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= polymer
+PORTVERSION= 0.3.1
+CATEGORIES= x11-themes
+MASTER_SITES= http://static.int.pl/~mig21/dev/releases/polymer/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= danfe
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Qt port of Plastik KDE theme
+
+BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
+
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+USE_AUTOTOOLS= autoheader:259
+USE_QT_VER= 3
+INSTALLS_SHLIB= yes
+
+MAKE_ARGS+= QTDIR=${X11BASE} \
+ QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++ \
+ QMAKE=${LOCALBASE}/bin/qmake
+
+QTSTYLESDIR= ${PREFIX}/lib/plugins/styles
+
+.include <bsd.port.pre.mk>
+
+.if ${MACHINE_CPU:Mmmx}
+CONFIGURE_ARGS+= --enable-mmx
+.endif
+.if ${MACHINE_CPU:Msse2}
+CONFIGURE_ARGS+= --enable-sse2
+.endif
+
+do-install:
+ @${MKDIR} ${QTSTYLESDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/style/libpolymer.so.1.0.0 \
+ ${QTSTYLESDIR}/polymer.so
+ ${INSTALL_PROGRAM} ${WRKSRC}/config/polymer-config ${PREFIX}/bin
+
+.include <bsd.port.post.mk>