aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/qt-bluecurve-theme/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-10-17 18:21:25 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-10-17 18:21:25 +0000
commitb0ccb5691ec85c0c970c73f3215f34503474d0f4 (patch)
treef2fef7b69add30159c49cda05251f28f9bbf40ef /x11-themes/qt-bluecurve-theme/Makefile
parentb351230a03b9dcfa5fe07e411ed7b33fd0a89265 (diff)
downloadports-b0ccb5691ec85c0c970c73f3215f34503474d0f4.tar.gz
ports-b0ccb5691ec85c0c970c73f3215f34503474d0f4.zip
Notes
Diffstat (limited to 'x11-themes/qt-bluecurve-theme/Makefile')
-rw-r--r--x11-themes/qt-bluecurve-theme/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/x11-themes/qt-bluecurve-theme/Makefile b/x11-themes/qt-bluecurve-theme/Makefile
new file mode 100644
index 000000000000..4f2ef1e991ce
--- /dev/null
+++ b/x11-themes/qt-bluecurve-theme/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: bluecurve-unified
+# Date created: 3 October 2002
+# Whom: Eugeney Ryzhyk
+#
+# $FreeBSD$
+#
+
+PORTNAME= qt-bluecurve-theme
+PORTVERSION= 0.47
+CATEGORIES= x11-toolkits
+MASTER_SITES= ${MASTER_SITE_REDHAT_LINUX}
+MASTER_SITE_SUBDIR= 8.0/en/os/i386/SRPMS
+DISTFILES= redhat-artwork-${PORTVERSION}-${RH_SUBVERSION}.src.rpm
+
+MAINTAINER= rzheka@users.sourceforge.net
+
+BUILD_DEPENDS= rpm2cpio:${PORTSDIR}/archivers/rpm2cpio \
+ libtool:${PORTSDIR}/devel/libtool
+
+WRKSRC= ${WRKDIR}/redhat-artwork-${PORTVERSION}
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+
+RH_SUBVERSION= 3
+
+USE_QT_VER= 3
+THEMES_SUBDIRS = ${WRKSRC}/art/qt/Bluecurve
+
+do-extract:
+ @${RM} -rf ${WRKDIR}
+ @${MKDIR} ${WRKDIR}
+ @if ! (cd ${WRKDIR} && rpm2cpio ${_DISTDIR}/${DISTFILES} | cpio -i redhat-artwork-${PORTVERSION}.tar.gz 2>/dev/null && ${GZIP_CMD} -dc redhat-artwork-${PORTVERSION}.tar.gz | tar -xf - && ${RM} redhat-artwork-${PORTVERSION}.tar.gz);\
+ then \
+ exit 1; \
+ fi
+ ${CP} ${FILESDIR}/Makefile-qt3 ${WRKSRC}/art/qt/Bluecurve/Makefile
+
+post-patch:
+ @${REINPLACE_CMD} -e 's#-O2#${CFLAGS}#' ${WRKSRC}/art/qt/Bluecurve/Makefile
+
+do-build:
+ @for theme_dir in ${THEMES_SUBDIRS};do \
+ (cd $$theme_dir; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}); \
+ done
+do-install:
+ @${MKDIR} ${PREFIX}/plugins/styles && ${CHMOD} a+rx ${PREFIX}/plugins/styles
+ @${INSTALL_PROGRAM} ${WRKSRC}/art/qt/Bluecurve/.libs/bluecurve.so ${PREFIX}/plugins/styles
+
+.include <bsd.port.mk>