aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/qtcurve-gtk2
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-10-23 10:49:00 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-10-23 10:49:00 +0000
commitfb76121bb79a1db9fee521e99fc6f19eeee6e43a (patch)
tree3c20bd3883645ebf7c608fe4ab4bf992f3856d34 /x11-themes/qtcurve-gtk2
parent4760c791f4d5dd3fa0cbcb80127a4f9def0ae30c (diff)
downloadports-fb76121bb79a1db9fee521e99fc6f19eeee6e43a.tar.gz
ports-fb76121bb79a1db9fee521e99fc6f19eeee6e43a.zip
Notes
Diffstat (limited to 'x11-themes/qtcurve-gtk2')
-rw-r--r--x11-themes/qtcurve-gtk2/Makefile18
-rw-r--r--x11-themes/qtcurve-gtk2/files/extra-patch-style-qt_settings.c12
-rw-r--r--x11-themes/qtcurve-gtk2/files/getline.c169
-rw-r--r--x11-themes/qtcurve-gtk2/files/getline.h24
4 files changed, 1 insertions, 222 deletions
diff --git a/x11-themes/qtcurve-gtk2/Makefile b/x11-themes/qtcurve-gtk2/Makefile
index b3c4fee2ebd0..2244ed6a0350 100644
--- a/x11-themes/qtcurve-gtk2/Makefile
+++ b/x11-themes/qtcurve-gtk2/Makefile
@@ -16,20 +16,4 @@ USE_BZIP2= yes
USES= cmake pkgconfig
USE_GNOME= gtk20
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 800067
-.if ${ARCH} == "amd64"
-CFLAGS+= -fPIC
-.endif
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-style-qt_settings.c
-.endif
-
-post-extract:
-.if ${OSVERSION} < 800067
- ${CP} ${FILESDIR}/getline.h ${WRKSRC}/style
- ${CP} ${FILESDIR}/getline.c ${WRKSRC}/style
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-themes/qtcurve-gtk2/files/extra-patch-style-qt_settings.c b/x11-themes/qtcurve-gtk2/files/extra-patch-style-qt_settings.c
deleted file mode 100644
index e151cc6f07cd..000000000000
--- a/x11-themes/qtcurve-gtk2/files/extra-patch-style-qt_settings.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- ./style/qt_settings.c.orig 2012-04-24 21:19:54.000000000 +0000
-+++ ./style/qt_settings.c 2012-08-23 11:13:08.651930973 +0000
-@@ -46,6 +46,9 @@
-
- #define strcmp_i(A, B) strncmp_i(A, B, -1)
-
-+#include "getline.h"
-+#include "getline.c"
-+
- QtCPalette qtcPalette;
- Options opts;
-
diff --git a/x11-themes/qtcurve-gtk2/files/getline.c b/x11-themes/qtcurve-gtk2/files/getline.c
deleted file mode 100644
index 1fcf9adece88..000000000000
--- a/x11-themes/qtcurve-gtk2/files/getline.c
+++ /dev/null
@@ -1,169 +0,0 @@
-/* getline.c -- Replacement for GNU C library function getline
-
-Copyright (C) 1993 Free Software Foundation, Inc.
-
-This program is free software; you can redistribute it and/or
-modify it under the terms of the GNU General Public License as
-published by the Free Software Foundation; either version 2 of the
-License, or (at your option) any later version.
-
-This program is distributed in the hope that it will be useful, but
-WITHOUT ANY WARRANTY; without even the implied warranty of
-MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-General Public License for more details. */
-
-/* Written by Jan Brittenson, bson@gnu.ai.mit.edu. */
-
-#ifdef HAVE_CONFIG_H
-#include <config.h>
-#endif
-
-#include <sys/types.h>
-#include <stdlib.h>
-#include <stdio.h>
-#include <assert.h>
-#include <errno.h>
-#include "getline.h"
-
-/* Always add at least this many bytes when extending the buffer. */
-#define MIN_CHUNK 64
-
-/* Read up to (and including) a TERMINATOR from STREAM into *LINEPTR
- + OFFSET (and null-terminate it). If LIMIT is non-negative, then
- read no more than LIMIT chars.
-
- *LINEPTR is a pointer returned from malloc (or NULL), pointing to
- *N characters of space. It is realloc'd as necessary.
-
- Return the number of characters read (not including the null
- terminator), or -1 on error or EOF. On a -1 return, the caller
- should check feof(), if not then errno has been set to indicate the
- error. */
-
-int
-getstr (lineptr, n, stream, terminator, offset, limit)
- char **lineptr;
- size_t *n;
- FILE *stream;
- int terminator;
- int offset;
- int limit;
-{
- int nchars_avail; /* Allocated but unused chars in *LINEPTR. */
- char *read_pos; /* Where we're reading into *LINEPTR. */
- int ret;
-
- if (!lineptr || !n || !stream)
- {
- errno = EINVAL;
- return -1;
- }
-
- if (!*lineptr)
- {
- *n = MIN_CHUNK;
- *lineptr = malloc (*n);
- if (!*lineptr)
- {
- errno = ENOMEM;
- return -1;
- }
- *lineptr[0] = '\0';
- }
-
- nchars_avail = *n - offset;
- read_pos = *lineptr + offset;
-
- for (;;)
- {
- int save_errno;
- register int c;
-
- if (limit == 0)
- break;
- else
- {
- c = getc (stream);
-
- /* If limit is negative, then we shouldn't pay attention to
- it, so decrement only if positive. */
- if (limit > 0)
- limit--;
- }
-
- save_errno = errno;
-
- /* We always want at least one char left in the buffer, since we
- always (unless we get an error while reading the first char)
- NUL-terminate the line buffer. */
-
- assert((*lineptr + *n) == (read_pos + nchars_avail));
- if (nchars_avail < 2)
- {
- if (*n > MIN_CHUNK)
- *n *= 2;
- else
- *n += MIN_CHUNK;
-
- nchars_avail = *n + *lineptr - read_pos;
- *lineptr = realloc (*lineptr, *n);
- if (!*lineptr)
- {
- errno = ENOMEM;
- return -1;
- }
- read_pos = *n - nchars_avail + *lineptr;
- assert((*lineptr + *n) == (read_pos + nchars_avail));
- }
-
- if (ferror (stream))
- {
- /* Might like to return partial line, but there is no
- place for us to store errno. And we don't want to just
- lose errno. */
- errno = save_errno;
- return -1;
- }
-
- if (c == EOF)
- {
- /* Return partial line, if any. */
- if (read_pos == *lineptr)
- return -1;
- else
- break;
- }
-
- *read_pos++ = c;
- nchars_avail--;
-
- if (c == terminator)
- /* Return the line. */
- break;
- }
-
- /* Done - NUL terminate and return the number of chars read. */
- *read_pos = '\0';
-
- ret = read_pos - (*lineptr + offset);
- return ret;
-}
-
-int
-getline (lineptr, n, stream)
- char **lineptr;
- size_t *n;
- FILE *stream;
-{
- return getstr (lineptr, n, stream, '\n', 0, GETLINE_NO_LIMIT);
-}
-
-int
-getline_safe (lineptr, n, stream, limit)
- char **lineptr;
- size_t *n;
- FILE *stream;
- int limit;
-{
- return getstr (lineptr, n, stream, '\n', 0, limit);
-}
diff --git a/x11-themes/qtcurve-gtk2/files/getline.h b/x11-themes/qtcurve-gtk2/files/getline.h
deleted file mode 100644
index 2816a0641af1..000000000000
--- a/x11-themes/qtcurve-gtk2/files/getline.h
+++ /dev/null
@@ -1,24 +0,0 @@
-#ifndef _getline_h_
-#define _getline_h_ 1
-
-#include <stdio.h>
-
-#if defined (__GNUC__) || (defined (__STDC__) && __STDC__)
-#define __PROTO(args) args
-#else
-#define __PROTO(args) ()
-#endif /* GCC. */
-
-#define GETLINE_NO_LIMIT -1
-
-#ifndef _WITH_GETLINE
-int
- getline __PROTO ((char **_lineptr, size_t *_n, FILE *_stream));
-int
- getline_safe __PROTO ((char **_lineptr, size_t *_n, FILE *_stream,
- int limit));
-int
- getstr __PROTO ((char **_lineptr, size_t *_n, FILE *_stream,
- int _terminator, int _offset, int limit));
-#endif
-#endif /* _getline_h_ */