aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/qtcurve
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2018-03-10 14:07:27 +0000
committerJason E. Hale <jhale@FreeBSD.org>2018-03-10 14:07:27 +0000
commitd69e75cfd35906fa01a707fb0d7ac8ec892168c4 (patch)
treeb12893f6904dca2919298336a28445662d22af51 /x11-themes/qtcurve
parent75eceed2d0422725a17a44bec466d32b226ba8e4 (diff)
downloadports-d69e75cfd35906fa01a707fb0d7ac8ec892168c4.tar.gz
ports-d69e75cfd35906fa01a707fb0d7ac8ec892168c4.zip
Notes
Diffstat (limited to 'x11-themes/qtcurve')
-rw-r--r--x11-themes/qtcurve/Makefile62
-rw-r--r--x11-themes/qtcurve/distinfo5
-rw-r--r--x11-themes/qtcurve/files/patch-323402d56
-rw-r--r--x11-themes/qtcurve/files/patch-7ddd37834
-rw-r--r--x11-themes/qtcurve/files/patch-bdf0a5c22
-rw-r--r--x11-themes/qtcurve/files/patch-gtk2_style_qtcurve.c11
-rw-r--r--x11-themes/qtcurve/files/patch-lib_utils_CMakeLists.txt16
-rw-r--r--x11-themes/qtcurve/files/patch-lib_utils_fd__utils.cpp (renamed from x11-themes/qtcurve/files/patch-lib_utils_fd__utils.c)4
-rw-r--r--x11-themes/qtcurve/files/patch-lib_utils_map.c20
-rw-r--r--x11-themes/qtcurve/files/patch-lib_utils_process.c12
-rw-r--r--x11-themes/qtcurve/pkg-descr2
-rw-r--r--x11-themes/qtcurve/pkg-plist.gtk24
-rw-r--r--x11-themes/qtcurve/pkg-plist.kf54
-rw-r--r--x11-themes/qtcurve/pkg-plist.utils11
14 files changed, 63 insertions, 200 deletions
diff --git a/x11-themes/qtcurve/Makefile b/x11-themes/qtcurve/Makefile
index b590010faad5..2bee5251dae2 100644
--- a/x11-themes/qtcurve/Makefile
+++ b/x11-themes/qtcurve/Makefile
@@ -1,8 +1,8 @@
# $FreeBSD$
PORTNAME= qtcurve
-PORTVERSION= 1.8.18
-PORTREVISION= 4
+DISTVERSION= 1.9.0-rc1
+PORTREVISION?= 0
CATEGORIES= x11-themes
MAINTAINER= jhale@FreeBSD.org
@@ -13,25 +13,30 @@ USES= metaport
# There is no NO_PATCH
PATCHDIR= ${MASTERDIR}/none
-OPTIONS_DEFINE= GTK2 KDE4 QT4 QT5
-OPTIONS_DEFAULT:= ${OPTIONS_DEFINE}
+OPTIONS_RADIO= QT5
+OPTIONS_RADIO_QT5= KF5 QT5
+OPTIONS_DEFINE= GTK2 KDE4 QT4
+OPTIONS_DEFAULT= GTK2 KDE4 QT4 QT5
-GTK2_RUN_DEPENDS= gtk2-qtcurve-theme>=1.8.18:x11-themes/qtcurve-gtk2
-KDE4_RUN_DEPENDS= kde4-style-qtcurve>=1.8.18:x11-themes/qtcurve-kde4
-QT4_RUN_DEPENDS= qt4-style-qtcurve>=1.8.18:x11-themes/qtcurve-qt4
-QT5_RUN_DEPENDS= qt5-style-qtcurve>=1.8.18:x11-themes/qtcurve-qt5
+GTK2_RUN_DEPENDS= gtk2-qtcurve-theme>=${PORTVERSION}:x11-themes/qtcurve-gtk2
+KDE4_RUN_DEPENDS= kde4-style-qtcurve>=${PORTVERSION}:x11-themes/qtcurve-kde4
+KF5_DESC= KDE Frameworks 5 + Qt 5 toolkit support
+KF5_RUN_DEPENDS= kf5-style-qtcurve>=${PORTVERSION}:x11-themes/qtcurve-kf5
+QT4_RUN_DEPENDS= qt4-style-qtcurve>=${PORTVERSION}:x11-themes/qtcurve-qt4
+QT5_RUN_DEPENDS= qt5-style-qtcurve>=${PORTVERSION}:x11-themes/qtcurve-qt5
.else # !defined(QTCURVE_SLAVE)
-LICENSE= LGPL21
+LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/COPYING
USE_GITHUB= yes
-GH_ACCOUNT= QtCurve
+GH_ACCOUNT= KDE
+GH_TAGNAME= a1ec5f8
USES= compiler:c++11-lib cmake pkgconfig
USE_XORG= x11 xcb
-.for i in gtk2 kde4 qt4 qt5
+.for i in gtk2 kde4 kf5 qt4 qt5
WITH_${i}= Off
.endfor
WITH_${QTCURVE_SLAVE}= On
@@ -39,7 +44,8 @@ WITH_${QTCURVE_SLAVE}= On
CMAKE_ARGS+= -DENABLE_GTK2=${WITH_gtk2} \
-DENABLE_QT4=${WITH_qt4} \
-DENABLE_QT5=${WITH_qt5} \
- -DQTC_QT4_ENABLE_KDE=${WITH_kde4}
+ -DQTC_QT4_ENABLE_KDE=${WITH_kde4} \
+ -DQTC_QT5_ENABLE_KDE=${WITH_kf5}
LDFLAGS+= -L${LOCALBASE}/lib
BUILD_WRKSRC= ${WRKSRC}/${QTCURVE_SLAVE}
@@ -51,11 +57,6 @@ PLIST= ${PKGDIR}/pkg-plist.${QTCURVE_SLAVE}
PKGNAMESUFFIX= -utils
USE_LDCONFIG= yes
BUILD_WRKSRC= ${WRKSRC}
-
-OPTIONS_DEFINE= NLS
-OPTIONS_SUB= yes
-NLS_USES= gettext-tools:build
-NLS_CMAKE_OFF= -DQTC_INSTALL_PO=Off
.else
LIB_DEPENDS+= libqtcurve-utils.so:x11-themes/qtcurve-utils
.endif
@@ -63,7 +64,7 @@ LIB_DEPENDS+= libqtcurve-utils.so:x11-themes/qtcurve-utils
.if ${QTCURVE_SLAVE} == "gtk2"
PKGNAMEPREFIX= gtk2-
PKGNAMESUFFIX= -theme
-USE_GNOME= gtk20 cairo pango
+USE_GNOME= cairo gdkpixbuf2 gtk20 pango
USE_LDCONFIG= yes
post-install:
@@ -76,22 +77,41 @@ WITH_qt4= On # required for KDE 4
PKGNAMEPREFIX= kde4-style-
USE_KDE= kdelibs workspace automoc4
USES+= kde:4
-USE_QT4= moc_build qmake_build rcc_build uic_build
+USE_QT4= corelib dbus gui svg moc_build qmake_build rcc_build uic_build
BUILD_WRKSRC= ${WRKSRC}/qt4
.endif
+.if ${QTCURVE_SLAVE} == "kf5"
+CONFLICTS_INSTALL= qt5-style-qtcurve
+WITH_qt5= On # required for KF5
+PKGNAMEPREFIX= kf5-style-
+USES+= kde:5
+USE_KDE= archive completion config configwidgets coreaddons \
+ ecm_build frameworkintegration guiaddons i18n iconthemes \
+ kdelibs4support kio widgetsaddons windowsystem xmlgui
+USE_QT5= core dbus gui printsupport svg widgets x11extras \
+ buildtools_build qmake_build
+BUILD_WRKSRC= ${WRKSRC}/qt5
+.endif
+
.if ${QTCURVE_SLAVE} == "qt4"
PKGNAMEPREFIX= qt4-style-
-USE_QT4= dbus gui svg moc_build qmake_build rcc_build uic_build
+USE_QT4= corelib dbus gui svg moc_build qmake_build rcc_build uic_build
PLIST_FILES= ${QT_PLUGINDIR_REL}/styles/qtcurve.so
.endif
.if ${QTCURVE_SLAVE} == "qt5"
+CONFLICTS_INSTALL= kf5-style-qtcurve
PKGNAMEPREFIX= qt5-style-
-USE_QT5= dbus gui svg widgets x11extras buildtools_build qmake_build
+USE_QT5= core dbus gui svg widgets x11extras \
+ buildtools_build qmake_build
PLIST_FILES= ${QT_PLUGINDIR_REL}/styles/qtcurve.so
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|bash|sh|' -e 's|\[\[|[|g' -e 's|\]\]|]|g' \
+ ${WRKSRC}/tools/gen-version.sh
+
.endif # !defined(QTCURVE_SLAVE)
.include <bsd.port.mk>
diff --git a/x11-themes/qtcurve/distinfo b/x11-themes/qtcurve/distinfo
index 905dc3b50a4e..596306ca0b99 100644
--- a/x11-themes/qtcurve/distinfo
+++ b/x11-themes/qtcurve/distinfo
@@ -1,2 +1,3 @@
-SHA256 (QtCurve-qtcurve-1.8.18_GH0.tar.gz) = 85997c9fa4a948945d719342f5993486aecf189d176408280bad9af8600873a6
-SIZE (QtCurve-qtcurve-1.8.18_GH0.tar.gz) = 991195
+TIMESTAMP = 1520485100
+SHA256 (KDE-qtcurve-1.9.0-rc1-a1ec5f8_GH0.tar.gz) = 1be388cb06f30c9dd4e5685a35ab5d5910619bc644c63e9f5fca75313fb8646d
+SIZE (KDE-qtcurve-1.9.0-rc1-a1ec5f8_GH0.tar.gz) = 800796
diff --git a/x11-themes/qtcurve/files/patch-323402d b/x11-themes/qtcurve/files/patch-323402d
deleted file mode 100644
index 28ccc2aeb8f5..000000000000
--- a/x11-themes/qtcurve/files/patch-323402d
+++ /dev/null
@@ -1,56 +0,0 @@
-From: Marco Martin <notmart@gmail.com>
-Date: Mon, 19 May 2014 08:37:37 +0000
-Subject: remove qt_filedialog_* api
-X-Git-Url: http://quickgit.kde.org/?p=qtcurve.git&a=commitdiff&h=323402d8b99502300f65e909c61153cbd5d5d997
----
-remove qt_filedialog_* api
-
-it has been removed and doesn't build anymore with recent Qt5 stable
-branch
----
-
-
---- qt5/style/qtcurve_api.cpp
-+++ qt5/style/qtcurve_api.cpp
-@@ -67,25 +67,6 @@
-
- #include <QDebug>
-
--extern QString (*qt_filedialog_existing_directory_hook)(
-- QWidget *parent, const QString &caption, const QString &dir,
-- QFileDialog::Options options);
--
--extern QString (*qt_filedialog_open_filename_hook)(
-- QWidget *parent, const QString &caption, const QString &dir,
-- const QString &filter, QString *selectedFilter,
-- QFileDialog::Options options);
--
--extern QStringList (*qt_filedialog_open_filenames_hook)(
-- QWidget * parent, const QString &caption, const QString &dir,
-- const QString &filter, QString *selectedFilter,
-- QFileDialog::Options options);
--
--extern QString (*qt_filedialog_save_filename_hook)(
-- QWidget *parent, const QString &caption, const QString &dir,
-- const QString &filter, QString *selectedFilter,
-- QFileDialog::Options options);
--
- namespace QtCurve {
-
- void
-@@ -161,13 +142,6 @@
- if(!qtcIsFlatBgnd(opts.menuBgndAppearance) && 0 == opts.lighterPopupMenuBgnd)
- opts.lighterPopupMenuBgnd=1; // shade so that we dont have 3d-ish borders...
- opts.menuBgndAppearance = APPEARANCE_FLAT;
-- }
--
-- if (opts.useQtFileDialogApps.contains(appName)) {
-- qt_filedialog_existing_directory_hook = 0L;
-- qt_filedialog_open_filename_hook = 0L;
-- qt_filedialog_open_filenames_hook = 0L;
-- qt_filedialog_save_filename_hook = 0L;
- }
-
- QCommonStyle::polish(app);
-
-
diff --git a/x11-themes/qtcurve/files/patch-7ddd378 b/x11-themes/qtcurve/files/patch-7ddd378
deleted file mode 100644
index c8b3fa0ba40c..000000000000
--- a/x11-themes/qtcurve/files/patch-7ddd378
+++ /dev/null
@@ -1,34 +0,0 @@
-From 7ddd3782ea5635cc0d6a6d292824da85ae9d1bb8 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Ren=C3=A9=20J=2EV=2E=20Bertin?= <rjvbertin@gmail.com>
-Date: Mon, 17 Apr 2017 11:11:31 +0200
-Subject: Make build against Qt 5.9.0
-
----
- qt5/style/qtcurve.h | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/qt5/style/qtcurve.h b/qt5/style/qtcurve.h
-index 6930c08..aedcd16 100644
---- qt5/style/qtcurve.h
-+++ qt5/style/qtcurve.h
-@@ -379,7 +379,7 @@ private:
- void emitMenuSize(QWidget *w, unsigned short size, bool force=false);
- void emitStatusBarState(QStatusBar *sb);
- const QColor&
-- MOArrow(QFlags<State> state, const QPalette &palette, bool mo,
-+ MOArrow(State state, const QPalette &palette, bool mo,
- QPalette::ColorRole rol) const
- {
- if (!(state & State_Enabled)) {
-@@ -391,7 +391,7 @@ private:
- }
- }
- const QColor&
-- MOArrow(QFlags<State> state, const QPalette &palette,
-+ MOArrow(State state, const QPalette &palette,
- QPalette::ColorRole rol) const
- {
- return MOArrow(state, palette, state & State_MouseOver, rol);
---
-cgit v0.11.2
-
diff --git a/x11-themes/qtcurve/files/patch-bdf0a5c b/x11-themes/qtcurve/files/patch-bdf0a5c
deleted file mode 100644
index f93b61fe01dc..000000000000
--- a/x11-themes/qtcurve/files/patch-bdf0a5c
+++ /dev/null
@@ -1,22 +0,0 @@
-From: Yichao Yu <yyc1992@gmail.com>
-Date: Sun, 02 Feb 2014 12:11:06 +0000
-Subject: [lib/utils/x11shadow] typo in shadow color .... #54
-X-Git-Url: http://quickgit.kde.org/?p=qtcurve.git&a=commitdiff&h=bdf0a5ce3ecc7ac0a7f9636358d444b7c4305828
----
-[lib/utils/x11shadow] typo in shadow color .... #54
----
-
-
---- lib/utils/x11helpers.c
-+++ lib/utils/x11helpers.c
-@@ -77,7 +77,7 @@
- {
- int shadow_size = 30;
- int shadow_radius = 4;
-- QtcColor c1 = {0.5, 0.4, 0.4};
-+ QtcColor c1 = {0.4, 0.4, 0.4};
- QtcColor c2 = {0.2, 0.2, 0.2};
- QtcImage *shadow_images[8];
- qtcShadowCreate(shadow_size, &c1, &c2, shadow_radius, false,
-
-
diff --git a/x11-themes/qtcurve/files/patch-gtk2_style_qtcurve.c b/x11-themes/qtcurve/files/patch-gtk2_style_qtcurve.c
deleted file mode 100644
index 800e3dfffd0a..000000000000
--- a/x11-themes/qtcurve/files/patch-gtk2_style_qtcurve.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- gtk2/style/qtcurve.c.orig 2014-01-25 20:13:54 UTC
-+++ gtk2/style/qtcurve.c
-@@ -372,7 +372,7 @@ gtkDrawFlatBox(GtkStyle *style, GdkWindo
- } else if (!(qtSettings.app == GTK_APP_JAVA && widget &&
- GTK_IS_LABEL(widget))) {
- if (state != GTK_STATE_PRELIGHT || opts.crHighlight ||
-- strcmp(detail, "checkbutton") != 0) {
-+ ( detail != NULL && strcmp(detail, "checkbutton") != 0 )) {
- parent_class->draw_flat_box(style, window, state, shadow, area,
- widget, detail, x, y, width, height);
- }
diff --git a/x11-themes/qtcurve/files/patch-lib_utils_CMakeLists.txt b/x11-themes/qtcurve/files/patch-lib_utils_CMakeLists.txt
index e18f39c1c884..1282a039db51 100644
--- a/x11-themes/qtcurve/files/patch-lib_utils_CMakeLists.txt
+++ b/x11-themes/qtcurve/files/patch-lib_utils_CMakeLists.txt
@@ -1,11 +1,11 @@
---- lib/utils/CMakeLists.txt.orig 2014-01-25 20:13:54 UTC
+--- lib/utils/CMakeLists.txt.orig 2017-06-04 19:20:38 UTC
+++ lib/utils/CMakeLists.txt
-@@ -13,7 +13,7 @@ set(qtcurve_utils_SRCS
- x11helpers.c
- x11wrap.c)
- set(qtcurve_utils_LINKS
-- m rt dl ${LIBEXECINFO_LIBRARIES} pthread)
-+ m rt ${CMAKE_DL_LIBS} ${LIBEXECINFO_LIBRARIES} pthread)
+@@ -20,7 +20,7 @@ set(qtcurve_utils_SRCS
+ set(qtcurve_utils_LINKS ${LIBEXECINFO_LIBRARIES} pthread)
- include_directories("${CMAKE_CURRENT_BINARY_DIR}")
+ if(NOT APPLE)
+- set(qtcurve_utils_LINKS ${qtcurve_utils_LINKS} m rt dl)
++ set(qtcurve_utils_LINKS ${qtcurve_utils_LINKS} m rt)
+ endif()
+ include_directories("${CMAKE_CURRENT_BINARY_DIR}")
diff --git a/x11-themes/qtcurve/files/patch-lib_utils_fd__utils.c b/x11-themes/qtcurve/files/patch-lib_utils_fd__utils.cpp
index b7c67c7d82c1..4dd19c810d67 100644
--- a/x11-themes/qtcurve/files/patch-lib_utils_fd__utils.c
+++ b/x11-themes/qtcurve/files/patch-lib_utils_fd__utils.cpp
@@ -1,5 +1,5 @@
---- lib/utils/fd_utils.c.orig 2014-01-25 20:13:54 UTC
-+++ lib/utils/fd_utils.c
+--- lib/utils/fd_utils.cpp.orig 2014-01-25 20:13:54 UTC
++++ lib/utils/fd_utils.cpp
@@ -21,6 +21,7 @@
#include "fd_utils.h"
diff --git a/x11-themes/qtcurve/files/patch-lib_utils_map.c b/x11-themes/qtcurve/files/patch-lib_utils_map.c
deleted file mode 100644
index 07d7c18d0f42..000000000000
--- a/x11-themes/qtcurve/files/patch-lib_utils_map.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- lib/utils/map.c.orig 2015-05-02 14:52:48 UTC
-+++ lib/utils/map.c
-@@ -22,7 +22,7 @@
- #include "map.h"
-
- static int
--qtcStrMapItemCompare(const void *_left, const void *_right, void *_map)
-+qtcStrMapItemCompare(void *_map, const void *_left, const void *_right)
- {
- const char **left = (const char**)_left;
- const char **right = (const char**)_right;
-@@ -36,7 +36,7 @@ qtcStrMapInit(QtcStrMap *map)
- {
- QTC_RET_IF_FAIL(map && !map->inited && map->items && map->size && map->num);
- qsort_r(map->items, map->num, map->size,
-- qtcStrMapItemCompare, map);
-+ map, qtcStrMapItemCompare);
- map->inited = true;
- }
-
diff --git a/x11-themes/qtcurve/files/patch-lib_utils_process.c b/x11-themes/qtcurve/files/patch-lib_utils_process.c
deleted file mode 100644
index 2f13171b77e2..000000000000
--- a/x11-themes/qtcurve/files/patch-lib_utils_process.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- lib/utils/process.c.orig 2014-01-25 20:13:54 UTC
-+++ lib/utils/process.c
-@@ -23,7 +23,8 @@
- #include "fd_utils.h"
- #include "timer.h"
- #include <unistd.h>
--#include <wait.h>
-+#include <signal.h>
-+#include <sys/wait.h>
- #include <sys/stat.h>
- #include <sys/socket.h>
- #include <fcntl.h>
diff --git a/x11-themes/qtcurve/pkg-descr b/x11-themes/qtcurve/pkg-descr
index 7787d397accd..b3d1e209ba5a 100644
--- a/x11-themes/qtcurve/pkg-descr
+++ b/x11-themes/qtcurve/pkg-descr
@@ -1,3 +1,3 @@
QtCurve is a set of widget styles for Qt and GTK+ toolkits.
-WWW: https://projects.kde.org/projects/playground/base/qtcurve
+WWW: https://cgit.kde.org/qtcurve.git
diff --git a/x11-themes/qtcurve/pkg-plist.gtk2 b/x11-themes/qtcurve/pkg-plist.gtk2
index 65332866e6d1..6e17852b3439 100644
--- a/x11-themes/qtcurve/pkg-plist.gtk2
+++ b/x11-themes/qtcurve/pkg-plist.gtk2
@@ -1,7 +1,7 @@
lib/gtk-2.0/%%GTK2_VERSION%%/engines/libqtcurve.so
lib/libqtcurve-cairo.so
-lib/libqtcurve-cairo.so.0
-lib/libqtcurve-cairo.so.0.1
+lib/libqtcurve-cairo.so.1
+lib/libqtcurve-cairo.so.1.0
share/themes/QtCurve/gtk-2.0/gtkrc
share/themes/QtCurve/gtk-2.0/icons3
share/themes/QtCurve/gtk-2.0/icons4
diff --git a/x11-themes/qtcurve/pkg-plist.kf5 b/x11-themes/qtcurve/pkg-plist.kf5
new file mode 100644
index 000000000000..68095c2f418b
--- /dev/null
+++ b/x11-themes/qtcurve/pkg-plist.kf5
@@ -0,0 +1,4 @@
+%%QT_PLUGINDIR%%/kstyle_qtcurve5_config.so
+%%QT_PLUGINDIR%%/styles/qtcurve.so
+share/kstyle/themes/qtcurve.themerc
+share/kxmlgui5/QtCurve/QtCurveui.rc
diff --git a/x11-themes/qtcurve/pkg-plist.utils b/x11-themes/qtcurve/pkg-plist.utils
index 52ec93dbf5ee..297095834b83 100644
--- a/x11-themes/qtcurve/pkg-plist.utils
+++ b/x11-themes/qtcurve/pkg-plist.utils
@@ -1,10 +1,3 @@
lib/libqtcurve-utils.so
-lib/libqtcurve-utils.so.1
-lib/libqtcurve-utils.so.1.0
-%%NLS%%share/locale/ko/LC_MESSAGES/qtcurve.mo
-%%NLS%%share/locale/ru/LC_MESSAGES/qtcurve.mo
-%%NLS%%share/locale/tr/LC_MESSAGES/qtcurve.mo
-%%NLS%%share/locale/uk/LC_MESSAGES/qtcurve.mo
-%%NLS%%share/locale/zh_CN/LC_MESSAGES/qtcurve.mo
-%%NLS%%share/locale/zh_HK/LC_MESSAGES/qtcurve.mo
-%%NLS%%share/locale/zh_TW/LC_MESSAGES/qtcurve.mo
+lib/libqtcurve-utils.so.2
+lib/libqtcurve-utils.so.2.0