aboutsummaryrefslogtreecommitdiff
path: root/x11-themes
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /x11-themes
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/adwaita-qt/Makefile6
-rw-r--r--x11-themes/gtk-qt4-engine/Makefile4
-rw-r--r--x11-themes/kde-base-artwork-kde4/Makefile4
-rw-r--r--x11-themes/kde-gtk-config/Makefile4
-rw-r--r--x11-themes/kde-wallpapers-kde4/Makefile4
-rw-r--r--x11-themes/kde4-style-bespin/Makefile4
-rw-r--r--x11-themes/kde4-style-nitrogen/Makefile4
-rw-r--r--x11-themes/kde4-style-oxygen-transparent/Makefile4
-rw-r--r--x11-themes/kde4-style-polyester/Makefile4
-rw-r--r--x11-themes/kde4-style-skulpture/Makefile4
-rw-r--r--x11-themes/kde4-windeco-crystal/Makefile4
-rw-r--r--x11-themes/kde4-windeco-dekorator/Makefile4
-rw-r--r--x11-themes/kdeartwork-kde4/Makefile4
-rw-r--r--x11-themes/kf5-breeze-icons/Makefile4
-rw-r--r--x11-themes/kf5-kemoticons/Makefile4
-rw-r--r--x11-themes/kf5-kiconthemes/Makefile4
-rw-r--r--x11-themes/kf5-oxygen-icons5/Makefile4
-rw-r--r--x11-themes/kf5-qqc2-desktop-style/Makefile4
-rw-r--r--x11-themes/lumina-themes/Makefile4
-rw-r--r--x11-themes/plasma5-breeze-gtk/Makefile4
-rw-r--r--x11-themes/plasma5-breeze-kde4/Makefile4
-rw-r--r--x11-themes/plasma5-breeze/Makefile4
-rw-r--r--x11-themes/plasma5-kde-gtk-config/Makefile4
-rw-r--r--x11-themes/plasma5-oxygen/Makefile4
-rw-r--r--x11-themes/plasma5-plasma-workspace-wallpapers/Makefile4
-rw-r--r--x11-themes/qt4-style-Kvantum/Makefile4
-rw-r--r--x11-themes/qt4-style-float/Makefile4
-rw-r--r--x11-themes/qt4-style-phase/Makefile4
-rw-r--r--x11-themes/qt4-style-quantumstyle/Makefile4
-rw-r--r--x11-themes/qt5-style-Kvantum/Makefile4
-rw-r--r--x11-themes/qt5-style-plugins/Makefile6
-rw-r--r--x11-themes/qt5-style-plugins/pkg-plist3
-rw-r--r--x11-themes/qtcurve/Makefile16
33 files changed, 77 insertions, 70 deletions
diff --git a/x11-themes/adwaita-qt/Makefile b/x11-themes/adwaita-qt/Makefile
index 01493c7f3750..1efc29cc4424 100644
--- a/x11-themes/adwaita-qt/Makefile
+++ b/x11-themes/adwaita-qt/Makefile
@@ -18,11 +18,13 @@ qt5_PKGNAMESUFFIX= 5
USES= cmake:outsource compiler:c++11-lib localbase pkgconfig
. if ${FLAVOR} == qt4
-USE_QT4= corelib dbus gui \
+USES+= qt:4
+USE_QT= corelib dbus gui \
moc_build rcc_build uic_build qmake_build
CMAKE_ON= USE_QT4
. else
-USE_QT5= core dbus gui widgets \
+USES+= qt:5
+USE_QT= core dbus gui widgets \
buildtools_build qmake_build
CMAKE_OFF= USE_QT4
. endif
diff --git a/x11-themes/gtk-qt4-engine/Makefile b/x11-themes/gtk-qt4-engine/Makefile
index 214fd24abc73..3aa3ea033c36 100644
--- a/x11-themes/gtk-qt4-engine/Makefile
+++ b/x11-themes/gtk-qt4-engine/Makefile
@@ -19,10 +19,10 @@ USE_GITHUB= yes
GH_ACCOUNT= davidsansome
GH_TAGNAME= 0dc6c26
-USES= cmake gettext kde:4 pkgconfig
+USES= cmake gettext kde:4 pkgconfig qt:4
USE_GNOME= cairo gdkpixbuf2 gtk20
USE_KDE= kdelibs automoc4
-USE_QT4= dbus corelib gui moc_build rcc_build uic_build qmake_build svg
+USE_QT= dbus corelib gui moc_build rcc_build uic_build qmake_build svg
USE_XORG= x11
WRKSRC_SUBDIR= ${PORTNAME}
diff --git a/x11-themes/kde-base-artwork-kde4/Makefile b/x11-themes/kde-base-artwork-kde4/Makefile
index 6788c422ce8a..393d8eed2b0e 100644
--- a/x11-themes/kde-base-artwork-kde4/Makefile
+++ b/x11-themes/kde-base-artwork-kde4/Makefile
@@ -11,9 +11,9 @@ COMMENT= Base artwork for the KDE Plasma Desktop
LICENSE= GPLv2
-USES= cmake:outsource kde:4 tar:xz
+USES= cmake:outsource kde:4 qt:4 tar:xz
USE_KDE= automoc4 kdelibs
-USE_QT4= moc_build qmake_build rcc_build uic_build
+USE_QT= moc_build qmake_build rcc_build uic_build
NO_BUILD= yes
.include <bsd.port.mk>
diff --git a/x11-themes/kde-gtk-config/Makefile b/x11-themes/kde-gtk-config/Makefile
index 5092660fc2ec..624b637cf49d 100644
--- a/x11-themes/kde-gtk-config/Makefile
+++ b/x11-themes/kde-gtk-config/Makefile
@@ -9,10 +9,10 @@ MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}/src
MAINTAINER= kde@FreeBSD.org
COMMENT= GTK2 and GTK3 Configurator for KDE
-USES= cmake:outsource gettext kde:4 pkgconfig tar:xz
+USES= cmake:outsource gettext kde:4 pkgconfig qt:4 tar:xz
USE_GNOME= gtk20 gtk30
USE_KDE= automoc4 kdelibs
-USE_QT4= moc_build qmake_build rcc_build uic_build
+USE_QT= moc_build qmake_build rcc_build uic_build
post-patch:
${REINPLACE_CMD} -e '/^install/s,KDE4_LIBEXEC_INSTALL_DIR,LIBEXEC_INSTALL_DIR,g' \
diff --git a/x11-themes/kde-wallpapers-kde4/Makefile b/x11-themes/kde-wallpapers-kde4/Makefile
index 542f096c7000..8da4720a338f 100644
--- a/x11-themes/kde-wallpapers-kde4/Makefile
+++ b/x11-themes/kde-wallpapers-kde4/Makefile
@@ -8,9 +8,9 @@ CATEGORIES= x11-themes kde kde-kde4
MAINTAINER= kde@FreeBSD.org
COMMENT= Set of wallpapers for the KDE Plasma workspace
-USES= cmake:outsource kde:4 tar:xz
+USES= cmake:outsource kde:4 qt:4 tar:xz
USE_KDE= automoc4 kdelibs
-USE_QT4= moc_build qmake_build rcc_build uic_build
+USE_QT= moc_build qmake_build rcc_build uic_build
NO_BUILD= yes
diff --git a/x11-themes/kde4-style-bespin/Makefile b/x11-themes/kde4-style-bespin/Makefile
index 672555db4589..0ac43cc3fe32 100644
--- a/x11-themes/kde4-style-bespin/Makefile
+++ b/x11-themes/kde4-style-bespin/Makefile
@@ -16,9 +16,9 @@ LICENSE= LGPL21
WRKSRC= ${WRKDIR}/cloudcity
-USES= cmake:noninja kde:4
+USES= cmake:noninja kde:4 qt:4
USE_CXXSTD= gnu++98
USE_KDE= kdelibs automoc4 workspace
-USE_QT4= corelib qmake_build moc_build rcc_build uic_build
+USE_QT= corelib qmake_build moc_build rcc_build uic_build
.include <bsd.port.mk>
diff --git a/x11-themes/kde4-style-nitrogen/Makefile b/x11-themes/kde4-style-nitrogen/Makefile
index 72b276dffcde..dcfca18566aa 100644
--- a/x11-themes/kde4-style-nitrogen/Makefile
+++ b/x11-themes/kde4-style-nitrogen/Makefile
@@ -16,8 +16,8 @@ LICENSE= GPLv2
WRKSRC= ${WRKDIR}/kde4-kstyle-nitrogen-${PORTVERSION}-Source
-USES= cmake kde:4
+USES= cmake kde:4 qt:4
USE_KDE= kdelibs automoc4
-USE_QT4= corelib qmake_build moc_build rcc_build uic_build
+USE_QT= corelib qmake_build moc_build rcc_build uic_build
.include <bsd.port.mk>
diff --git a/x11-themes/kde4-style-oxygen-transparent/Makefile b/x11-themes/kde4-style-oxygen-transparent/Makefile
index c1221f2bf841..2ac9c645f14c 100644
--- a/x11-themes/kde4-style-oxygen-transparent/Makefile
+++ b/x11-themes/kde4-style-oxygen-transparent/Makefile
@@ -13,8 +13,8 @@ COMMENT= KDE oxygen style with transparency
LICENSE= GPLv2
-USES= cmake kde:4 tar:xz
+USES= cmake kde:4 qt:4 tar:xz
USE_KDE= kdelibs workspace automoc4
-USE_QT4= corelib qmake_build moc_build rcc_build uic_build
+USE_QT= corelib qmake_build moc_build rcc_build uic_build
.include <bsd.port.mk>
diff --git a/x11-themes/kde4-style-polyester/Makefile b/x11-themes/kde4-style-polyester/Makefile
index 6bc1d051ee6b..61c94f26f98e 100644
--- a/x11-themes/kde4-style-polyester/Makefile
+++ b/x11-themes/kde4-style-polyester/Makefile
@@ -14,8 +14,8 @@ COMMENT= KDE style and window decoration
LICENSE= LGPL20+
LICENSE_FILE= ${WRKSRC}/COPYING.LIB
-USES= cmake gettext kde:4 tar:bzip2
+USES= cmake gettext kde:4 qt:4 tar:bzip2
USE_KDE= kdelibs automoc4
-USE_QT4= qmake_build moc_build rcc_build uic_build
+USE_QT= qmake_build moc_build rcc_build uic_build
.include <bsd.port.mk>
diff --git a/x11-themes/kde4-style-skulpture/Makefile b/x11-themes/kde4-style-skulpture/Makefile
index 76f951a51cd0..ffb348c9774f 100644
--- a/x11-themes/kde4-style-skulpture/Makefile
+++ b/x11-themes/kde4-style-skulpture/Makefile
@@ -14,8 +14,8 @@ COMMENT= KDE style featuring 3D artwork and enhanced the visual experience
LICENSE= GPLv3
-USES= cmake kde:4
+USES= cmake kde:4 qt:4
USE_KDE= kdelibs automoc4 workspace
-USE_QT4= corelib qmake_build moc_build rcc_build uic_build
+USE_QT= corelib qmake_build moc_build rcc_build uic_build
.include <bsd.port.mk>
diff --git a/x11-themes/kde4-windeco-crystal/Makefile b/x11-themes/kde4-windeco-crystal/Makefile
index ef8843663fec..f25f96e9f5ad 100644
--- a/x11-themes/kde4-windeco-crystal/Makefile
+++ b/x11-themes/kde4-windeco-crystal/Makefile
@@ -14,9 +14,9 @@ COMMENT= Transparent KDE window decoration
LICENSE= GPLv2
-USES= cmake:outsource,noninja kde:4 tar:bzip2
+USES= cmake:outsource,noninja kde:4 qt:4 tar:bzip2
USE_KDE= kdelibs automoc4 workspace
-USE_QT4= qmake_build moc_build rcc_build uic_build \
+USE_QT= qmake_build moc_build rcc_build uic_build \
corelib gui qt3support
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/x11-themes/kde4-windeco-dekorator/Makefile b/x11-themes/kde4-windeco-dekorator/Makefile
index d02b4ec3ab32..9358b046f581 100644
--- a/x11-themes/kde4-windeco-dekorator/Makefile
+++ b/x11-themes/kde4-windeco-dekorator/Makefile
@@ -16,9 +16,9 @@ LICENSE= GPLv2
LIB_DEPENDS= libqimageblitz.so:x11/qimageblitz
-USES= cmake kde:4 tar:bzip2
+USES= cmake kde:4 qt:4 tar:bzip2
USE_KDE= kdelibs automoc4 workspace
-USE_QT4= corelib qmake_build moc_build rcc_build uic_build
+USE_QT= corelib qmake_build moc_build rcc_build uic_build
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
.include <bsd.port.mk>
diff --git a/x11-themes/kdeartwork-kde4/Makefile b/x11-themes/kdeartwork-kde4/Makefile
index 96c279dca918..401e94d8b8a1 100644
--- a/x11-themes/kdeartwork-kde4/Makefile
+++ b/x11-themes/kdeartwork-kde4/Makefile
@@ -10,9 +10,9 @@ PKGNAMESUFFIX= -kde4
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE Artworks Themes
-USES= cmake:outsource kde:4 tar:xz
+USES= cmake:outsource kde:4 qt:4 tar:xz
USE_KDE= kdelibs libkexiv2 workspace automoc4
-USE_QT4= corelib gui opengl \
+USE_QT= corelib gui opengl \
moc_build qmake_build rcc_build uic_build
USE_XORG= x11 xt
diff --git a/x11-themes/kf5-breeze-icons/Makefile b/x11-themes/kf5-breeze-icons/Makefile
index 60f7e028a028..4d92214512cf 100644
--- a/x11-themes/kf5-breeze-icons/Makefile
+++ b/x11-themes/kf5-breeze-icons/Makefile
@@ -10,9 +10,9 @@ COMMENT= Breeze icon theme for KDE
LICENSE= LGPL3+
LICENSE_FILE= ${WRKSRC}/COPYING-ICONS
-USES= cmake:outsource kde:5 tar:xz
+USES= cmake:outsource kde:5 qt:5 tar:xz
USE_KDE= ecm
-USE_QT5= buildtools_build core qmake_build testlib
+USE_QT= buildtools_build core qmake_build testlib
NO_ARCH= yes
diff --git a/x11-themes/kf5-kemoticons/Makefile b/x11-themes/kf5-kemoticons/Makefile
index 0ae902b146c1..eeea21e2ecb6 100644
--- a/x11-themes/kf5-kemoticons/Makefile
+++ b/x11-themes/kf5-kemoticons/Makefile
@@ -7,8 +7,8 @@ CATEGORIES= x11-themes kde kde-frameworks
MAINTAINER= kde@FreeBSD.org
COMMENT= KF5 library to convert emoticons
-USES= cmake:outsource compiler:c++11-lib kde:5 tar:xz
+USES= cmake:outsource compiler:c++11-lib kde:5 qt:5 tar:xz
USE_KDE= archive config coreaddons ecm service
-USE_QT5= buildtools_build core gui qmake_build widgets xml
+USE_QT= buildtools_build core gui qmake_build widgets xml
.include <bsd.port.mk>
diff --git a/x11-themes/kf5-kiconthemes/Makefile b/x11-themes/kf5-kiconthemes/Makefile
index 768683279e64..8133d80d8e4a 100644
--- a/x11-themes/kf5-kiconthemes/Makefile
+++ b/x11-themes/kf5-kiconthemes/Makefile
@@ -7,10 +7,10 @@ CATEGORIES= x11-themes kde kde-frameworks
MAINTAINER= kde@FreeBSD.org
COMMENT= KF5 library for handling icons in applications
-USES= cmake:outsource compiler:c++11-lib gettext kde:5 tar:xz
+USES= cmake:outsource compiler:c++11-lib gettext kde:5 qt:5 tar:xz
USE_KDE= archive auth codecs config configwidgets coreaddons ecm \
i18n itemviews widgetsaddons
-USE_QT5= buildtools_build concurrent core dbus gui qmake_build \
+USE_QT= buildtools_build concurrent core dbus gui qmake_build \
script svg widgets xml
.include <bsd.port.mk>
diff --git a/x11-themes/kf5-oxygen-icons5/Makefile b/x11-themes/kf5-oxygen-icons5/Makefile
index 3c5d18c75600..2b6ea378d49f 100644
--- a/x11-themes/kf5-oxygen-icons5/Makefile
+++ b/x11-themes/kf5-oxygen-icons5/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= x11-themes kde kde-frameworks
MAINTAINER= kde@FreeBSD.org
COMMENT= The Oxygen icon theme for KDE
-USES= cmake:outsource kde:5 tar:xz
+USES= cmake:outsource kde:5 qt:5 tar:xz
USE_KDE= ecm_build # We only install icons.
# The qmake dependency is only needed so that kf5-e-c-m can query qmake for
@@ -15,7 +15,7 @@ USE_KDE= ecm_build # We only install icons.
# We explicitly prevent it from looking for qt5-core and specify qmake's path
# to avoid needlessly depending on qt5-core; we're just installing a ton of
# icon files and do not even use the paths queried from qmake.
-USE_QT5= qmake_build
+USE_QT= qmake_build
CMAKE_ARGS= -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Core=TRUE \
-DQMAKE_EXECUTABLE:PATH=${QMAKE}
diff --git a/x11-themes/kf5-qqc2-desktop-style/Makefile b/x11-themes/kf5-qqc2-desktop-style/Makefile
index db4f65f88e6e..4b82b3bc690d 100644
--- a/x11-themes/kf5-qqc2-desktop-style/Makefile
+++ b/x11-themes/kf5-qqc2-desktop-style/Makefile
@@ -7,10 +7,10 @@ CATEGORIES= x11-themes kde kde-frameworks
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt QuickControl2 style for KDE
-USES= cmake:outsource kde:5 pkgconfig tar:xz
+USES= cmake:outsource kde:5 pkgconfig qt:5 tar:xz
USE_KDE= auth codecs config configwidgets coreaddons ecm iconthemes \
kirigami2 widgetsaddons
-USE_QT5= gui network qml quick widgets xml \
+USE_QT= gui network qml quick widgets xml \
buildtools_build core qmake_build
.include <bsd.port.mk>
diff --git a/x11-themes/lumina-themes/Makefile b/x11-themes/lumina-themes/Makefile
index 46b9e3499361..2f5ad2dd3db6 100644
--- a/x11-themes/lumina-themes/Makefile
+++ b/x11-themes/lumina-themes/Makefile
@@ -11,8 +11,8 @@ COMMENT= Lumina desktop wallpapers/colors
LICENSE= BSD2CLAUSE CC0-1.0
LICENSE_COMB= multi
-USES= qmake
-USE_QT5= qmake_build
+USES= qmake qt:5
+USE_QT= qmake_build
USE_GITHUB= yes
GH_ACCOUNT= trueos
diff --git a/x11-themes/plasma5-breeze-gtk/Makefile b/x11-themes/plasma5-breeze-gtk/Makefile
index c26f05535452..b267ccbe7692 100644
--- a/x11-themes/plasma5-breeze-gtk/Makefile
+++ b/x11-themes/plasma5-breeze-gtk/Makefile
@@ -10,9 +10,9 @@ COMMENT= Plasma5 Breeze visual style for Gtk
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING.LIB
-USES= cmake:outsource cpe kde:5 pkgconfig tar:xz
+USES= cmake:outsource cpe kde:5 pkgconfig qt:5 tar:xz
USE_GNOME= gdkpixbuf2
USE_KDE= ecm
-USE_QT5= core buildtools_build qmake_build
+USE_QT= core buildtools_build qmake_build
.include <bsd.port.mk>
diff --git a/x11-themes/plasma5-breeze-kde4/Makefile b/x11-themes/plasma5-breeze-kde4/Makefile
index cc25b2070887..bf51321ded56 100644
--- a/x11-themes/plasma5-breeze-kde4/Makefile
+++ b/x11-themes/plasma5-breeze-kde4/Makefile
@@ -14,9 +14,9 @@ LICENSE_FILE= ${WRKSRC}/COPYING
CMAKE_ON= USE_KDE4
USES= cmake:outsource compiler:c++11-lang cpe gettext \
- kde:4 pkgconfig tar:xz
+ kde:4 pkgconfig qt:4 tar:xz
USE_KDE= kdelibs automoc4
-USE_QT4= corelib dbus gui svg \
+USE_QT= corelib dbus gui svg \
moc_build qmake_build rcc_build uic_build
USE_XORG= x11 xcb
diff --git a/x11-themes/plasma5-breeze/Makefile b/x11-themes/plasma5-breeze/Makefile
index 6aa7f9c773cc..a676eee99b16 100644
--- a/x11-themes/plasma5-breeze/Makefile
+++ b/x11-themes/plasma5-breeze/Makefile
@@ -11,11 +11,11 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
USES= cmake:outsource compiler:c++11-lib cpe \
- gettext kde:5 pkgconfig tar:xz
+ gettext kde:5 pkgconfig qt:5 tar:xz
USE_KDE= auth breeze-icons codecs config configwidgets coreaddons \
decoration ecm frameworkintegration guiaddons i18n kcmutils \
plasma-framework service wayland widgetsaddons windowsystem
-USE_QT5= core dbus gui network qml quick widgets x11extras xml \
+USE_QT= core dbus gui network qml quick widgets x11extras xml \
buildtools_build qmake_build
USE_XORG= xcb
diff --git a/x11-themes/plasma5-kde-gtk-config/Makefile b/x11-themes/plasma5-kde-gtk-config/Makefile
index 8ac395d8d42f..838a902381d5 100644
--- a/x11-themes/plasma5-kde-gtk-config/Makefile
+++ b/x11-themes/plasma5-kde-gtk-config/Makefile
@@ -16,12 +16,12 @@ BUILD_DEPENDS= gsettings-desktop-schemas>=0:devel/gsettings-desktop-schemas
RUN_DEPENDS= gsettings-desktop-schemas>=0:devel/gsettings-desktop-schemas
USES= cmake:outsource compiler:c++11-lib cpe gettext \
- kde:5 pkgconfig tar:xz
+ kde:5 pkgconfig qt:5 tar:xz
USE_GNOME= cairo gdkpixbuf2 gtk20 gtk30 glib20
USE_KDE= archive attica auth codecs completion config configwidgets \
coreaddons ecm i18n iconthemes jobwidgets kcmutils kio \
newstuff service widgetsaddons xmlgui
-USE_QT5= concurrent core dbus gui network testlib widgets xml \
+USE_QT= concurrent core dbus gui network testlib widgets xml \
buildtools_build qmake_build
USE_XORG= xcursor
diff --git a/x11-themes/plasma5-oxygen/Makefile b/x11-themes/plasma5-oxygen/Makefile
index 8a7115f513b7..df3e7de311d9 100644
--- a/x11-themes/plasma5-oxygen/Makefile
+++ b/x11-themes/plasma5-oxygen/Makefile
@@ -13,12 +13,12 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LICENSE_FILE_LGPL21= ${WRKSRC}/COPYING.LIB
USES= cmake:outsource compiler:c++11-lib cpe gettext \
- kde:5 pkgconfig tar:xz
+ kde:5 pkgconfig qt:5 tar:xz
USE_LDCONFIG= yes
USE_KDE= auth codecs completion config configwidgets coreaddons decoration ecm \
frameworkintegration guiaddons i18n kcmutils service \
wayland widgetsaddons windowsystem
-USE_QT5= core dbus gui network qml quick widgets x11extras xml \
+USE_QT= core dbus gui network qml quick widgets x11extras xml \
buildtools_build qmake_build
USE_XORG= xcb
diff --git a/x11-themes/plasma5-plasma-workspace-wallpapers/Makefile b/x11-themes/plasma5-plasma-workspace-wallpapers/Makefile
index 20b1f2a201f3..ba74b35307f0 100644
--- a/x11-themes/plasma5-plasma-workspace-wallpapers/Makefile
+++ b/x11-themes/plasma5-plasma-workspace-wallpapers/Makefile
@@ -12,9 +12,9 @@ LICENSE_COMB= multi
LICENSE_FILE= ${WRKSRC}/COPYING
LICENSE_FILE_LGPL3= ${WRKSRC}/COPYING.LGPL3
-USES= cmake:outsource cpe kde:5 tar:xz
+USES= cmake:outsource cpe kde:5 qt:5 tar:xz
USE_KDE= ecm
-USE_QT5= buildtools_build qmake_build
+USE_QT= buildtools_build qmake_build
# The qmake dependency is only needed so that kf5-e-c-m can query qmake for
# some installation directories.
diff --git a/x11-themes/qt4-style-Kvantum/Makefile b/x11-themes/qt4-style-Kvantum/Makefile
index c52398a4f02a..ba41b524947d 100644
--- a/x11-themes/qt4-style-Kvantum/Makefile
+++ b/x11-themes/qt4-style-Kvantum/Makefile
@@ -15,8 +15,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USE_GITHUB= yes
GH_ACCOUNT= tsujan
-USES= compiler:c++11-lang qmake
-USE_QT4= corelib gui svg rcc_build uic_build moc_build
+USES= compiler:c++11-lang qmake qt:4
+USE_QT= corelib gui svg rcc_build uic_build moc_build
USE_XORG= x11 xext
WRKSRC_SUBDIR= ${PORTNAME}
diff --git a/x11-themes/qt4-style-float/Makefile b/x11-themes/qt4-style-float/Makefile
index 9af918331844..c2360a4f57c2 100644
--- a/x11-themes/qt4-style-float/Makefile
+++ b/x11-themes/qt4-style-float/Makefile
@@ -15,8 +15,8 @@ COMMENT= Style for Qt 4 and KDE
LICENSE= GPLv2
-USES= tar:bzip2 qmake
-USE_QT4= corelib gui moc_build rcc_build
+USES= qt:4 tar:bzip2 qmake
+USE_QT= corelib gui moc_build rcc_build
WRKSRC= ${WRKDIR}/floatstyle-${PORTVERSION}
diff --git a/x11-themes/qt4-style-phase/Makefile b/x11-themes/qt4-style-phase/Makefile
index f9ae9cd3df2a..20b5dba3f029 100644
--- a/x11-themes/qt4-style-phase/Makefile
+++ b/x11-themes/qt4-style-phase/Makefile
@@ -15,8 +15,8 @@ COMMENT= Widget style for Qt 4 and KDE 4
LICENSE= MIT
-USES= tar:bzip2 qmake
-USE_QT4= corelib gui moc_build
+USES= qt:4 tar:bzip2 qmake
+USE_QT= corelib gui moc_build
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/x11-themes/qt4-style-quantumstyle/Makefile b/x11-themes/qt4-style-quantumstyle/Makefile
index efa8c9648cb3..9c2982af6c5a 100644
--- a/x11-themes/qt4-style-quantumstyle/Makefile
+++ b/x11-themes/qt4-style-quantumstyle/Makefile
@@ -16,8 +16,8 @@ COMMENT= SVG themeable style for Qt 4 and KDE
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= qmake
-USE_QT4= corelib gui svg rcc_build uic_build moc_build
+USES= qmake qt:4
+USE_QT= corelib gui svg rcc_build uic_build moc_build
WRKSRC= ${WRKDIR}/QuantumStyle
diff --git a/x11-themes/qt5-style-Kvantum/Makefile b/x11-themes/qt5-style-Kvantum/Makefile
index ab91f57f6424..a31fcbf89cb3 100644
--- a/x11-themes/qt5-style-Kvantum/Makefile
+++ b/x11-themes/qt5-style-Kvantum/Makefile
@@ -15,8 +15,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USE_GITHUB= yes
GH_ACCOUNT= tsujan
-USES= compiler:c++11-lang qmake
-USE_QT5= core gui svg widgets x11extras buildtools_build linguisttools_build
+USES= compiler:c++11-lang qmake qt:5
+USE_QT= core gui svg widgets x11extras buildtools_build linguisttools_build
USE_XORG= x11 xext
USE_GL= gl
diff --git a/x11-themes/qt5-style-plugins/Makefile b/x11-themes/qt5-style-plugins/Makefile
index 09fe13b260a4..88970a8db600 100644
--- a/x11-themes/qt5-style-plugins/Makefile
+++ b/x11-themes/qt5-style-plugins/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qt5-style-plugins
PORTVERSION= 5.0.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-themes
MASTER_SITES= QT/community_releases/additional_qt_src_pkgs/
DISTNAME= qtstyleplugins-src-${PORTVERSION}
@@ -14,8 +14,8 @@ COMMENT= Additional Styles for Qt 5 and KDE
LICENSE= LGPL21
-USES= qmake
-USE_QT5= buildtools_build core gui widgets
+USES= qmake qt:5
+USE_QT= buildtools_build core gui widgets
USE_GL+= gl
WRKSRC= ${WRKDIR}/qtstyleplugins-src-${PORTVERSION}
diff --git a/x11-themes/qt5-style-plugins/pkg-plist b/x11-themes/qt5-style-plugins/pkg-plist
index 44825186d54b..1bd3061b5e14 100644
--- a/x11-themes/qt5-style-plugins/pkg-plist
+++ b/x11-themes/qt5-style-plugins/pkg-plist
@@ -1,4 +1,7 @@
lib/cmake/Qt5Widgets/Qt5Widgets_.cmake
%%QT_PLUGINDIR%%/styles/libqcleanlooksstyle.so
+%%DEBUG%%%%QT_PLUGINDIR%%/styles/libqcleanlooksstyle.so.debug
%%QT_PLUGINDIR%%/styles/libqmotifstyle.so
+%%DEBUG%%%%QT_PLUGINDIR%%/styles/libqmotifstyle.so.debug
%%QT_PLUGINDIR%%/styles/libqplastiquestyle.so
+%%DEBUG%%%%QT_PLUGINDIR%%/styles/libqplastiquestyle.so.debug
diff --git a/x11-themes/qtcurve/Makefile b/x11-themes/qtcurve/Makefile
index 2bee5251dae2..763ed88c10b8 100644
--- a/x11-themes/qtcurve/Makefile
+++ b/x11-themes/qtcurve/Makefile
@@ -9,7 +9,7 @@ MAINTAINER= jhale@FreeBSD.org
COMMENT?= Widget styles for Qt and GTK+ toolkits
.if !defined(QTCURVE_SLAVE)
-USES= metaport
+USES= metaport qt:4
# There is no NO_PATCH
PATCHDIR= ${MASTERDIR}/none
@@ -76,8 +76,8 @@ post-install:
WITH_qt4= On # required for KDE 4
PKGNAMEPREFIX= kde4-style-
USE_KDE= kdelibs workspace automoc4
-USES+= kde:4
-USE_QT4= corelib dbus gui svg moc_build qmake_build rcc_build uic_build
+USES+= kde:4 qt:4
+USE_QT= corelib dbus gui svg moc_build qmake_build rcc_build uic_build
BUILD_WRKSRC= ${WRKSRC}/qt4
.endif
@@ -85,25 +85,27 @@ BUILD_WRKSRC= ${WRKSRC}/qt4
CONFLICTS_INSTALL= qt5-style-qtcurve
WITH_qt5= On # required for KF5
PKGNAMEPREFIX= kf5-style-
-USES+= kde:5
+USES+= kde:5 qt:5
USE_KDE= archive completion config configwidgets coreaddons \
ecm_build frameworkintegration guiaddons i18n iconthemes \
kdelibs4support kio widgetsaddons windowsystem xmlgui
-USE_QT5= core dbus gui printsupport svg widgets x11extras \
+USE_QT= core dbus gui printsupport svg widgets x11extras \
buildtools_build qmake_build
BUILD_WRKSRC= ${WRKSRC}/qt5
.endif
.if ${QTCURVE_SLAVE} == "qt4"
PKGNAMEPREFIX= qt4-style-
-USE_QT4= corelib dbus gui svg moc_build qmake_build rcc_build uic_build
+USES+= qt:4
+USE_QT= corelib dbus gui svg moc_build qmake_build rcc_build uic_build
PLIST_FILES= ${QT_PLUGINDIR_REL}/styles/qtcurve.so
.endif
.if ${QTCURVE_SLAVE} == "qt5"
CONFLICTS_INSTALL= kf5-style-qtcurve
PKGNAMEPREFIX= qt5-style-
-USE_QT5= core dbus gui svg widgets x11extras \
+USES+= qt:5
+USE_QT= core dbus gui svg widgets x11extras \
buildtools_build qmake_build
PLIST_FILES= ${QT_PLUGINDIR_REL}/styles/qtcurve.so
.endif