aboutsummaryrefslogtreecommitdiff
path: root/x11-themes
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-09-09 01:00:23 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-09-09 01:00:23 +0000
commitf1ed97d2b90a60b088a16e28b3be29a0bee89aec (patch)
tree6e6d3900e3697a7bf2da67c60be8fa38d9849170 /x11-themes
parent1cc06b1ac3d6120a49a36c26b4a03e0035995fd6 (diff)
downloadports-f1ed97d2b90a60b088a16e28b3be29a0bee89aec.tar.gz
ports-f1ed97d2b90a60b088a16e28b3be29a0bee89aec.zip
Notes
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/Makefile1
-rw-r--r--x11-themes/beastie/Makefile56
-rw-r--r--x11-themes/beastie/distinfo2
-rw-r--r--x11-themes/beastie/pkg-descr5
4 files changed, 64 insertions, 0 deletions
diff --git a/x11-themes/Makefile b/x11-themes/Makefile
index 7452e6e49c95..14ac5f6f5358 100644
--- a/x11-themes/Makefile
+++ b/x11-themes/Makefile
@@ -5,6 +5,7 @@
COMMENT = X11 themes
SUBDIR += baghira
+ SUBDIR += beastie
SUBDIR += bluecurve-themes
SUBDIR += buffy
SUBDIR += clean-theme-gtk
diff --git a/x11-themes/beastie/Makefile b/x11-themes/beastie/Makefile
new file mode 100644
index 000000000000..55169635aeef
--- /dev/null
+++ b/x11-themes/beastie/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: beastie
+# Date created: 2005-09-06
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/x11-themes/beastie/Makefile,v 1.3 2005/09/06 06:01:04 ahze Exp $
+#
+
+PORTNAME= beastie
+PORTVERSION= 05.07.11
+CATEGORIES= x11-themes
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= ahze
+DISTNAME= Beastie-${PORTVERSION}
+
+MAINTAINER= ahze@FreeBSD.org
+COMMENT= Gnome theme with FreeBSD Colors
+
+WRKSRC= ${WRKDIR}/Beastie
+USE_X_PREFIX= yes
+NO_BUILD= yes
+
+THEME_FILES= README index.theme gtk-2.0/gtkrc
+THEME_DIR= share/themes/Beastie/
+PLIST_FILES= ${THEME_FILES:S|^|${THEME_DIR}|}
+PLIST_DIRS= ${THEME_DIR}/gtk-2.0 ${THEME_DIR}
+
+.include <bsd.port.pre.mk>
+
+.if exists(${X11BASE}/libdata/pkgconfig/gtk-engines-2.pc)
+WITH_GTKENGINES= yes
+.endif
+
+.if !defined(WITHOUT_GTKENGINES) || defined(WITH_GTKENGINES)
+RUN_DEPENDS+= gtk-engines2>=2.6.4:${PORTSDIR}/x11-themes/gtk-engines2 \
+ gnome-themes>=2.11.91:${PORTSDIR}/x11-themes/gnome-themes
+.else
+RUN_DEPENDS+= clearlooks>=0.6.0:${PORTSDIR}/x11-themes/clearlooks \
+ clearlooks-metacity>=0.6:${PORTSDIR}/x11-themes/clearlooks-metacity
+.endif
+
+pre-everything::
+.if !defined(WITHOUT_GTKENGINES) && !defined(WITH_GTKENGINES)
+ @${ECHO_MSG} "You can disable gtk-engines support (clearlooks)"
+ @${ECHO_MSG} "and use x11-themes/clearlooks for the clearlooks"
+ @${ECHO_MSG} "engine by defining"
+ @${ECHO_MSG} "WITHOUT_GTKENGINES=yes"
+.endif
+
+do-install:
+ ${MKDIR} ${PREFIX}/${THEME_DIR}/gtk-2.0
+.for f in ${THEME_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/${THEME_DIR}/${f}
+.endfor
+
+.include <bsd.port.post.mk>
diff --git a/x11-themes/beastie/distinfo b/x11-themes/beastie/distinfo
new file mode 100644
index 000000000000..c6a3e52b58bd
--- /dev/null
+++ b/x11-themes/beastie/distinfo
@@ -0,0 +1,2 @@
+MD5 (Beastie-05.07.11.tar.gz) = 3e44b9a3aaaf852af10b8f251227c707
+SIZE (Beastie-05.07.11.tar.gz) = 1701
diff --git a/x11-themes/beastie/pkg-descr b/x11-themes/beastie/pkg-descr
new file mode 100644
index 000000000000..7417b74b1da6
--- /dev/null
+++ b/x11-themes/beastie/pkg-descr
@@ -0,0 +1,5 @@
+GNOME theme with FreeBSD colors
+
+Author: Jeremy Messenger <mezz@FreeBSD.org>
+ Michael Johnson <ahze@FreeBSD.org>
+WWW: http://people.freebsd.org/~ahze/Beastie/