aboutsummaryrefslogtreecommitdiff
path: root/x11-themes
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-20 11:53:37 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-08-20 11:53:37 +0000
commit0f22b5b163518c62dfefd35cddbae3c5ba1ffc43 (patch)
tree51e1d35561945762dcc8e8cfc955e5af9658f433 /x11-themes
parent7e2d54d00eb6eae8c0b0c691c11ed00f3a17dacb (diff)
downloadports-0f22b5b163518c62dfefd35cddbae3c5ba1ffc43.tar.gz
ports-0f22b5b163518c62dfefd35cddbae3c5ba1ffc43.zip
Notes
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gtk-qt4-engine/Makefile26
-rw-r--r--x11-themes/gtk-qt4-engine/distinfo6
-rw-r--r--x11-themes/gtk-qt4-engine/files/patch-CMakeLists.txt11
-rw-r--r--x11-themes/gtk-qt4-engine/files/patch-kcm_gtk__CMakeLists.txt11
-rw-r--r--x11-themes/gtk-qt4-engine/pkg-descr6
-rw-r--r--x11-themes/gtk-qt4-engine/pkg-plist21
6 files changed, 40 insertions, 41 deletions
diff --git a/x11-themes/gtk-qt4-engine/Makefile b/x11-themes/gtk-qt4-engine/Makefile
index c3fcee5db8d5..a1faae2ca704 100644
--- a/x11-themes/gtk-qt4-engine/Makefile
+++ b/x11-themes/gtk-qt4-engine/Makefile
@@ -1,32 +1,30 @@
-# New ports collection makefile for: gtk-qt-engine
-# Date created: 23 February 2004
-# Whom: Danny Pansters <danny@ricin.com>
+# New ports collection makefile for: gtk-qt4-engine
+# Date created: 07 July 2008
+# Whom: Kris Moore <kris@pcbsd.org>
#
# $FreeBSD$
#
-PORTNAME= gtk-qt-engine
-PORTVERSION= 0.8
-PORTREVISION= 1
+PORTNAME= gtk-qt4-engine
+PORTVERSION= 1.1
CATEGORIES= x11-themes
-MASTER_SITES= http://gtk-qt.ecs.soton.ac.uk/files/${PORTVERSION}/ \
- http://freebsd.ricin.com/ports/distfiles/
+MASTER_SITES= http://gtk-qt.ecs.soton.ac.uk/files/${PORTVERSION}/
+DISTFILES= gtk-qt-engine-${PORTVERSION}
-MAINTAINER= danny@ricin.com
+MAINTAINER= kris@pcbsd.org
COMMENT= GTK-QT Theme Engine allows GTK2 apps to use QT/KDE themes
USE_BZIP2= yes
USE_GETTEXT= yes
-USE_GMAKE= yes
USE_GNOME= gtk20
-USE_QT_VER= 3
-USE_KDEBASE_VER=3
-HAS_CONFIGURE= yes
+USE_QT_VER= 4
+QT_COMPONENTS= gui moc_build rcc_build uic_build qmake_build
USE_CMAKE= yes
+USE_KDE4= kdebase kdeprefix automoc4
OPTIONS= LIBBONOBOUI "Install libbonoboui if missing" off
-WRKSRC= ${WRKDIR}/${PORTNAME}
+WRKSRC= ${WRKDIR}/gtk-qt-engine
.include <bsd.port.pre.mk>
diff --git a/x11-themes/gtk-qt4-engine/distinfo b/x11-themes/gtk-qt4-engine/distinfo
index 8b2df70652b0..11078a5aef6f 100644
--- a/x11-themes/gtk-qt4-engine/distinfo
+++ b/x11-themes/gtk-qt4-engine/distinfo
@@ -1,3 +1,3 @@
-MD5 (gtk-qt-engine-0.8.tar.bz2) = 9fe75b7765b6a5b49901fcd6f4f4aa4b
-SHA256 (gtk-qt-engine-0.8.tar.bz2) = 6658bdbd3f2120d34f5c59b5bc3cfed5ef83a2aa8572d775483aa304396b0d45
-SIZE (gtk-qt-engine-0.8.tar.bz2) = 59472
+MD5 (gtk-qt-engine-1.1) = de8048baef7dfe6c97cd97c463d66152
+SHA256 (gtk-qt-engine-1.1) = 4310f8f179c5ab70cea614a07b0c3e84234d05388dded85596200fa754c290a6
+SIZE (gtk-qt-engine-1.1) = 58079
diff --git a/x11-themes/gtk-qt4-engine/files/patch-CMakeLists.txt b/x11-themes/gtk-qt4-engine/files/patch-CMakeLists.txt
deleted file mode 100644
index b744c10ad78a..000000000000
--- a/x11-themes/gtk-qt4-engine/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- CMakeLists.txt.orgi 2008-05-21 13:40:34.000000000 +0200
-+++ CMakeLists.txt 2008-05-21 13:41:09.000000000 +0200
-@@ -1,6 +1,8 @@
- PROJECT (gtk-qt-engine)
- INCLUDE (UsePkgConfig)
-
-+cmake_minimum_required(VERSION 2.4.8)
-+
- # Find KDE
- FIND_PACKAGE(KDE3 REQUIRED)
-
diff --git a/x11-themes/gtk-qt4-engine/files/patch-kcm_gtk__CMakeLists.txt b/x11-themes/gtk-qt4-engine/files/patch-kcm_gtk__CMakeLists.txt
new file mode 100644
index 000000000000..622bdc58c715
--- /dev/null
+++ b/x11-themes/gtk-qt4-engine/files/patch-kcm_gtk__CMakeLists.txt
@@ -0,0 +1,11 @@
+--- ./kcm_gtk/CMakeLists.txt.orig 2008-03-11 04:30:19.000000000 +0300
++++ ./kcm_gtk/CMakeLists.txt 2008-08-20 02:18:45.000000000 +0400
+@@ -16,7 +16,7 @@
+
+ KDE4_ADD_PLUGIN(kcm_gtk4 ${kcm_gtk4_SOURCES})
+
+-INCLUDE_DIRECTORIES(${KDE4_INCLUDE_DIR})
++INCLUDE_DIRECTORIES(BEFORE ${KDE4_INCLUDE_DIR})
+ LINK_DIRECTORIES(${KDE4_LIB_DIR})
+
+ TARGET_LINK_LIBRARIES(kcm_gtk4 ${KDE4_KDECORE_LIBRARY} ${KDE4_KDEUI_LIBRARY} ${QT_QTCORE_LIBRARY} ${QT_QTGUI_LIBRARY})
diff --git a/x11-themes/gtk-qt4-engine/pkg-descr b/x11-themes/gtk-qt4-engine/pkg-descr
index 57c143032b06..a042a33439ee 100644
--- a/x11-themes/gtk-qt4-engine/pkg-descr
+++ b/x11-themes/gtk-qt4-engine/pkg-descr
@@ -1,6 +1,6 @@
-GTK-QT Theme Engine allows GTK2 apps to use QT/KDE themes
-so that they fit in more nicely with KDE. Includes a KDE
-control center module for GTK theme selection.
+GTK-QT4 Theme Engine allows GTK2 apps to use QT/KDE themes
+so that they fit in more nicely with KDE. Includes a KDE4
+system settings module for GTK theme selection.
WWW: http://gtk-qt.ecs.soton.ac.uk/index.php
diff --git a/x11-themes/gtk-qt4-engine/pkg-plist b/x11-themes/gtk-qt4-engine/pkg-plist
index 2839c55702ac..1a46e39cb498 100644
--- a/x11-themes/gtk-qt4-engine/pkg-plist
+++ b/x11-themes/gtk-qt4-engine/pkg-plist
@@ -1,8 +1,8 @@
-lib/gtk-2.0/%%GTK2_VERSION%%/engines/libqtengine.so
-lib/kde3/kcm_kcmgtk.la
-lib/kde3/kcm_kcmgtk.so
-share/applications/kcmgtk.desktop
+lib/kde4/kcm_gtk4.so
+share/applications/kde4/kcmgtk4.desktop
+share/icons/kcmgtk.png
share/locale/bg/LC_MESSAGES/gtkqtengine.mo
+share/locale/cs/LC_MESSAGES/gtkqtengine.mo
share/locale/de/LC_MESSAGES/gtkqtengine.mo
share/locale/es/LC_MESSAGES/gtkqtengine.mo
share/locale/fr/LC_MESSAGES/gtkqtengine.mo
@@ -11,12 +11,13 @@ share/locale/nn/LC_MESSAGES/gtkqtengine.mo
share/locale/ru/LC_MESSAGES/gtkqtengine.mo
share/locale/sv/LC_MESSAGES/gtkqtengine.mo
share/locale/tr/LC_MESSAGES/gtkqtengine.mo
-share/themes/Qt/gtk-2.0/gtkrc
-@dirrm share/themes/Qt/gtk-2.0
-@dirrm share/themes/Qt
-@dirrmtry share/themes
-@dirrmtry share/applications
-@dirrmtry lib/kde3
+@dirrmtry share/applications/kde4
+@dirrmtry lib/kde4
+@cwd %%LOCALBASE%%
+lib/gtk-2.0/%%GTK2_VERSION%%/engines/libqt4engine.so
+share/themes/Qt4/gtk-2.0/gtkrc
+@dirrm share/themes/Qt4/gtk-2.0
+@dirrm share/themes/Qt4
@dirrmtry lib/gtk-2.0/%%GTK2_VERSION%%/engines
@dirrmtry lib/gtk-2.0/%%GTK2_VERSION%%
@dirrmtry lib/gtk-2.0