aboutsummaryrefslogtreecommitdiff
path: root/x11-themes
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-04-04 07:53:18 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-04-04 07:53:18 +0000
commit6d6bbc2970b369f625318989ca23683ae67be9a7 (patch)
tree0d62eaf25fec82bfb17d06e4f149395e9e372513 /x11-themes
parent46b82b34008265593881bcf108f35296a6cd3545 (diff)
downloadports-6d6bbc2970b369f625318989ca23683ae67be9a7.tar.gz
ports-6d6bbc2970b369f625318989ca23683ae67be9a7.zip
Notes
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gnome-themes/Makefile8
-rw-r--r--x11-themes/gnome-themes/distinfo2
-rw-r--r--x11-themes/gnome-themes/files/patch-configure83
3 files changed, 87 insertions, 6 deletions
diff --git a/x11-themes/gnome-themes/Makefile b/x11-themes/gnome-themes/Makefile
index 8888d0c79b9f..6bdb1fd624e3 100644
--- a/x11-themes/gnome-themes/Makefile
+++ b/x11-themes/gnome-themes/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnome-themes
-PORTVERSION= 2.2
-PORTREVISION= 1
+PORTVERSION= 2.2.1
CATEGORIES= x11-toolkits gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.2
@@ -24,7 +23,12 @@ RUN_DEPENDS= ${X11BASE}/lib/gtk-2.0/2.2.0/engines/libthinice.so:${PORTSDIR}/x11-
USE_BZIP2= yes
USE_X_PREFIX= yes
+USE_REINPLACE= yes
USE_LIBTOOL= yes
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+post-patch:
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|noinst_PROGRAMS = |noinst_PROGRAMS = #|g'
+
.include <bsd.port.mk>
diff --git a/x11-themes/gnome-themes/distinfo b/x11-themes/gnome-themes/distinfo
index a0b32f0fe100..1437e8984b35 100644
--- a/x11-themes/gnome-themes/distinfo
+++ b/x11-themes/gnome-themes/distinfo
@@ -1 +1 @@
-MD5 (gnome2/gnome-themes-2.2.tar.bz2) = 18f9b8cea0469bf2ae934024c6f4fa9d
+MD5 (gnome2/gnome-themes-2.2.1.tar.bz2) = 55cdb9dc45256207e08d0654035c2b2a
diff --git a/x11-themes/gnome-themes/files/patch-configure b/x11-themes/gnome-themes/files/patch-configure
index 8afd3d20e32f..2a763b11ffe5 100644
--- a/x11-themes/gnome-themes/files/patch-configure
+++ b/x11-themes/gnome-themes/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Mon Feb 3 20:16:09 2003
-+++ configure Mon Feb 3 20:16:31 2003
-@@ -7640,6 +7640,7 @@
+--- configure.orig Wed Mar 12 07:49:35 2003
++++ configure Thu Mar 13 23:50:27 2003
+@@ -7641,6 +7641,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
@@ -8,3 +8,80 @@
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+@@ -7707,22 +7708,16 @@
+ echo "$as_me:$LINENO: checking for gtk+-2.0 >= 1.3.11
+ gdk-pixbuf-2.0 >= 1.3.11
+ gtk-engines-2
+- gtk-thinice-engine-2
+- libgnomeui-2.0
+- libglade-2.0" >&5
++ gtk-thinice-engine-2" >&5
+ echo $ECHO_N "checking for gtk+-2.0 >= 1.3.11
+ gdk-pixbuf-2.0 >= 1.3.11
+ gtk-engines-2
+- gtk-thinice-engine-2
+- libgnomeui-2.0
+- libglade-2.0... $ECHO_C" >&6
++ gtk-thinice-engine-2... $ECHO_C" >&6
+
+ if $PKG_CONFIG --exists "gtk+-2.0 >= 1.3.11
+ gdk-pixbuf-2.0 >= 1.3.11
+ gtk-engines-2
+- gtk-thinice-engine-2
+- libgnomeui-2.0
+- libglade-2.0" ; then
++ gtk-thinice-engine-2" ; then
+ echo "$as_me:$LINENO: result: yes" >&5
+ echo "${ECHO_T}yes" >&6
+ succeeded=yes
+@@ -7732,9 +7727,7 @@
+ GTKTHEME_CFLAGS=`$PKG_CONFIG --cflags "gtk+-2.0 >= 1.3.11
+ gdk-pixbuf-2.0 >= 1.3.11
+ gtk-engines-2
+- gtk-thinice-engine-2
+- libgnomeui-2.0
+- libglade-2.0"`
++ gtk-thinice-engine-2"`
+ echo "$as_me:$LINENO: result: $GTKTHEME_CFLAGS" >&5
+ echo "${ECHO_T}$GTKTHEME_CFLAGS" >&6
+
+@@ -7743,9 +7736,7 @@
+ GTKTHEME_LIBS=`$PKG_CONFIG --libs "gtk+-2.0 >= 1.3.11
+ gdk-pixbuf-2.0 >= 1.3.11
+ gtk-engines-2
+- gtk-thinice-engine-2
+- libgnomeui-2.0
+- libglade-2.0"`
++ gtk-thinice-engine-2"`
+ echo "$as_me:$LINENO: result: $GTKTHEME_LIBS" >&5
+ echo "${ECHO_T}$GTKTHEME_LIBS" >&6
+ else
+@@ -7756,9 +7747,7 @@
+ GTKTHEME_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "gtk+-2.0 >= 1.3.11
+ gdk-pixbuf-2.0 >= 1.3.11
+ gtk-engines-2
+- gtk-thinice-engine-2
+- libgnomeui-2.0
+- libglade-2.0"`
++ gtk-thinice-engine-2"`
+ echo $GTKTHEME_PKG_ERRORS
+ fi
+
+@@ -7776,15 +7765,11 @@
+ { { echo "$as_me:$LINENO: error: Library requirements (gtk+-2.0 >= 1.3.11
+ gdk-pixbuf-2.0 >= 1.3.11
+ gtk-engines-2
+- gtk-thinice-engine-2
+- libgnomeui-2.0
+- libglade-2.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them." >&5
++ gtk-thinice-engine-2) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them." >&5
+ echo "$as_me: error: Library requirements (gtk+-2.0 >= 1.3.11
+ gdk-pixbuf-2.0 >= 1.3.11
+ gtk-engines-2
+- gtk-thinice-engine-2
+- libgnomeui-2.0
+- libglade-2.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them." >&2;}
++ gtk-thinice-engine-2) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them." >&2;}
+ { (exit 1); exit 1; }; }
+ fi
+