aboutsummaryrefslogtreecommitdiff
path: root/x11-themes
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-06-25 21:07:58 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-06-25 21:07:58 +0000
commit5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf (patch)
tree3291541f3b73432c893dec35f4f23770dd07732a /x11-themes
parent9c92503171817f96d944009b9ea88d3c083c9a45 (diff)
downloadports-5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf.tar.gz
ports-5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf.zip
Make ninja opt-out in cmake.mk
Using ninja instead of make (1) can lead to significant speed ups while building. Therefore switch from having the ninja generator opt-in to having it opt-out. Previously cmake-ports that wanted to use ninja could set CMAKE_NINJA=yes now, ports that do not work with ninja can set cmake:<existing args>,noninja Note, that needing this should be an exception and most often points to a broken cmake of the port. The ports using cmake were modified * removed USES=gmake, if ninja is used * removed MAKE_ARGS, if ninja is used * added the cmake-argument noninja if necessary PR: 219629 PR: 213331 Exp-run by: antoine Reviewed by: rakuco Differential Revision: https://reviews.freebsd.org/D10748
Notes
Notes: svn path=/head/; revision=444324
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/kde4-style-bespin/Makefile2
-rw-r--r--x11-themes/kde4-windeco-crystal/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/x11-themes/kde4-style-bespin/Makefile b/x11-themes/kde4-style-bespin/Makefile
index c2f588fb0fdc..a11d40ec971b 100644
--- a/x11-themes/kde4-style-bespin/Makefile
+++ b/x11-themes/kde4-style-bespin/Makefile
@@ -16,7 +16,7 @@ LICENSE= LGPL21
WRKSRC= ${WRKDIR}/cloudcity
-USES= cmake kde:4
+USES= cmake:noninja kde:4
USE_KDE= kdelibs automoc4 workspace
USE_QT4= corelib qmake_build moc_build rcc_build uic_build
diff --git a/x11-themes/kde4-windeco-crystal/Makefile b/x11-themes/kde4-windeco-crystal/Makefile
index cf0696a679c9..a71ebc9a4e43 100644
--- a/x11-themes/kde4-windeco-crystal/Makefile
+++ b/x11-themes/kde4-windeco-crystal/Makefile
@@ -14,7 +14,7 @@ COMMENT= Transparent KDE window decoration
LICENSE= GPLv2
-USES= cmake:outsource kde:4 tar:bzip2
+USES= cmake:outsource,noninja kde:4 tar:bzip2
USE_KDE= kdelibs automoc4 workspace
USE_QT4= qmake_build moc_build rcc_build uic_build \
corelib gui qt3support