aboutsummaryrefslogtreecommitdiff
path: root/x11-themes
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-04-17 21:04:26 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-04-17 21:04:26 +0000
commit744e24490c6971f22a1a07d68fc85eb5d3a0589f (patch)
tree1a89cb626f039b2b4c39a60155e965d50ae35875 /x11-themes
parentde23b4ec725bbaaed8fb4a83ff16afddc3083cf4 (diff)
downloadports-744e24490c6971f22a1a07d68fc85eb5d3a0589f.tar.gz
ports-744e24490c6971f22a1a07d68fc85eb5d3a0589f.zip
Notes
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gnome-splashscreen-manager/Makefile13
-rw-r--r--x11-themes/gnome-splashscreen-manager/files/patch-lib_gnome-splashscreen-manager_gnome_splashscreen_manager.rb11
2 files changed, 23 insertions, 1 deletions
diff --git a/x11-themes/gnome-splashscreen-manager/Makefile b/x11-themes/gnome-splashscreen-manager/Makefile
index c950790751a7..8837f572a1b3 100644
--- a/x11-themes/gnome-splashscreen-manager/Makefile
+++ b/x11-themes/gnome-splashscreen-manager/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnome-splashscreen-manager
PORTVERSION= 0.1
+PORTREVISION= 1
CATEGORIES= x11-themes
MASTER_SITES= http://www.miketech.net/gnome-art/download/
DISTNAME= gnome-art-${PORTVERSION}
@@ -14,7 +15,8 @@ DISTNAME= gnome-art-${PORTVERSION}
MAINTAINER= ahze@FreeBSD.org
COMMENT= Gnome splash screen manager
-BUILD_DEPENDS= ruby-glade-create-template:${PORTSDIR}/devel/ruby-libglade2 \
+BUILD_DEPENDS= gnome-session:${PORTSDIR}/x11/gnomesession \
+ ruby-glade-create-template:${PORTSDIR}/devel/ruby-libglade2 \
${RUBY_SITEARCHLIBDIR}/gnome2.so:${PORTSDIR}/x11/ruby-gnome2 \
${RUBY_SITEARCHLIBDIR}/gconf2.so:${PORTSDIR}/devel/ruby-gconf2
RUN_DEPENDS= ${BUILD_DEPENDS}
@@ -23,8 +25,17 @@ WRKSRC= ${WRKDIR}/gnome-art/${PORTNAME}
USE_RUBY= yes
USE_REINPLACE= yes
USE_RUBY_SETUP= yes
+GSPLASH= ${X11BASE}/share/gnome/pixmaps/splash
post-patch:
+ cd ${WRKSRC}/lib/gnome-splashscreen-manager/ && \
+ for file in `${FIND} ${GSPLASH} -type f` ; do \
+ ${SED} -e 's|%%SPLASHSCREENS%%|\\n<splash_screen>\\n\\t<name>%%F%%</name>\\n\\t<filename>%%F%%</filename>\\n\\t<description>...</description>\\n\\t<author>?</author>\\n\\t<license>unknown</license>\\n</splash_screen>\\n%%SPLASHSCREENS%%|' \
+ < gnome_splashscreen_manager.rb > gnome_splashscreen_manager.rb.bak ; \
+ ${SED} -e "s|%%F%%|$${file}|g" < gnome_splashscreen_manager.rb.bak > gnome_splashscreen_manager.rb ; \
+ done
+ @${REINPLACE_CMD} -e 's|%%SPLASHSCREENS%%||' \
+ ${WRKSRC}/lib/gnome-splashscreen-manager/gnome_splashscreen_manager.rb
@${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share|' \
${WRKSRC}/lib/gnome-splashscreen-manager/ui/main_window.rb
@${FIND} ${WRKSRC} -name '*.bak' -delete
diff --git a/x11-themes/gnome-splashscreen-manager/files/patch-lib_gnome-splashscreen-manager_gnome_splashscreen_manager.rb b/x11-themes/gnome-splashscreen-manager/files/patch-lib_gnome-splashscreen-manager_gnome_splashscreen_manager.rb
new file mode 100644
index 000000000000..d3ea180a1e06
--- /dev/null
+++ b/x11-themes/gnome-splashscreen-manager/files/patch-lib_gnome-splashscreen-manager_gnome_splashscreen_manager.rb
@@ -0,0 +1,11 @@
+--- lib/gnome-splashscreen-manager/gnome_splashscreen_manager.rb.orig Sun Apr 17 02:02:05 2005
++++ lib/gnome-splashscreen-manager/gnome_splashscreen_manager.rb Sun Apr 17 02:06:02 2005
+@@ -41,7 +41,7 @@
+ puts "Create SplashScreen-File"
+ splash_screens_file = File.new(file, File::CREAT|File::TRUNC|File::RDWR, 0644)
+
+- new_splash_screens_file = "<?xml version=\"1.0\"?>\n<splash_screens>\n</splash_screens>\n"
++ new_splash_screens_file = "<?xml version=\"1.0\"?>\n<splash_screens>\n%%SPLASHSCREENS%%\n<splash_screens>\n</splash_screens>\n"
+
+ splash_screens_file.write(new_splash_screens_file)
+