aboutsummaryrefslogtreecommitdiff
path: root/x11-themes
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-04-05 07:46:20 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-04-05 07:46:20 +0000
commit77c16dc2bbc6841cf1d5cd74b176a3144fba0052 (patch)
tree50796f02864bf5a2a6138aab221046b51a10f718 /x11-themes
parent5c1200fcd6e8901f93ddae5d9f638a6379536047 (diff)
downloadports-77c16dc2bbc6841cf1d5cd74b176a3144fba0052.tar.gz
ports-77c16dc2bbc6841cf1d5cd74b176a3144fba0052.zip
Notes
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/kde4-windeco-crystal/files/patch-CMakeLists.txt27
-rw-r--r--x11-themes/kde4-windeco-crystal/files/patch-client_CMakeLists.txt13
-rw-r--r--x11-themes/kde4-windeco-crystal/files/patch-client_config_CMakeLists.txt13
3 files changed, 53 insertions, 0 deletions
diff --git a/x11-themes/kde4-windeco-crystal/files/patch-CMakeLists.txt b/x11-themes/kde4-windeco-crystal/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..490b483265f3
--- /dev/null
+++ b/x11-themes/kde4-windeco-crystal/files/patch-CMakeLists.txt
@@ -0,0 +1,27 @@
+First hunk:
+ Include KDE4Workspace cmake magic so that KDE4WORKSPACE_KDECORATIONS_LIBS gets defined.
+
+Second hunk:
+ CMP0005 Preprocessor definition values are now escaped automatically.
+ https://cmake.org/cmake/help/v3.0/policy/CMP0005.html
+
+--- CMakeLists.txt.orig 2017-03-29 09:58:52 UTC
++++ CMakeLists.txt
+@@ -3,6 +3,7 @@ project(KWIN_CRYSTAL)
+ set(VERSION 2.2.1)
+
+ find_package(KDE4 REQUIRED)
++find_package(KDE4Workspace REQUIRED)
+
+ include (CPack)
+ include (MacroLibrary)
+@@ -42,7 +43,8 @@ include (KDE4Defaults)
+
+ ########### global ###############
+
+-add_definitions (${QT_DEFINITIONS} ${KDE4_DEFINITIONS} -DHAVE_CONFIG_H=1 -DVERSION=\\"${VERSION}\\")
++cmake_policy(SET CMP0005 NEW)
++add_definitions (${QT_DEFINITIONS} ${KDE4_DEFINITIONS} -DHAVE_CONFIG_H=1 -DVERSION="${VERSION}")
+ include_directories (${KDE4_INCLUDES} ${CMAKE_SOURCE_DIR} ${CMAKE_BINARY_DIR})
+
+ include_directories(
diff --git a/x11-themes/kde4-windeco-crystal/files/patch-client_CMakeLists.txt b/x11-themes/kde4-windeco-crystal/files/patch-client_CMakeLists.txt
new file mode 100644
index 000000000000..62ba741a236b
--- /dev/null
+++ b/x11-themes/kde4-windeco-crystal/files/patch-client_CMakeLists.txt
@@ -0,0 +1,13 @@
+Use the variables defined by the KDE4 cmake files to link against kdecorations.
+
+--- client/CMakeLists.txt.orig 2017-03-29 09:58:23 UTC
++++ client/CMakeLists.txt
+@@ -77,7 +77,7 @@ set(kwin3_crystal_PART_SRCS
+ )
+
+ kde4_add_plugin(kwin3_crystal ${kwin3_crystal_PART_SRCS})
+-target_link_libraries(kwin3_crystal ${KDE4_KDEUI_LIBS} kdecorations )
++target_link_libraries(kwin3_crystal ${KDE4_KDEUI_LIBS} ${KDE4WORKSPACE_KDECORATIONS_LIBS} )
+
+ install(TARGETS kwin3_crystal DESTINATION ${PLUGIN_INSTALL_DIR} )
+ install( FILES crystal.desktop DESTINATION ${DATA_INSTALL_DIR}/kwin/ )
diff --git a/x11-themes/kde4-windeco-crystal/files/patch-client_config_CMakeLists.txt b/x11-themes/kde4-windeco-crystal/files/patch-client_config_CMakeLists.txt
new file mode 100644
index 000000000000..dbf025063209
--- /dev/null
+++ b/x11-themes/kde4-windeco-crystal/files/patch-client_config_CMakeLists.txt
@@ -0,0 +1,13 @@
+Use the variables defined by the KDE4 cmake files to link against kio and kdeui.
+
+--- client/config/CMakeLists.txt.orig 2017-03-29 09:58:23 UTC
++++ client/config/CMakeLists.txt
+@@ -12,7 +12,7 @@ kde4_add_plugin(kwin_crystal_config ${kwin_crystal_con
+
+
+
+-target_link_libraries(kwin_crystal_config kdeui kio ${KDE4_KDEUI_LIBS} ${QT_QTGUI_LIBRARY} ${QT_QT3SUPPORT_LIBRARY})
++target_link_libraries(kwin_crystal_config ${KDE4_KIO_LIBS} ${KDE4_KDEUI_LIBS} ${QT_QTGUI_LIBRARY} ${QT_QT3SUPPORT_LIBRARY})
+
+ install(TARGETS kwin_crystal_config DESTINATION ${PLUGIN_INSTALL_DIR} )
+