aboutsummaryrefslogtreecommitdiff
path: root/x11-themes
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-06-03 04:49:02 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-06-03 04:49:02 +0000
commitdda4a694f062105b3f9458543aeba24af8fd0c91 (patch)
tree5953f9d4db215780fa8933c5f5cb3a76e53a6a17 /x11-themes
parenta4eb231d9e019fa99892798566eee6d89670476b (diff)
downloadports-dda4a694f062105b3f9458543aeba24af8fd0c91.tar.gz
ports-dda4a694f062105b3f9458543aeba24af8fd0c91.zip
Notes
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gtk-aquaextremesunken-theme/Makefile20
-rw-r--r--x11-themes/gtk-aquaextremesunken-theme/pkg-descr6
-rw-r--r--x11-themes/gtk-digital-cream-theme/Makefile22
-rw-r--r--x11-themes/gtk-digital-cream-theme/pkg-descr2
-rw-r--r--x11-themes/gtk-digital-harmony-theme/Makefile18
-rw-r--r--x11-themes/gtk-digital-harmony-theme/pkg-descr2
-rw-r--r--x11-themes/gtk-longhorninspirat-theme/Makefile22
-rw-r--r--x11-themes/gtk-longhorninspirat-theme/pkg-descr2
-rw-r--r--x11-themes/gtk-milk-theme/Makefile13
-rw-r--r--x11-themes/gtk-milk-theme/pkg-descr6
-rw-r--r--x11-themes/metacity-aquaextremesunken-theme/Makefile1
-rw-r--r--x11-themes/metacity-digital-cream-theme/Makefile1
-rw-r--r--x11-themes/metacity-digital-harmony-theme/Makefile1
-rw-r--r--x11-themes/metacity-longhorninspirat-theme/Makefile1
14 files changed, 47 insertions, 70 deletions
diff --git a/x11-themes/gtk-aquaextremesunken-theme/Makefile b/x11-themes/gtk-aquaextremesunken-theme/Makefile
index fc1461bbc840..1461afb64a78 100644
--- a/x11-themes/gtk-aquaextremesunken-theme/Makefile
+++ b/x11-themes/gtk-aquaextremesunken-theme/Makefile
@@ -11,15 +11,14 @@ PKGNAMESUFFIX= -theme
DISTNAME= AquaExtremeSunken
MAINTAINER= danfe@FreeBSD.org
-COMMENT= A port of AquaExtreme Sunken theme
+COMMENT= Port of AquaExtreme Sunken theme
-TYPE?= gtk
+NO_BUILD= yes
+TYPE?= gtk
THEME_NAME= ${DISTNAME}
-NO_BUILD= yes
-
-.if ${TYPE} == "gtk"
+.if ${TYPE} == gtk
THEME_DIR= ${PREFIX}/share/themes/${THEME_NAME}
PLIST_SUB+= GTK20="" METACITY="@comment "
USE_GNOME= gtk20
@@ -29,16 +28,15 @@ PLIST_SUB+= GTK20="@comment " METACITY=""
USE_GNOME= gnomehier
.endif
-NO_STAGE= yes
do-install:
- @${MKDIR} ${THEME_DIR}
-.if ${TYPE} == "gtk"
+ @${MKDIR} ${STAGEDIR}${THEME_DIR}
+.if ${TYPE} == gtk
cd ${WRKSRC} && ${FIND} gtk-2.0 | \
- ${CPIO} -pdu -R ${SHAREOWN}:${SHAREGRP} ${THEME_DIR}
- ${INSTALL_DATA} ${WRKSRC}/index.theme ${THEME_DIR}
+ ${CPIO} -pdu -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${THEME_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/index.theme ${STAGEDIR}${THEME_DIR}
.else
cd ${WRKSRC} && ${FIND} metacity-1 | \
- ${CPIO} -pdu -R ${SHAREOWN}:${SHAREGRP} ${THEME_DIR}
+ ${CPIO} -pdu -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${THEME_DIR}
.endif
.include <bsd.port.mk>
diff --git a/x11-themes/gtk-aquaextremesunken-theme/pkg-descr b/x11-themes/gtk-aquaextremesunken-theme/pkg-descr
index af96ae4e1e5d..a3c94731a8cf 100644
--- a/x11-themes/gtk-aquaextremesunken-theme/pkg-descr
+++ b/x11-themes/gtk-aquaextremesunken-theme/pkg-descr
@@ -1,4 +1,2 @@
-Port of AquaExtreme Sunken theme. Original work by Max Rudberg
-(http://www.maxthemes.com).
-
-WWW: http://www.users.monornet.hu/linux/
+Port of AquaExtreme Sunken theme. Original theme created by Max Rudberg
+(http://www.maxrudberg.com/).
diff --git a/x11-themes/gtk-digital-cream-theme/Makefile b/x11-themes/gtk-digital-cream-theme/Makefile
index 2a2190e11603..d3f13629f01d 100644
--- a/x11-themes/gtk-digital-cream-theme/Makefile
+++ b/x11-themes/gtk-digital-cream-theme/Makefile
@@ -11,16 +11,15 @@ PKGNAMESUFFIX= -theme
DISTNAME= Digital-Cream
MAINTAINER= danfe@FreeBSD.org
-COMMENT= Very neat and clean theme for GNOME desktop
+COMMENT= Neat and clean theme for GNOME desktop
-TYPE?= gtk
+USES= tar:bzip2
+NO_BUILD= yes
+TYPE?= gtk
THEME_NAME= ${DISTNAME}
-USE_BZIP2= yes
-NO_BUILD= yes
-
-.if ${TYPE} == "gtk"
+.if ${TYPE} == gtk
THEME_DIR= ${PREFIX}/share/themes/${THEME_NAME}
PLIST_SUB+= GTK20="" METACITY="@comment "
USE_GNOME= gtk20
@@ -30,19 +29,18 @@ PLIST_SUB+= GTK20="@comment " METACITY=""
USE_GNOME= gnomehier
.endif
-NO_STAGE= yes
post-extract:
@${FIND} ${WRKSRC} -type f -print0 | ${XARGS} -0 ${CHMOD} 644
do-install:
- @${MKDIR} ${THEME_DIR}
- ${INSTALL_DATA} ${WRKSRC}/index.theme ${THEME_DIR}
-.if ${TYPE} == "gtk"
+ @${MKDIR} ${STAGEDIR}${THEME_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/index.theme ${STAGEDIR}${THEME_DIR}
+.if ${TYPE} == gtk
cd ${WRKSRC} && ${FIND} gtk-2.0 -name '*[^~]' | \
- ${CPIO} -pdu -R ${SHAREOWN}:${SHAREGRP} ${THEME_DIR}
+ ${CPIO} -pdu -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${THEME_DIR}
.else
cd ${WRKSRC} && ${FIND} metacity-1 -name '*[^~]' | \
- ${CPIO} -pdu -R ${SHAREOWN}:${SHAREGRP} ${THEME_DIR}
+ ${CPIO} -pdu -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${THEME_DIR}
.endif
.include <bsd.port.mk>
diff --git a/x11-themes/gtk-digital-cream-theme/pkg-descr b/x11-themes/gtk-digital-cream-theme/pkg-descr
index 635e50734d80..4f7f559712c8 100644
--- a/x11-themes/gtk-digital-cream-theme/pkg-descr
+++ b/x11-themes/gtk-digital-cream-theme/pkg-descr
@@ -1,3 +1 @@
Neat and clean theme for GNOME desktop by roberTO.
-
-WWW: http://www.users.monornet.hu/linux/
diff --git a/x11-themes/gtk-digital-harmony-theme/Makefile b/x11-themes/gtk-digital-harmony-theme/Makefile
index 9c3830ce47f8..f178e6f55f23 100644
--- a/x11-themes/gtk-digital-harmony-theme/Makefile
+++ b/x11-themes/gtk-digital-harmony-theme/Makefile
@@ -13,13 +13,12 @@ DISTNAME= Digital-Harmony
MAINTAINER= danfe@FreeBSD.org
COMMENT= Another popular theme for GNOME desktop
-TYPE?= gtk
+NO_BUILD= yes
+TYPE?= gtk
THEME_NAME= ${DISTNAME}
-NO_BUILD= yes
-
-.if ${TYPE} == "gtk"
+.if ${TYPE} == gtk
THEME_DIR= ${PREFIX}/share/themes/${THEME_NAME}
PLIST_SUB+= GTK20="" METACITY="@comment "
USE_GNOME= gtk20
@@ -29,21 +28,20 @@ PLIST_SUB+= GTK20="@comment " METACITY=""
USE_GNOME= gnomehier
.endif
-NO_STAGE= yes
post-extract:
@${RM} -rf ${WRKSRC}/gtk-2.0/Scrollbars/Backup \
${WRKSRC}/gtk-2.0/ReadME.txt
@${FIND} ${WRKSRC} -type f -print0 | ${XARGS} -0 ${CHMOD} 644
do-install:
- @${MKDIR} ${THEME_DIR}
- ${INSTALL_DATA} ${WRKSRC}/index.theme ${THEME_DIR}
-.if ${TYPE} == "gtk"
+ @${MKDIR} ${STAGEDIR}${THEME_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/index.theme ${STAGEDIR}${THEME_DIR}
+.if ${TYPE} == gtk
cd ${WRKSRC} && ${FIND} gtk-2.0 | \
- ${CPIO} -pdu -R ${SHAREOWN}:${SHAREGRP} ${THEME_DIR}
+ ${CPIO} -pdu -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${THEME_DIR}
.else
cd ${WRKSRC} && ${FIND} metacity-1 | \
- ${CPIO} -pdu -R ${SHAREOWN}:${SHAREGRP} ${THEME_DIR}
+ ${CPIO} -pdu -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${THEME_DIR}
.endif
.include <bsd.port.mk>
diff --git a/x11-themes/gtk-digital-harmony-theme/pkg-descr b/x11-themes/gtk-digital-harmony-theme/pkg-descr
index fb84847438a8..b2551283fa56 100644
--- a/x11-themes/gtk-digital-harmony-theme/pkg-descr
+++ b/x11-themes/gtk-digital-harmony-theme/pkg-descr
@@ -1,3 +1 @@
This is yet another popular GNOME desktop theme by roberTO.
-
-WWW: http://www.users.monornet.hu/linux/
diff --git a/x11-themes/gtk-longhorninspirat-theme/Makefile b/x11-themes/gtk-longhorninspirat-theme/Makefile
index 521843d86938..ab606f04e44a 100644
--- a/x11-themes/gtk-longhorninspirat-theme/Makefile
+++ b/x11-themes/gtk-longhorninspirat-theme/Makefile
@@ -11,17 +11,16 @@ PKGNAMESUFFIX= -theme
DISTNAME= Longhorn_Inspirat
MAINTAINER= danfe@FreeBSD.org
-COMMENT= A port of Windows XP theme Longhorn Inspirat
+COMMENT= Port of Windows XP theme Longhorn Inspirat
-TYPE?= gtk
+USES= tar:bzip2
+NO_BUILD= yes
+TYPE?= gtk
THEME_NAME= "${DISTNAME:S/_/ /}"
WRKSRC= ${WRKDIR}/${THEME_NAME}
-USE_BZIP2= yes
-NO_BUILD= yes
-
-.if ${TYPE} == "gtk"
+.if ${TYPE} == gtk
THEME_DIR= ${PREFIX}/share/themes/${THEME_NAME}
PLIST_SUB+= GTK20="" METACITY="@comment "
USE_GNOME= gtk20
@@ -31,20 +30,19 @@ PLIST_SUB+= GTK20="@comment " METACITY=""
USE_GNOME= gnomehier
.endif
-NO_STAGE= yes
post-extract:
@${FIND} ${WRKSRC} -type f -print0 | ${XARGS} -0 ${CHMOD} 644
@${RM} -r ${WRKSRC}/gtk-2.0/.Trash-roberto
do-install:
- @${MKDIR} ${THEME_DIR}
- ${INSTALL_DATA} ${WRKSRC}/index.theme ${THEME_DIR}
-.if ${TYPE} == "gtk"
+ @${MKDIR} ${STAGEDIR}${THEME_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/index.theme ${STAGEDIR}${THEME_DIR}
+.if ${TYPE} == gtk
cd ${WRKSRC} && ${FIND} gtk-2.0 | \
- ${CPIO} -pdu -R ${SHAREOWN}:${SHAREGRP} ${THEME_DIR}
+ ${CPIO} -pdu -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${THEME_DIR}
.else
cd ${WRKSRC} && ${FIND} metacity-1 | \
- ${CPIO} -pdu -R ${SHAREOWN}:${SHAREGRP} ${THEME_DIR}
+ ${CPIO} -pdu -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${THEME_DIR}
.endif
.include <bsd.port.mk>
diff --git a/x11-themes/gtk-longhorninspirat-theme/pkg-descr b/x11-themes/gtk-longhorninspirat-theme/pkg-descr
index ae2aeba3d87c..2487e9ad225e 100644
--- a/x11-themes/gtk-longhorninspirat-theme/pkg-descr
+++ b/x11-themes/gtk-longhorninspirat-theme/pkg-descr
@@ -1,4 +1,2 @@
Port of Longhorn Inspirat theme, originally created by Stefanka for
Windows XP.
-
-WWW: http://www.users.monornet.hu/linux/
diff --git a/x11-themes/gtk-milk-theme/Makefile b/x11-themes/gtk-milk-theme/Makefile
index 0702fc98b632..0bffd49b5174 100644
--- a/x11-themes/gtk-milk-theme/Makefile
+++ b/x11-themes/gtk-milk-theme/Makefile
@@ -12,16 +12,15 @@ PKGNAMESUFFIX= -theme
DISTNAME= Milk-${PORTVERSION}
MAINTAINER= danfe@FreeBSD.org
-COMMENT= A port of Milk, Mac OS X theme
-
-TYPE?= gtk
-
-THEME_NAME= Milk
+COMMENT= Port of Milk, Mac OS X theme
USES= tar:bzip2
NO_BUILD= yes
-.if ${TYPE} == "gtk"
+TYPE?= gtk
+THEME_NAME= Milk
+
+.if ${TYPE} == gtk
THEME_DIR= ${PREFIX}/share/themes/${THEME_NAME}
PLIST_SUB+= GTK20="" METACITY="@comment "
USE_GNOME= gtk20
@@ -37,7 +36,7 @@ post-extract:
do-install:
@${MKDIR} ${STAGEDIR}${THEME_DIR}
${INSTALL_DATA} ${WRKSRC}/index.theme ${STAGEDIR}${THEME_DIR}
-.if ${TYPE} == "gtk"
+.if ${TYPE} == gtk
cd ${WRKSRC} && ${COPYTREE_SHARE} gtk-2.0 ${STAGEDIR}${THEME_DIR}
.else
cd ${WRKSRC} && ${COPYTREE_SHARE} metacity-1 ${STAGEDIR}${THEME_DIR}
diff --git a/x11-themes/gtk-milk-theme/pkg-descr b/x11-themes/gtk-milk-theme/pkg-descr
index 9a539f729052..3ae7b3333394 100644
--- a/x11-themes/gtk-milk-theme/pkg-descr
+++ b/x11-themes/gtk-milk-theme/pkg-descr
@@ -1,4 +1,2 @@
-Port of a Milk, Mac OS X theme originally made by Max Rudberg
-(http://www.maxthemes.com).
-
-WWW: http://www.users.monornet.hu/linux/
+Port of a Milk, Mac OS X theme originally created by Max Rudberg
+(http://www.maxrudberg.com/).
diff --git a/x11-themes/metacity-aquaextremesunken-theme/Makefile b/x11-themes/metacity-aquaextremesunken-theme/Makefile
index 15269e62fc3f..f168e8a3872d 100644
--- a/x11-themes/metacity-aquaextremesunken-theme/Makefile
+++ b/x11-themes/metacity-aquaextremesunken-theme/Makefile
@@ -4,5 +4,4 @@
TYPE= metacity
MASTERDIR= ${.CURDIR}/../gtk-aquaextremesunken-theme
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/x11-themes/metacity-digital-cream-theme/Makefile b/x11-themes/metacity-digital-cream-theme/Makefile
index 3e454bd4f611..a598c1862398 100644
--- a/x11-themes/metacity-digital-cream-theme/Makefile
+++ b/x11-themes/metacity-digital-cream-theme/Makefile
@@ -4,5 +4,4 @@
TYPE= metacity
MASTERDIR= ${.CURDIR}/../gtk-digital-cream-theme
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/x11-themes/metacity-digital-harmony-theme/Makefile b/x11-themes/metacity-digital-harmony-theme/Makefile
index 95bf5c6920ff..96efe00a1f52 100644
--- a/x11-themes/metacity-digital-harmony-theme/Makefile
+++ b/x11-themes/metacity-digital-harmony-theme/Makefile
@@ -4,5 +4,4 @@
TYPE= metacity
MASTERDIR= ${.CURDIR}/../gtk-digital-harmony-theme
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/x11-themes/metacity-longhorninspirat-theme/Makefile b/x11-themes/metacity-longhorninspirat-theme/Makefile
index cd57fae792e7..93d34deafb7b 100644
--- a/x11-themes/metacity-longhorninspirat-theme/Makefile
+++ b/x11-themes/metacity-longhorninspirat-theme/Makefile
@@ -4,5 +4,4 @@
TYPE= metacity
MASTERDIR= ${.CURDIR}/../gtk-longhorninspirat-theme
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"