aboutsummaryrefslogtreecommitdiff
path: root/x11-themes
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-04-16 00:40:58 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-04-16 00:40:58 +0000
commitb2152e9b0398ede16ed1f465080d0c593ef8ae3c (patch)
treeedc3f7c341606437ab340d48cc3028dc889dc13c /x11-themes
parentb8cbe9f50ef1d78f44725236c06fbd57bf505f9f (diff)
downloadports-b2152e9b0398ede16ed1f465080d0c593ef8ae3c.tar.gz
ports-b2152e9b0398ede16ed1f465080d0c593ef8ae3c.zip
Notes
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/Makefile1
-rw-r--r--x11-themes/gnome-art/Makefile31
-rw-r--r--x11-themes/gnome-art/distinfo2
-rw-r--r--x11-themes/gnome-art/pkg-descr13
-rw-r--r--x11-themes/gnome-art/pkg-plist18
5 files changed, 65 insertions, 0 deletions
diff --git a/x11-themes/Makefile b/x11-themes/Makefile
index 6f9d3804ca46..78ba8e81eada 100644
--- a/x11-themes/Makefile
+++ b/x11-themes/Makefile
@@ -22,6 +22,7 @@
SUBDIR += fluxbox-sid-pack
SUBDIR += fvwm-themes
SUBDIR += geramik
+ SUBDIR += gnome-art
SUBDIR += gnome-backgrounds
SUBDIR += gnome-icons
SUBDIR += gnome-icons-aqua-fusion
diff --git a/x11-themes/gnome-art/Makefile b/x11-themes/gnome-art/Makefile
new file mode 100644
index 000000000000..37b2b789d34c
--- /dev/null
+++ b/x11-themes/gnome-art/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: gnome-art
+# Date created: 2005-04-15
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnome-art
+PORTVERSION= 0.1
+CATEGORIES= x11-themes
+MASTER_SITES= http://www.miketech.net/gnome-art/download/
+
+MAINTAINER= ahze@FreeBSD.org
+COMMENT= Frontend for art.gnome.org
+
+BUILD_DEPENDS= ruby-glade-create-template:${PORTSDIR}/devel/ruby-libglade2 \
+ ${RUBY_SITEARCHLIBDIR}/gnome2.so:${PORTSDIR}/x11/ruby-gnome2
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}/${PORTNAME}
+USE_RUBY= yes
+USE_REINPLACE= yes
+USE_RUBY_SETUP= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share|' \
+ ${WRKSRC}/lib/gnome-art/ui/main_window.rb \
+ ${WRKSRC}/lib/gnome-art/ui/download_dialog.rb
+ @${FIND} ${WRKSRC} -name '*.bak' -delete
+
+.include <bsd.port.mk>
diff --git a/x11-themes/gnome-art/distinfo b/x11-themes/gnome-art/distinfo
new file mode 100644
index 000000000000..9d9149579f3a
--- /dev/null
+++ b/x11-themes/gnome-art/distinfo
@@ -0,0 +1,2 @@
+MD5 (gnome-art-0.1.tar.gz) = a3b42bab3c71cb958d27130c2de01617
+SIZE (gnome-art-0.1.tar.gz) = 63750
diff --git a/x11-themes/gnome-art/pkg-descr b/x11-themes/gnome-art/pkg-descr
new file mode 100644
index 000000000000..66a76285dae6
--- /dev/null
+++ b/x11-themes/gnome-art/pkg-descr
@@ -0,0 +1,13 @@
+A frontend for art.gnome.org
+
+The GNOME Art Collection written in ruby is a collection of tools for managing
+art from the art.gnome.org website. GNOME Art is the graphical frontend for
+art.gnome.org.
+
+Backgrounds and all themes can be downloaded and previewed.
+Backgrounds, icon themes and splash screens can be installed directly.
+
+GNOME Splash Screen Manager is for managing the splash screens of the GNOME
+desktop.
+
+WWW: http://www.miketech.net/gnome-art/
diff --git a/x11-themes/gnome-art/pkg-plist b/x11-themes/gnome-art/pkg-plist
new file mode 100644
index 000000000000..32e66ea6fee7
--- /dev/null
+++ b/x11-themes/gnome-art/pkg-plist
@@ -0,0 +1,18 @@
+bin/gnome-art
+%%DATADIR%%/glade/download_dialog.glade
+%%DATADIR%%/glade/download_dialog.gladep
+%%DATADIR%%/glade/gnome-graphics.png
+%%DATADIR%%/glade/gnome_art.glade
+%%DATADIR%%/glade/gnome_art.gladep
+%%DATADIR%%/glade/pixmaps/gnome-graphics.png
+%%RUBY_SITELIBDIR%%/gnome_art.rb
+%%RUBY_SITELIBDIR%%/gnome-art/config.rb
+%%RUBY_SITELIBDIR%%/gnome-art/get_art.rb
+%%RUBY_SITELIBDIR%%/gnome-art/gnome_art.rb
+%%RUBY_SITELIBDIR%%/gnome-art/ui/main_window.rb
+%%RUBY_SITELIBDIR%%/gnome-art/ui/download_dialog.rb
+@dirrm %%RUBY_SITELIBDIR%%/gnome-art/ui
+@dirrm %%RUBY_SITELIBDIR%%/gnome-art
+@dirrm %%DATADIR%%/glade/pixmaps
+@dirrm %%DATADIR%%/glade
+@dirrm %%DATADIR%%